forum.universal-devices.com

Welcome to UDI Forum
It is currently Thu Apr 24, 2014 9:58 am

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 26 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: few communication issues
PostPosted: Fri Sep 09, 2011 8:02 pm 
Offline

Joined: Tue May 31, 2011 12:26 pm
Posts: 4
Hello,
I have a couple of questions.
1. I recently replaced some devices that a were controlled by a keypadLinc 8. when I look at the device controller/responder info it looks as if it was OK. the keypadlinc button does not control them. they do work manually.
I did try the 'restore' feature a few times and it does not seem to work. it writes for a long time, like 10 of minutes.....
2. when I do make changes to the switches it seems to write to the devices for a long, long, long time. is that normal?

3. I recently had a power outage and one of my keypadLinc 8 reset back to a keypad 6 setup. I have tried to restore the device and it does not change it back to the 8 button setup. should that happen?

4. I seem to have to reset the 99i with a power unplug at times and not sure why it is hung. I do this after the java window will not pop up or the login window. not sure why but it seems very unstable.

Any suggestions would be great.
thanks,


Top
 Profile  
 
PostPosted: Fri Sep 23, 2011 6:36 am 
Offline
Advanced

Joined: Thu Nov 20, 2008 12:31 am
Posts: 286
One feature in the Admin Console that might be helpful in your diagnosis process is the Event Viewer.
When configured, the viewer will show all of the communication ISY sees when a specific action is initiated, like a device restore. The log can be reviewed by someone knowledgeable about Insteon communication to identify what may be causing a communication issue.

To use, navigate to Tools | Diagnostics | Event Viewer.
Specify "Device Communication Events" for the viewing level.
Clear any existing entries by pressing (Clear)
Leave the Event Viewer window open and set focus back on the main Admin Console Window.
Run a specific action you have an issue with
Look at the Event Viewer window and save the log information captured for the action.


Top
 Profile  
 
PostPosted: Fri Sep 23, 2011 11:24 am 
Offline
Advanced

Joined: Sat Sep 01, 2007 12:00 pm
Posts: 3189
Location: South East Connecticut
Did you add the new replacement and then use the replace function to remove the old device?


Top
 Profile  
 
PostPosted: Wed Nov 16, 2011 1:22 pm 
Offline

Joined: Sat May 23, 2009 2:20 pm
Posts: 14
So I am now having serious communication issues. I just bought a RemoteLinc2, so I updated to 3.1.10. After some minor problems, I got it figured out and working.

However since the update, and adding the RemoteLinc 2, and replacing a bad Switchlinc (because doing 3 things at once makes troubleshooting so much more fun), I am having massive communication issues. Switches that were working fine are no longer doing what they did yesterday, and My Lighting reports that it cannot communicate with 5-6 devices that were working fine before, and that I did not touch. I can still control the devices from My Lighting.

I do not know where to start.

I cleared the event log, and then tried to query a keypadlinc that is giving me problems, and then I tried to write to device. I get an error, cannot communicate with device.

Also, in trying to upload my event log, it tells me extension txt is not allowed.


Wed 11/16/2011 12:15:12 PM : [INST-ACK ] 02 62 01.1C.D1 0F 19 00 06 LTSREQ (LIGHT)

Wed 11/16/2011 12:15:12 PM : [INST-SRX ] 02 50 01.1C.D1 0F.D6.57 23 01 00 (00)

Wed 11/16/2011 12:15:12 PM : [ 1 1C D1 1] ST 0

Wed 11/16/2011 12:15:12 PM : [ 1 1C D1 1] OL 255

Wed 11/16/2011 12:15:12 PM : [INST-ACK ] 02 62 01.1C.D1 0F 19 01 06 LTSREQ (01)

Wed 11/16/2011 12:15:12 PM : [ 1 1C D1 1] RR 93

Wed 11/16/2011 12:15:21 PM : [INST-ACK ] 02 62 01.1C.D1 0F 19 01 06 LTSREQ (01)

Wed 11/16/2011 12:15:22 PM : [INST-SRX ] 02 50 01.1C.D1 0F.D6.57 23 01 D0 (D0)

Wed 11/16/2011 12:15:30 PM : [1 1C D1 1 ] Using engine version i1 for 'Hall by Master'

Wed 11/16/2011 12:15:30 PM : [1 1C D1 1 ] Link 0 : 0FF8 [A2071C27B1FF1F06] Writing [A2071C27B1FF1F06]

Wed 11/16/2011 12:15:30 PM : [INST-ACK ] 02 62 01.1C.D1 0F 28 0F 06 SET-MSB(0F)

Wed 11/16/2011 12:15:31 PM : [INST-SRX ] 02 50 01.1C.D1 0F.D6.57 23 28 0F SET-MSB(0F)

Wed 11/16/2011 12:15:31 PM : [INST-ACK ] 02 62 01.1C.D1 0F 2B F8 06 PEEK (F8)

Wed 11/16/2011 12:15:40 PM : [INST-ACK ] 02 62 01.1C.D1 0F 28 0F 06 SET-MSB(0F)

Wed 11/16/2011 12:15:49 PM : [INST-ACK ] 02 62 01.1C.D1 0F 28 0F 06 SET-MSB(0F)

Wed 11/16/2011 12:15:49 PM : [INST-SRX ] 02 50 01.1C.D1 0F.D6.57 23 28 0F SET-MSB(0F)

Wed 11/16/2011 12:15:49 PM : [INST-ACK ] 02 62 01.1C.D1 0F 2B F8 06 PEEK (F8)

Wed 11/16/2011 12:15:50 PM : [INST-SRX ] 02 50 01.1C.D1 0F.D6.57 23 2B A2 PEEK (A2)

Wed 11/16/2011 12:15:50 PM : [INST-ACK ] 02 62 01.1C.D1 0F 28 0F 06 SET-MSB(0F)

Wed 11/16/2011 12:15:59 PM : [INST-ACK ] 02 62 01.1C.D1 0F 28 0F 06 SET-MSB(0F)

Wed 11/16/2011 12:15:59 PM : [INST-SRX ] 02 50 01.1C.D1 0F.D6.57 23 28 0F SET-MSB(0F)

Wed 11/16/2011 12:15:59 PM : [INST-ACK ] 02 62 01.1C.D1 0F 2B F9 06 PEEK (F9)

Wed 11/16/2011 12:16:08 PM : [INST-ACK ] 02 62 01.1C.D1 0F 28 0F 06 SET-MSB(0F)

Wed 11/16/2011 12:16:12 PM : [1 1C D1 1 ] Link 0 : 0FF8 [A2071C27B1FF1F06] *Failed Writing [A2071C27B1FF1F06]


Top
 Profile  
 
PostPosted: Wed Nov 16, 2011 1:49 pm 
Offline
Advanced

Joined: Thu Jan 08, 2009 5:39 am
Posts: 9267
Device 01.1C.D1 is not responding to many of the commands issued by the ISY.

What is 01.1C.D1

Could be the device itself or something has happened to the phase coupling devices such as Access Points were moved to support the RemoteLinc2 or a new source of powerline interference has developed such as aging CFLs, or some new appliance.


Top
 Profile  
 
PostPosted: Wed Nov 16, 2011 2:49 pm 
Offline

Joined: Sat May 23, 2009 2:20 pm
Posts: 14
01.1C.D1 is the keypadlinc that is now not responding. It worked yesterday. I have many switches that are acting the same way. I find it hard to believe I had a bunch of switches that all went bad at once.

I did not move the access points because I knew that could be a source of problems. I had someone from Insteon come to my house and he told me where to put my access points. I have 3 and I will not move them.

I cannot think of anything else that has changed in my house. I do not use CFL's. No new appliances.

The problems all started when I did this upgrade to 3.1.10. I know that does not make sense either.

Any suggestions on where to start looking, or how to go about it? (I think I did not do a reset of the keypadlinc (01.1C.1D) since the problem started.)

One of the changes I made was to replace a switch. The new switch is not accepting commands from the ISY, however, like, the keypadlinc, I can control the keypadlinc, and the new switchlinc from My Lighting, even though I do not seem to be able to write to them.


Top
 Profile  
 
PostPosted: Wed Nov 16, 2011 3:32 pm 
Offline
Advanced

Joined: Thu Jan 08, 2009 5:39 am
Posts: 9267
I would check the wiring connections for the new switch. There are many other things that can interfere with powerline communication. Cell phone chargers, PC power supplies, flat screen TVs, just to mention a few. The approach is to unplug them (turning them off is not enough) and see if things improve. This is not an ISY 3.1.10 problem. The ISY is trying to write a link record to the KeypadLinc. It is the memory read commands that are failing some of the time. A command is issued and gets no response from the device. The same command is issued a little later and it works but a command that had been issued before that worked fails to get a response from the device the next time. Basic communication to the device is unreliable. If the new switch and the KeypadLinc are on the same circuit something about that circuit is suspect.

The difference between direct device control and updating the link record is the total number of commands that have to work. To turn the KeypadLinc On or Off requires a single command and Insteon hardware will retry that command several times. To update a link record requires a minimum of 9 commands, possibly 17 commands, to work for the update to complete successfully. Hard to get 9-17 commands to work compared to a single command when there is unreliable communication.


Top
 Profile  
 
PostPosted: Wed Nov 16, 2011 3:40 pm 
Offline

Joined: Sat May 23, 2009 2:20 pm
Posts: 14
Thank you. I will enlist the help of my son and I will unplug everything in the house and try again.

Is there a way to test for the communication problem as I start plugging things back in?


Top
 Profile  
 
PostPosted: Thu Nov 17, 2011 4:42 am 
Offline
Advanced

Joined: Fri Sep 19, 2008 7:50 pm
Posts: 2520
Location: Springfield OH
Quote:
Is there a way to test for the communication problem as I start plugging things back in?


The ISY offers the scene test as a tool to give one some clue about communication robustness. There are a few tricks to using it effectively, but I have found it to be pretty useful. The primary thing to remember is that if you have any programs enabled that could change the status of any device in your scene-under-test, temporarily disable these programs for the scene test.


Top
 Profile  
 
PostPosted: Thu Nov 17, 2011 11:16 pm 
Offline

Joined: Sat May 23, 2009 2:20 pm
Posts: 14
I am feeling pretty lost at this point. I tried unplugging everything in the house (other than the Insteon devices). Still serious problems. It did not make a difference.

I then reset my ISY. In the past, to do this, I just disconnected the network cables to it. This time I also unplugged the PLM. I think that was productive.

I can control any switch or device from My Lighting. I am not getting the communication errors I was (I think). I can query. I can restore and write to device.

However, no switch in my house will control any other switch. I have about 37 Insteon devices and instantly, no switch will control another. Also, the timed programs no longer run. I can still control scenes and switches with an IR command, and the ControlLinc, and RemoteLinc 2. Other than that, I have no control.

I can tap-tap to link the switches, but then what is the point of the ISY.

Any suggestions would be greatly appreciated.


Top
 Profile  
 
PostPosted: Thu Nov 17, 2011 11:45 pm 
Offline
Advanced

Joined: Thu Jan 08, 2009 5:39 am
Posts: 9267
Pure device to device control where ISY Programs are not involved is totally dependent on the link database in each device. The device where the button/paddle is pressed is the Controller which must have a link record pointing to the Responder device and the Responder device must have a link record pointing back to the Controller. For all the devices to lose link records is very difficult to explain. There is no single command nor event that I am aware of to make that happen.

Suggest picking two devices, a Controller where the paddle is pressed (stay away from KeypadLincs for now) and the Responder that should turn On/Off in response to the paddle press. Right click on the Controller node in the My Lighting tree, select Diagnostics | Show Device Links Table which will display all the link records in the Controller. When complete click on Compare which is a button along the bottom of the Show window. The ISY will compare the link records found against what it thinks should be there. Do the same thing for the Responder device. If any discrepancies are found right click on the device node and select Restore Device which directs the ISY to rewrite all the device link records.

The other thing I would check is that phase coupling is working. Tap the Set button 4 times on one of the Access Points and look at the other Access Point LED to confirm RF communication is happening and they are on opposite phases.


Top
 Profile  
 
PostPosted: Fri Nov 18, 2011 12:18 am 
Offline

Joined: Sat May 23, 2009 2:20 pm
Posts: 14
I am not really sure what I am looking at. I get 2 lines identical and 1 ignore.

(Also, I upgraded to 3.1.12.)

I restored the devices (which I do not think is actually doing anything). I do not see a difference.


Top
 Profile  
 
PostPosted: Fri Nov 18, 2011 12:29 am 
Offline
Advanced

Joined: Thu Jan 08, 2009 5:39 am
Posts: 9267
That device (assuming it is a SwitchLinc or something similar) has no Scenes defined in it. The two link records are those created when the device is added to the ISY and the last is the End Of List record which is in the device to mark the end of the active records but is not stored in the ISY. Thus the ignored.

How many ISY Scenes is this device defined in?


Top
 Profile  
 
PostPosted: Fri Nov 18, 2011 9:13 am 
Offline

Joined: Sat May 23, 2009 2:20 pm
Posts: 14
It shows it is a controller for 1 scene, and a responder to 6 scenes.

(BTW, thank you for the help and for responding so quickly).


Top
 Profile  
 
PostPosted: Fri Nov 18, 2011 9:15 am 
Offline

Joined: Sat May 23, 2009 2:20 pm
Posts: 14
Also, when I start My Lighting, I get an error. Request Failed. This just started with the last upgrade.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 26 posts ]  Go to page 1, 2  Next

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: Google [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group