Jump to content

ELK no longer operating Insteon devices


starmanj

Recommended Posts

My ELK used to be able to control my ISY99i's Insteon devices. I upgraded some ELK modules and added a few more devices, now the ELK won't work at all with Insteon. If I unplug the PLM it will sometimes activate a light then cease to operate any Insteon. I restored the PLM via the ISY, same result-- it would trigger one event then stop.

 

The ISY performs fine by itself, and the ELK does fine by itself.

 

I confirmed via the WIKI everything is setup correctly, and tried export/importing light setup repeatedly.

 

Is there something I might be missing? Bad PLM maybe?

Link to comment
Share on other sites

Hi gatchel-

I only have one PLM, the one used by the ISY99i. The ELK controls Insteon lighting by sending IP commands to the ISY, which then uses the PLM to control the lights. That's how it's supposed to work.

Link to comment
Share on other sites

Ditto on what Gatchel said.

 

When Elk is connected to ISY, Elk no longer controls Insteon directly. It controls ISY via the ethernet connection which controls Insteon through its connection to its PLM. The serial connection from Elk to PLM is no more. There should only be 1 plm.

Link to comment
Share on other sites

I think you meant ditto on what I said.

 

Anyway it appears the ELK won't communicate at all with the ISY. When I leave the ISY event monitor on, there is no device communication events at all from the ELK.

 

How do you ensure the ELK is logged into the ISY? There are settings for the ISY to log into the ELK, but not vice-versa!

Link to comment
Share on other sites

Actually I didn't see your post, it posted while I was writing. I was confused as Gatchel about whether you were trying to use two PLM's.

 

I still don't understand how you mean Elk works fine by itself. Are you unplugging the PLM and plugging into Elk serial port?

 

When you configure Elk for controlling ISY (downloading the config from ISY and loading into Elk), it no longer will work directly as I recall. So if it works when you plug the PLM directly into Elk, then you probably have Elk lighting not configured as per the ISY download.

 

Also, in ISY, on the elk configuration screen, does it have the correct port number and IP? Are you trying to use SSL? Personally I have had issues with SSL and don't use it as the whole thing is behind the same firewall.

 

Do you have the Elk module for ISY? When you hit refresh topology, does it download all the stuff from Elk? Do you see any of the Elk zones and stuff?

Link to comment
Share on other sites

something in my first post gave you the impression I had two PLMs... I have a normal setup with an ELK and ISY which of course requires a PLM. The ISY logs into the ELK successfully and all ELK controls appear on the ISY.

 

I am trying to get the ELK to trigger an Insteon light via ELK rules. ISY sees ELK fine but ELK simply can't see the ISY or trigger any lights. IP, ports etc. are all setup properly. It's driving me nuts. I don't have the ISY ELK module since I don't need its functionality, I just need the ELK to trigger a light.

 

I use the M1XEP, not a PLM attached to the ELK.

 

I'm trying to debug the rules-- I can observe the ISY event logs but see no device communications between the ELK and ISY. My question is, how can the ISY login and arm/disarm the ELK but the ELK can't trigger an Insteon event?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...