Jump to content

Elk M1XEP Update for Windows 10 Fails


sanders2222

Recommended Posts

This update is confusing.  Two files were provided to update the M1XEP.

    M1XEP_v2.0.34_Update.exe &

    M1XEP_v2_Update.exe

 

Their site also cautions you need a PC running Win 7 (or earlier versions).  I assume I have to use the older OS to run the M1XEP update.  But in doing so, the program window states "Update from Windows 10 PC".  When I pressed continue, an error popped up '2002' was invalid and then the green progress bar seems to hang and will not complete.

 

I was able to close down that window and confirmed I did not break my connection.  But now I'm at a loss how to proceed.  Has anyone gone through this update successfully?  Also, how do I find out what firmware version my M1XEP is currently running? (EDIT I found the M1XEP versions under Send/Receive & "Enroll/Update Control & Devices". I have FW ver. 1.3.28)

 

What am I missing?

Link to comment
Share on other sites

AND I got lucky and figured things out.  Rather than download and run the EXE files like I was trying to do, updates are made through the ELKRP. 

   1st check Help/Updates and download the latest boot and firmware updates for M1XEP.  

   2nd Send/Receive/Enroll/Update and select the M1XEP.

   3rd Update the bootware first, then the update the firmware.

But of course, y'all already knew this,,,,,

 

Now I can't connect (way past the 8 minutes too).   Instead I get the message " System rejected the Remote Program Access Code" and I'm kinked out of the app.  Is there a new access code that is required?

Link to comment
Share on other sites

Open ElkRP--> open your account.  The RP access code is in the lower right panel; make sure this box is not empty.  If so, put in 246801 -->this is the factory default access code.  Save then reboot the M1XEP.

 

KS

The default access code has always been there and has not changed.  I rebooted the XEP then re-opened my ELKRP account.  Same result.  I presume the XEP updates have rendered the unit inaccessible for some reason. The link to the ISY is also broken,

 

This thread has also been posted on:

    http://cocoontech.com/forums/topic/28814-elk-m1xep-update-for-windows-10-fails/

Still NO SOLUTION! And I'm really missing the integration I had between the ELK and the ISY.  Bummer.

Link to comment
Share on other sites

I think it would be best to contact ELK Tech support. They are fantastic and always ready and willing to help.

I was able to connect with ELK Tech support. One Tech commented that because I was a home owner (& not a professional installer/distributor) they were not supposed to be helping me.  But they did!

 

After some discussions and system reboots, we were headed in the direction of opening an RMA to send my XEP plus $75 back to North Carolina for servicing.  At a last ditch thought, I mentioned I had an older version of the ELKRP (2.0.12) and it was suggested I update that and see if that made a difference.

 

AND IT DID!  The updated ELKRP (ver 2.0.24) connected to the ELK and restored my pathway through the XEP. I cancelled the RMA!

 

However, I'm not out of the woods yet.  While the ISY recognizes the ELK connection, it is not communicating with it.  The zones show up but none of the statuses are known.  Nor will the ELK recognize commands sent from the ISY.  So I wonder if I need a different Access Code on the ISY configuration?  Any suggestions?

Link to comment
Share on other sites

Issue RESOLVED

Not doing anything else... the ISY/ELK communication suddenly started working.  So I'm happy now LOL!

 

Apparently if you want to upgrade your M1XEP software to work with Win10, be sure your ELKRP software version is the latest.  Their website doesn't state this, but my network communication was lost until I downloaded and updated the ELKRP to ver 2.0.24.  I also used a Win7 PC to do all this before upgrading to Win10.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


  • Recently Browsing

    • No registered users viewing this page.
  • Forum Statistics

    • Total Topics
      36.6k
    • Total Posts
      367.9k
×
×
  • Create New...