Jump to content

Geofence Location Error Question


Recommended Posts

At 3:48AM today, Mobilinc HD app on my iPhone reported that I left and entered my geofence. Of course this triggered my garage door to open and remain open until I woke up because the ISY thought I was arriving home. My garage door open alert went off but it didn't wake me up.


I have had this configuration set up for over a year without any issues. The phone was on my nightstand all night and connected to wifi. Not sure why this would have tripped.


My phone is an iPhone 6s with the latest OS. Mobilinc version is v4.7.  ISY 5.0.4


I checked the logs on my wireless router and it didn't reboot or lose connection during the time frame. So wifi connectivity should have been fine. According to the writeup on the Mobilinc website, wifi is also used by the iPhone to identify your location along with cell site info. 


How does the geofence know that my wifi is my home location? Is there anything in Mobilinc or the iPhone to set my wifi SSID as home so that Mobilinc will know that I am within my home geofence? 


Any suggestions to try to prevent this in the future besides disabling the garage geofence program at night? 





Link to comment
Share on other sites

Hi sumguy,


I'm sorry to hear this. Unfortunately iOS only knows why that happened. MobiLinc registers the fence with iOS to monitor. iOS tells MobiLinc when iOS thinks the iOS device is inside or outside of the fence. The most common reason that I know about it the iPhone lost Wi-Fi connectivity briefly which would cause iOS to look at cell tower locations for your general location. That could cause the issue.


To guard against this in the future either a disable of sensitive programs at night and/or add in a delay of a few seconds before taking action. When I've seen iOS toggle between in/out of regions like this it *usually* happens back to back quickly. A delay in the program would filter these spurious updates.



Link to comment
Share on other sites

Thanks Wes. I knew it was an iOS issue. Just didn't know if there was a better way to force the phone to realize it was home (not use cell location) or if there was a setting in Mobilinc to set a specific SSID as home and have that setting ignore the geofence if the phone was on the SSID. Of course, as you said in your response, my issue may have been caused by a brief loss of the wifi connection. So that would't really solve the issue anyway. 


The region toggle was within the same minute according to iOS alerts. I will add a short delay in the program and see how that goes. 


Thanks for the response!!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...