Jump to content

RainMachine - HeartBeat -1 normal?


Scyto

Recommended Posts

I just added a rainmachine to me setup and then recalled you had one and came here to looksee :-)

 

I downloaded the latest nodesetup.zip

I configured the rainmachine in the nodelink UI

I installed the nodesetup.zip

i clicked install nodes

 

I see a heartbeat and my program (the heartbeat says -1)

I don't see any zones

I don't see status of a rain detector (i think thats normal as i suspect you don't support that item?)

 

This is what i see in logs - i note an ISY logon error, which is odd but very like the issues I saw 'way back when' when nodelink first came out....

 

any suggestions - should i try another nodesetup.zip uploade / reboot ISY cycle?

 

2016-07-22 15:34:03 - Web Request: /general.css
2016-07-22 15:34:04 - {"zones": [{"uid": 1, "name": "Side Trees & Bushes", "state": 0, "active": true, "userDuration": 0, "machineDuration": 0, "remaining": 0, "cycle": 0, "noOfCycles": 0, "restriction": false, "type": 7, "master": false, "waterSense": false}, {"uid": 2, "name": "Back Trees", "state": 0, "active": true, "userDuration": 0, "machineDuration": 0, "remaining": 0, "cycle": 0, "noOfCycles": 0, "restriction": false, "type": 7, "master": false, "waterSense": false}, {"uid": 3, "name": "Front Upper Lawn", "state": 0, "active": true, "userDuration": 0, "machineDuration": 0, "remaining": 0, "cycle": 0, "noOfCycles": 0, "restriction": false, "type": 2, "master": false, "waterSense": false}, {"uid": 4, "name": "Front Lower Lawn", "state": 0, "active": true, "userDuration": 0, "machineDuration": 0, "remaining": 0, "cycle": 0, "noOfCycles": 0, "restriction": false, "type": 2, "master": false, "waterSense": false}, {"uid": 5, "name": "Front Bushes", "state": 0, "active": true, "userDuration": 0, "machineDuration": 0, "remaining": 0, "cycle": 0, "noOfCycles": 0, "restriction": false, "type": 7, "master": false, "waterSense": false}, {"uid": 6, "name": "Zone 6", "state": 0, "active": false, "userDuration": 0, "machineDuration": 0, "remaining": 0, "cycle": 0, "noOfCycles": 0, "restriction": false, "type": 1, "master": false, "waterSense": false}, {"uid": 7, "name": "Zone 7", "state": 0, "active": false, "userDuration": 0, "machineDuration": 0, "remaining": 0, "cycle": 0, "noOfCycles": 0, "restriction": false, "type": 1, "master": false, "waterSense": false}, {"uid": 8, "name": "Zone 8", "state": 0, "active": false, "userDuration": 0, "machineDuration": 0, "remaining": 0, "cycle": 0, "noOfCycles": 0, "restriction": false, "type": 1, "master": false, "waterSense": false}]}(G) [rain1]
2016-07-22 15:34:04 - {"hourly": false, "freeze": false, "month": false, "weekDay": false, "rainDelay": false, "rainDelayCounter": -1, "rainSensor": false}(G) [rain1]
2016-07-22 15:34:04 - {"programs": [{"uid": 1, "name": "Water My Garden", "active": true, "startTime": "04:34", "cycles": 2, "soak": 1800, "cs_on": true, "delay": 0, "delay_on": false, "status": 0, "startTimeParams": {"offsetSign": -1, "type": 1, "offsetMinutes": 60}, "frequency": {"type": 0, "param": "0"}, "coef": 0.0, "ignoreInternetWeather": false, "futureField1": 0, "freq_modified": 0, "useWaterSense": false, "nextRun": "2016-07-23", "simulationExpired": false, "wateringTimes": [{"id": 1, "name": "Side Trees & Bushes", "duration": 300, "active": true}, {"id": 2, "name": "Back Trees", "duration": 300, "active": true}, {"id": 3, "name": "Front Upper Lawn", "duration": 300, "active": true}, {"id": 4, "name": "Front Lower Lawn", "duration": 300, "active": true}, {"id": 5, "name": "Front Bushes", "duration": 300, "active": true}, {"id": 6, "name": "Zone 6", "duration": 0, "active": false}, {"id": 7, "name": "Zone 7", "duration": 0, "active": false}, {"id": 8, "name": "Zone 8", "duration": 0, "active": false}]}]}(G) [rain1]
2016-07-22 15:34:04 - ISY: Variable rain1-GV1 replaced in queue (Val: 1, QS: 159)
2016-07-22 15:34:04 - ISY Error: The remote server returned an error: (404) OK. (ns/1/nodes/n001_rain1/add/RainMachine?primary=n001_rain1&name=RainMachine&nls=123R)
2016-07-22 15:34:04 - ISY Error: The remote server returned an error: (404) OK. (ns/1/nodes/n001_rain1_p1/add/RainMachineProgram?primary=n001_rain1&name=Water My Garden&nls=123RP)
2016-07-22 15:34:04 - ISY Error: Login failure (verify ISY password on the system config page)
2016-07-22 15:34:04 - Web Request: /general.css
2016-07-22 15:34:05 - Web Request: /isylink/nodes/n001_gem_chan18/query?requestId=6036
2016-07-22 15:34:06 - Web Request: /index.htm
2016-07-22 15:34:07 - ISY Error: The remote server returned an error: (404) OK. (ns/1/nodes/n001_rain1_z1/report/status/ST/0/25)
2016-07-22 15:34:09 - Web Request: /index.htm
Link to comment
Share on other sites

I need a different log.

2016-07-22 15:34:04 - ISY: Variable rain1-GV1 replaced in queue (Val: 1, QS: 159)

 

You have 159 items in your queue meaning some send much before this piece of log was failing.

 

The 404s on trying to add nodes means they already exist in the ISY.  This is a UDI bug.

The heartbeat should be toggling 1/-1

 

Try hitting the install nodes after you see data from the RainMachine.  It won't install zones until it actually see how many you have from the RainMachine.

Link to comment
Share on other sites

Thanks @io_guy - i think there some odd issues.

 

When i went to rainmachine nodelink page i got 'Not authorized - Please setup valid ISY password'

 

The one rainmachine program i have shows up in ISY just not the zone and i have yet to see heartbeat change (maybe i need to set a light to blink when it changes)

 

I rebooted nodelink (0.5. 8) and clicked install nodes - there is the logs, it is not even sending the zones (yet lists them on the nodelink webpage)

I am thinking the invalid password error below is it trying to create the new nodes....?:

2016-07-25 13:31:41 - Web Request: /index.htm
2016-07-25 13:31:43 - Web Request: /general.css
2016-07-25 13:31:43 - Web Request: /favicon.ico
2016-07-25 13:31:43 - Invalid Web Request: /favicon.ico
2016-07-25 13:31:45 - Web Request: /rain1.htm
2016-07-25 13:31:45 - Web Request: /general.css
2016-07-25 13:31:48 - ISY Error: The remote server returned an error: (404) OK. (ns/1/nodes/n001_rain1/add/RainMachine?primary=n001_rain1&name=RainMachine&nls=123R)
2016-07-25 13:31:48 - ISY Error: The remote server returned an error: (404) OK. (ns/1/nodes/n001_rain1_p1/add/RainMachineProgram?primary=n001_rain1&name=Water My Garden&nls=123RP)
2016-07-25 13:31:48 - ISY Error: Login failure (verify ISY password on the system config page)
2016-07-25 13:31:48 - Web Request: /general.css
2016-07-25 13:31:53 - Web Request: /index.htm

I also still get this on the main nodelink page with regular frequency "HTTP/1.0 404 Not Found Connection: close"

 

I also just realized the config page is inconsistent 75% of the time these items do not appear on the page at all!

Require password to access NodeLink pages
Sends log data to specified Syslog server
Relay Server Enable Relay Server
This Option checks With the AutomationShack server every 24h For program updates New updates are automatically downloaded and the program is restarted
Advanced REST Configuration Request Timeout Retry Delay Use HTTP Keep-Alive <input unchecked="" type="checkbox" data-cke-saved-name="httpKeepAlive" name="httpKeepAlive" value="1" &="" "="" style="border-style: none; font-size: 1.1em; font-family: Verdana, Helvetica, sans-serif; padding: 2px;">
These settings are For advanced REST configuration And should Not be changed Timeout: The amount of time a REST sends waits for an ISY response before it gives up Delay: The amount of time to wait before a retry when a REST send to the ISY fails Keep-Alive: Sets when HTTP Keep-Alive is used for HTTP requests (recommended)
Link to comment
Share on other sites

Your first code snip just shows it failed to install nodes.  No idea what you are trying to say in the second code paste.

 

The only time I've seen login errors like that are when the profile number in the ISY does not match NodeLink.  Did you say you have another NodeLink device already up and running?

Link to comment
Share on other sites

Hi, sorry the second paste was supposed to be the UI text that sometimes is there and sometimes is not - it lost formatting :-( - I now see this text more often - turning off verbose logging seems to have helped. Though i still get lots of "HTTP/1.0 404 Not Found Connection: close" when refreshing my browser.  But perhaps all that is unrelated to rain machine issues.

 

My ISY is configured with two nodes. ISYLink on profile 1 and Hue Lights on profile 5 provided by polyglot.  Nodelink and polyglot are both running on the same Pi.  See attached.

 

what does the "2016-07-25 13:31:48 - ISY Error: Login failure (verify ISY password on the system config page)" error mean - given that the username and password is fine and working for everything else?

post-4914-0-49075300-1469491021_thumb.png

post-4914-0-66088100-1469491102_thumb.png

post-4914-0-58539900-1469491180_thumb.png

post-4914-0-12608900-1469491244_thumb.png

Link to comment
Share on other sites

I had been looking at the Rachio , but the interface to the ISY is messy at best

Is the rainachine the best way to go at this point ???

...Barry

I am not sure what you mean by best?  what is it you want / need?

 

I just switched from 'blossom' which had been a big disappointment since their original kickstarter.  I chose the rainmachine mini-8 due to how many APIs they worked with and the easy integration with my netatmo system.  I got a click rain sensor to gfo with it.

 

I still had to setup a baseline of how much i wanted each zone to get watered.  It seems to adjust. when it detects real rain.

 

I like that it can run without need of the cloud service if i want.  I like it has onboard web server.

post-4914-0-54700800-1469495295_thumb.png

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...