Jump to content

Reconnecting to ISY


shannong

Recommended Posts

I have issues with reconnection to the ISY after connectivity is lost. I have only one Profile and use a direct connection to the ISY (no portal).

 

For example, I returned home and wanted to use Agave to control my Tstat. It wasn't connected and then realized I had turned off my WiFi while gone so it didn't have access again, yet. I turned on my WiFi but Agave would not  connect. There wasn't a gray "1" in the upper right left corner. No blinking yellow to show it's trying to connect. There was nothing in the corner. I tried controlling a device to cause a connection request. Force stopped the app and restarted. Still nothing.

 

After fiddling with it for about 2 minutes I gave up. I checked it 15 min later and it was connected. This has happened several times both locally over WiFi and when connecting remotely over VPN.

 

To summarize, two issues:

1. Long timeout and delay for resolving connectivity issues. I'll always have connectivity "issues" as I use a direct connection locally and only use a VPN to home when I need to do something.

2. Should have a way to initiate a reconnection to the ISY when there is a problem. On the home screen would be nice by hitting the spot where connection status normally shows. 

Link to comment

I have issues with reconnection to the ISY after connectivity is lost. I have only one Profile and use a direct connection to the ISY (no portal).

 

For example, I returned home and wanted to use Agave to control my Tstat. It wasn't connected and then realized I had turned off my WiFi while gone so it didn't have access again, yet. I turned on my WiFi but Agave would not  connect. There wasn't a gray "1" in the upper right left corner. No blinking yellow to show it's trying to connect. There was nothing in the corner. I tried controlling a device to cause a connection request. Force stopped the app and restarted. Still nothing.

 

After fiddling with it for about 2 minutes I gave up. I checked it 15 min later and it was connected. This has happened several times both locally over WiFi and when connecting remotely over VPN.

 

To summarize, two issues:

1. Long timeout and delay for resolving connectivity issues. I'll always have connectivity "issues" as I use a direct connection locally and only use a VPN to home when I need to do something.

2. Should have a way to initiate a reconnection to the ISY when there is a problem. On the home screen would be nice by hitting the spot where connection status normally shows. 

I'll look into it.  Is this with the new 1.1.0 or an older version?

Link to comment

I only tested a few times at home by turning WiFi On/Off, and it does seem better. However, the home screen seems to go static which added to my perception of the problem or maybe was even the primary problem.

 

Today I noticed that Agave will have reconnected when I go to a device from the home screen as it shows the "1" (within 5 secs after enabling WiFi again) and I can control a device, but when I go back (using Back function on the phone) to the home screen it still shows blank and not connected. Same thing when connectivity is lost. A device display will show disconnected (no "1") but the home screen still shows connectivity. Same thing for the busy chasing circle when connection is first lost. This can persist for 5 min or maybe forever as long as I know.

 

Selecting home from the hamburger reflects current connected status regardless of the state.

 

I've noticed complaints about device status updates on the home screen that I've also experienced. Maybe there's show general home screen update issues to look at.

Today I discovered that when I return to the home screen from a device by using "back" on my phone it's seem to be a static painted screen. I can go to the device and back to the home screen multiple times for minutes with no change even though connected. However, if I select Home from the hamburger a new home screen is displayed showing current status of connection and/or devices.

Link to comment

Archived

This topic is now archived and is closed to further replies.


  • Recently Browsing

    • No registered users viewing this page.
  • Forum Statistics

    • Total Topics
      36.6k
    • Total Posts
      368.3k
×
×
  • Create New...