Jump to content

ISY Does not see device events after PLM replacement

Recommended Posts

My situation:


My PLM died.  I did not know that was an issue at first.  I got these file not found errors.  So, I tried to restore ISY from backup.  This, of course, did not solve the PLM problem, so I continued to get those errors. I likely also tried a restore PLM on the bad PLM.


I then looked up the error and saw it was likely PLM, so I got a new PLM.


When I installed the new PLM, everything seemed to be ok except no control events from any device were being seen by the ISY.


I tried restore from backup and the restore PLM and restore devices in all permutations with no change.  I tried ISY factory reset and PLM factory reset.  Same result.


I tried to manually reinsert a switch by deleting it an readding it - still not seen by ISY.


All ISY commands work - I can write to devices and I can turn them on and off from the admin console, so ISY can talk to switches they just seem to not be able to talk back without a query (which seems to automatically happen when you turn something on or off from the console).


Eventually,  I believe I tried a Delete PLM out of desperation.  I now see multiple references as I research the problem that say "never Delete PLM".  Obvious question - if it should never be done, why have it as an option?  More relevant to where I am at though, is none of the places where it says not to do it indicate what to do when one actually does it.


It would seem to me that it should be no more harmful then getting a blank ISY and PLM, restoring from backup and then having everything write out to the devices.  But no operations seem to help.  What are the steps to reestablish everything?  I still have the backup that I can reload whenever needed.




Thanks for any and all help.

Link to comment
Share on other sites

If not for the Delete modem option, there would be no way to start anew, that is, wipe everything out and start from scratch. That's an essential necessity for some users. It's not meant for repairs.


But, if you have a valid backup, then all is not lost. What shows in the Administrative Console now? Which firmware and UI are you using? Did you follow any instructions for replacing the PLM? Answer all three questions. Add what you can.

Link to comment
Share on other sites

ISY994i Pro (1110)


   -Portal Integration - Mobilinc (21073)

Firmware: Insteon_UD994 v4.5.1 (2016-06-15 - 14:08:09)

UI:  Same as firmware


Admin console looks normal - all devices are there.  All programs are there.  I can control devices from the console and run programs that control devices. But if a program works by a status that is changed by a switch, it will not work.  I cannot see status changes on the console when I press a switch even though the light goes on or off appropriately.  If I query the switch from the console, it then updates to the right status.


I have unplugged and restarted both the PLM and the ISY multiple times.  I have restored ISY from backup and then run Restore Devices. I have tried Restore Modem.  I am always in the same state.  All looks fine on ISY, but switches do not communicate back to ISY (maybe not to PLM either, I have no way to see that).  I have tried factory resets followed by restore isy followed by restore devices.


If there is some other magical order of doing things or a way to "start from scratch" as you mentioned, I am happy to try it.



Link to comment
Share on other sites

No - I saw it, but these instructions are very basic and have to do with macro steps and do not really apply to my situation - as I mentioned, I have tried resetting everything multiple times.  But if it helps,


1. Unplug ISY - I have unplugged and even factory reset the device more than once,
2. Unplug the old PLM - the old PLM is gone, so not releveant anymore
3. Unplug the cable from the old PLM - again, it is gone and unplugged
4. Plug the cable into the new PLM - since I can connect to all devices from ISY, this step is confirmed
5. Plug in the new PLM - again, I am connecting outbound from ISY with no issues
6. Plug in ISY - multiple times
7. Login to the ISY and do a "Restore Modem (PLM)" - multiple times, as well as restore devices, individual write to devices and adding back a device


As mentioned, I even deleted and readded a device to the ISY (which includes Remove Links) and ISY still did not see control changes.


Further, since it says you should never do Delete Modem and I did, and the steps above are the standard steps,  wouldn't be different steps?  If they are the same steps, what make a big deal about doing the delete?


Thanks for any insight you can give,

Link to comment
Share on other sites

Delete Modem (PLM) removes all the links from the PLM. And removes them from the ISY links table. A Restore Modem(PLM) will only do the ones still in the ISY Link Table that now has no PLM links in it.


You have to use a backup made before the Delete Modem (PLM) was used.

Using the Restore ISY with the previous backup that has all the links in it. Not the links after removing the PLMs links.

I believe you may then have to do a Restore Modem (PLM) with the restored ISY link table.

Link to comment
Share on other sites

ok - i tried one more time just to be sure

I unplugged everything - i then

1.  Reset the PLM to factory

2.  Reset the ISY to factory

3.  connected the rj45 from the PLM to the ISY

4.  Restored the ISY backup

5.  Ran Restore Modem


Turning a light on from the switch still did not produce a change in admin Main screen for the device


I then looked at the device links and did a compare to ISY

Device had 4 links and ISY had 2.  So, I did a Restore Device on the switch.  I relooked at device links and did a compare and they matched.  But still the switch does not change the status on Admin Main.


What can I do?



Link to comment
Share on other sites

Update:  Good news.  Somehow in the last round of resetting things I am able to get switches back in by deleting them from ISY and relinking them.  I may also have 1 faulty switch which contributed to some of the confusion.


This makes the problem to other threads I have seen where focus have to delete and re-add.  It seems programs handle this well, but not scenes.  Scenes need to have devices readded.  Fortunately, I do not have many scenes and rely more on programs.


I am not sure what the expected behavior for outlets is.  When the button on an insteon outlet is pushed (older top only dimmable outlet), should ISY see that event?   Because I tried the same delete and add for an outlet and it is not seeing the manually pushed button.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...