Jump to content

Cannot access ISY994i over internet via Mobilinc


Recommended Posts

I have two ISY994i's, one at home and the other at the cabin, fired up the Mobilinc app to adjust thermostat at cabin and didn't work. Definitely worked a few weeks before and have changed nothing since then. Works fine on arrival over the local network/Wifi.


I use a Netgear router with dyndns.org dynamic IP address service, and it is working and the router IP address and dyndns.org's info on the IP address is correct. Tried setting the Secure https manually to the router's current IP address and no difference. Tried changing my secure port from 555 to 443 and back, no difference (including on the ISY994i of course).


Reset router, cable modem, ISY994i, Mobilinc, no difference.


Error message received when trying to control a device:

"Network Error. There was a problem sending the request. Please verify the connection settings in My Settings an try again. Error code: 0. Error Message: A connection failure occurred: SSL problem (Possible causes may include a bad/xpired/self-signed certificate, clock set to wrong date)"


The cabin ISY994i is on firmware 4.2.18. Yes that's long in the tooth but I don't update unless there's an irresistible feature or a problem.


My ISY994i at my main home seems to be working fine through Mobilinc although for some reason I cannot access it through the web browser.


What now, update the firmware or am I missing something obvious? If firmware update is indicated, which version? Any theories what has happened?



Link to comment

Yes there is, I stumbled upon that when I was searching for a solution but I don't think this is a factor since it still works with my other ISY994i and isn't corrected by bypassing the dyndns.org hostname redirect to my router's current IP address.


At least, I think it is permitted to enter the current 32-bit numerical ip address directly into the https: field on the settings page in Mobilinc?


It's the strangest thing, it's as if my router isn't forwarding the hits to the ISY994i's port 443.



Link to comment

Well I bit the bullet and updated the firmware to 4.5.1 and the problem is solved. Was there a stealth update done to the ISY, is that even done? Or was the firmware corrupted somehow? Anyway it works over the internet outside of the home Wifi via https again.


There's another problem that's been cropping up, will post on that separately, but before the update also I have been getting some internal error dialogs. Hit continue 4 times and things still "seem" to be normal.



Link to comment


This topic is now archived and is closed to further replies.

  • Create New...