Jump to content

Anyone on 5.0.14 using HomeAssistant?


Recommended Posts

So I have been having intermittent issues with the ISY component not working in HomeAssistant.

I get errors like this:

2018-12-14 18:08:45 ERROR (MainThread) [homeassistant.setup] Error during setup of component isy994
Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/homeassistant/setup.py”, line 148, in _async_setup_component
component.setup, hass, processed_config) # type: ignore
File “/usr/local/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/isy994.py”, line 379, in setup
use_https=https, tls_ver=tls_version, log=_LOGGER)
File “/usr/local/lib/python3.6/site-packages/PyISY/ISY.py”, line 84, in init
self.nodes = Nodes(self, xml=self.conn.getNodes())
File “/usr/local/lib/python3.6/site-packages/PyISY/Nodes/init.py”, line 52, in init
File “/usr/local/lib/python3.6/site-packages/PyISY/Nodes/init.py”, line 238, in parse
Group(self, nid, nname, members, controllers), ntype)
File “/usr/local/lib/python3.6/site-packages/PyISY/Nodes/group.py”, line 43, in init
File “/usr/local/lib/python3.6/site-packages/PyISY/Nodes/group.py”, line 83, in update
if self.parent[m].status > 0:
File “/usr/local/lib/python3.6/site-packages/VarEvents/init.py”, line 255, in gt
return self._val > other
TypeError: ‘>’ not supported between instances of ‘NoneType’ and ‘int’

I have been able to use it while on 5.0.14, but very little and today I tried with a fresh install of Hassio and got the above errors again.

Trying to figure out why this is happening and what could be done to resolve it, but nothing has worked for me.

Any thoughts on this?

And please forgive me if there is something obvious in there...I'm not a programmer.

Link to comment

@danbutter - I'm using v5.0.14 and except for the issues I've reported it is working fine. Looking at the traceback it looks like the issue is with ISY scenes and how PyISY parses the XML that the ISY returns.

Do any of the ISY devices or scenes show up and work?  To troubleshoot you may want to try changing some of the scene names. 

Also you can enter this URL from a browser to see the XML that the ISY is returning to see if anything looks unusual (change /isy/ to the name or IP address of your system) http://isy/rest/nodes/?members=true. (here's the ISY REST documentation if you need it).

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...