Jump to content

Multiple Devices By that name


Recommended Posts

As of an hour ago suddenly Alexa states that "there are multiple devices by that name"  for every device I have tried.   I tried re-running discovery with no change.  I tried deleting the devices manually and re-discovering, they then show up as two devices with the same name.  I tried unlinking, and re-linking my ISY v3 skill and had no change in behavior.


I am currently running firmware 4.6.2 

Link to comment

I investigated the logs for Cap, elliot and Bipto.

For elliott and Bibto, things look normal. Do you experience duplicate spokens like cap does? Just wondering if there may be a different issue or not. If you have duplicate spokens, you may want to unlink, delete spokens and relink.

For Cap, I see lots of device discoveries starting about 3 hours ago.

Amazon does regular device discoveries on schedule. I can't differentiate between a manual request you would have made, and a scheduled one. I see 14 discovery within 3 hours, and this does not look normal to me. I even see some of them milliseconds apart, which are clearly not a manual request. That may explain duplicate spokens that you see in the Alexa app as well.

My recommendation would have been to unlink, remove spokens and relink, but you already did that. 

I would then suggest the following.

1. Unlink the skill

2. Delete spokens in the Alexa app

3. Go to Amazon.com, click Accounts & Lists. Under Other accounts, click Login with Amazon. If you see anything related to UDI, remove it.

4. Relink



Link to comment

I was experiencing the same thing cap60552 mentioned in that every spoken was responding with "there are multiple devices by that name, which one?". This would continue even if I repeated myself and no matter which device I was trying to interact with. I did not do the troubleshooting (unlinking and what not) that cap mentioned but instead came here to find this thread. 

I just checked again and all of my spokens phrases are working properly. I have made not changes and bmercier says he has not changed anything on my behalf so it seems likely to me that Amazon has having some kind of cloud issue that has since recovered. I'll keep an eye out through the day and speak up if I experience another occurrence. 

Link to comment

It is fixed for me as well.   

As for the tons of discovery, that was probably me.  I was removing, and adding devices pretty frantically in testing.  The multiple discovery's milliseconds apart were me trying to run it using my phone, and the in room device also heard me. 


Link to comment

I experienced the same thing yesterday morning (between the times of 7:15 and 9:15 a.m. MST). I think even my Logitech Harmony Skill was behaving oddly. I didn't have time to investigate before having to leave for some appointments. I received calls and messages from 2 of my customers experiencing the same thing I was experiencing (with lights, I/O lincs, etc.) "There are multiple devices with that name. Which one did you want?". By the time I returned home last evening, everything was working perfectly. I suspect there something errant was happening on the Amazon side of things. Did any one see something to the effect in the news?

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...