Jump to content

ISY GUI boots but can't do anything


Recommended Posts

Hi guys,

My ISY Launcher seems to show all my devices but when I try to do something with one of them (turn on or off) 

It says Network error

I can't control the ISY with the Alexa app either.

Any thoughts?

The PLM Info say 0.0.0 v0 / Not Connected

I tried changing the CAT6 cable but that doesn't seem to fix it.

Port A goes to PLM and Network goes to my router

Drew

Link to comment
Share on other sites

I have functionality again for the most part. 

My programs aren’t working. 

Scenes work fine and individual lights work fine. 

Is there some sort of reset I have to do to get the programs back? 

Its late so I haven’t tried deleting a program and making a new one.

i can try that tomorrow  

let me know if there’s anything else I should try first 

Drew  

 

Link to comment
Share on other sites

Re-entering programs likely will not change anything. Are the programs based on triggers from the insteon network? If yes, that means the PLM is still suspect, not maintaining the table of network devices and ignoring the insteon network message as a result

Paul

Link to comment
Share on other sites

Oh it can be, unfortunately. And when its in the dying state, it can be recovered temporarily with "Restore modem".. things work, and then it slowly loses them.

The way to test:

  • Find a program, triggered by an insteon device, that's quit working
  • Look at the device's screen in the admin console while turning it on/off
  • If everything's working,  the AC should show on and off as you change
  • The test:
    • Restore modem
    • Try the above again
    • If it works, I'll give a 95% that the PLM is on the way out

Its not you plugging/unplugging it, its just where it is in its life

Paul

Link to comment
Share on other sites

There's no simple way to test -- there are merely symptoms that when put together indicate a probable PLM failure.

The root cause is Smarthome's choice of the incorrect capacitor type for the power-supply inside the device, and as is typical of capacitor-induced power supply failures, there's no binary "it's working - but now it's not" -- rather the supply degrades very gradually over time so that errors and problems simply become more and more likely to happen.  The point being that a human would describe the symptoms as generally flaky behavior.  I've also observed that when the supply fails to a certain point, removing and re-applying power can result in a device that seemed to work not correctly powering up.

In any case, compared to a new working unit, you'll likely note that the LED is dimmer on the failing unit.  From an interface point-of-view, small transactions or queries by the ISY may seem to work, but larger sustained ones tend to fail (e.g. the ISY might be able to respond with its ID at boot, but will fail when the ISY tries to count the links in the PLM's link database.

The only real way to know is to swap it for a new one.  And given that they fail every two years, plus or minus a few months, you should always have a spare on hand.

Link to comment
Share on other sites

Okay. Thanks everyone for the help. 

I’ll stop any sort of frustration with testing and just buy another PLM

I know there’s two different kinds. 

I believe I have to purchase

 Insteon 2413S Powerlinc Modem Dual-Band Serial Interface. 

 

I remember the the last time I had to replace this I had no end of issues as well and had to send them back and get replacements  to the point where amazon was getting to the point where I was going to pay shipping 

 

Link to comment
Share on other sites

Yes, 2413S... What's important is that you ask the seller to make sure you're getting => V2.4 firmware where component changes were made to improve the life. There is also a v2.5 coming out, but not sure if its on the shelf yet. I talked to SH in Novemeber and they said 2.5 was not out for the 2413 S yet.

Either way, I would email SH customer service, ask them specifically what version is out, and tell them when you put in your order you're expecting the latest and greatest.

I had a PLM with Homeseer that lasted 3+ years and I sold it when i came to the ISY. My first ISY PLM was used, and lasted > 4 years for me. It died related to an extended brown out / black out where power went on and off repeatedly and I was not at home.

I now have a 2.4, but its too soon to tell based on my experience with them. When 2.5 comes out for the 2413S, I'll buy another as a backup

Paul

Link to comment
Share on other sites

I just checked amazon.ca and it says this;

Quote

 

New revision (2.3) addresses issues with hardware longevity

buy from ‘ships from and sold by Amazon’ to ensure you receive the latest revision

 

I checked other retailers and they make no mention of the firmware version.

I also tried to make a simple program and it failed?

I also noticed I bought this PLM from Amazon October 2016 so I guess from what you guys are saying I shouldn't complain.

Is 2.3 horrible? it seems I can't be sure what version I get anywhere else?

Is there a way from the ISY GUI to see the firmware version of the PLM I currently have?

I've included a screen grab of what I see when I check PLM INFO/Status

Drew

Screen Shot 2019-03-30 at 12.32.32 PM.png

Link to comment
Share on other sites

I got the PLM today and its indeed V2.4 so I'm pretty happy about that.

I've followed the exact instructions as far as replacing the PLM and that seems to have gone off without a hitch.

I am having some issues with some devices.

A KPL seems to not be recognized by the ISY GUI.

It works and the remontelincs work with it but when I try to access it through the ISY GUI it says "Cannot communicate with...Please Check Connections."

Also, the Lamplincs aren't showing a "Write Updates" icon.

When I went to press the set button still nothing happened.

Will I have to re add them to the ISY?

Replacing the PLM is never smooth it seems.

EDIT: Turns out none of my programs or timers are working. And when I try to voice command some lights (not programs) they fail.

 

 

Drew

 

Link to comment
Share on other sites

Don't re-add

The ISY is system of record for the insteon network, and gets is info from the PLM. If the PLM is dying and its info corrupted, that gets copied into the ISY's records

Here's something to try:

  • Pick the keypad
  • Right click
  • Restore device
  • Does it work?

If it works, there may be a way to get everything back without individually restoring remaining devices.I suggest a trying restoring a recent backup that has everything you need, but from before the recent PLM problems. After it restores, try a restore modem... that should get the bulk of it back if this was the problem. Sometimes some devices will need to be individually restored.

Paul

Link to comment
Share on other sites

Hi Paul,

I've restored some of the devices and can continue to do that. I'm a little gun shy to restore my recent backup of the ISY as it was last backed up a few days before it died. I don't know if I trust the backup. 

I don't mind going through each device and restore/write updates. 

My programs are still an issue though.

How can I get those back?

Drew

Link to comment
Share on other sites

I would've guessed that programs were not triggering due to PLM table being corrupt / empty. The PLM only responds to device messages its been told about - which on the ISY happens when you install.

Lets start with that .... do you have programs that are 

If status mydevice is on

....or..

If control mydevice is switched on

Do you have programs of that type that won't execute even after being restored?

Can you show examples of the schedule programs that don't execute?

Paul

Link to comment
Share on other sites

I have both kinds of Programs.

Quote

 

Theatre 25% - [ID 0012][Parent 0001]

If
        Status  'Theatre Room' is Off
    And Control 'Theatre Room' is switched Off
 
Then
        Set 'Theatre Room' 25%
 
Else
   - No Actions - (To add one, press 'Action')
 

 

 

 

I just made a timer and that seemed to work.

I thought it was because it was new but when I made a new program it still didn't work.

 

Link to comment
Share on other sites

For the theater room program can you confirm

  • You restore device'd it?
  • If you turn it on / off, the Admin Console sees those changes?
  • The program doesn't work?

I've not had the case of needing to reenter a program.  Maybe take a few programs of both type and try:

  • Change something simple like off to on, then change it back
  • That will allow you to click "update" for each program
  • click Save changes, let it finish and retest

 

Link to comment
Share on other sites

That was one of the devices I had to restore yes. And the Admin Console doesn't update to the status of the device.

(I have a KPL upstairs that doesn't update the ISY GUI either it seems)

The program still doesn't work.

I tried changing a small part of the program, updating, changing it back, and updating it again. Then saving changes.

Still the same issue.

I tried writing a new program and it still didn't work. Although it was a program based off the theatre room SWL so I'll try making a program with a different SWL that seems to be functional.

Ignore that.

Turns out more devices aren't updating the ISY now that I start running around the house and checking back to the ISY GUI

 

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...