Jump to content

No module named 'chump'


EddieRock

Recommended Posts

Hey @Jimbo I installed on my raspberrypi and receive this error and the node server is disconnected... I also put this issue on your project in github.

Platform: Pi 3 (I think)
Raspbian GNU/Linux 10 (buster)
Polyglot Version 2.2.3 Status: Connected
ISY Version: 5.0.16

2019-12-14 13:26:12,367 [MainThread] [INFO ] Received Config from STDIN.
2019-12-14 13:26:12,369 [MainThread] [INFO ] UDI Polyglot v2 Interface 2.0.34 Starting...
2019-12-14 13:26:12,381 [MainThread] [ERROR] Traceback (most recent call last):
2019-12-14 13:26:12,381 [MainThread] [ERROR] File "./notification-poly.py", line 9, in <module>
2019-12-14 13:26:12,382 [MainThread] [ERROR] from nodes import Controller
2019-12-14 13:26:12,382 [MainThread] [ERROR] File "/home/pi/.polyglot/nodeservers/Notification/nodes/__init__.py", line 4, in <module>
2019-12-14 13:26:12,384 [MainThread] [ERROR] from .Pushover import Pushover
2019-12-14 13:26:12,384 [MainThread] [ERROR] File "/home/pi/.polyglot/nodeservers/Notification/nodes/Pushover.py", line 12, in <module>
2019-12-14 13:26:12,386 [MainThread] [ERROR] from chump import Application
2019-12-14 13:26:12,386 [MainThread] [ERROR] ModuleNotFoundError
2019-12-14 13:26:12,386 [MainThread] [ERROR] :
2019-12-14 13:26:12,386 [MainThread] [ERROR] No module named 'chump'

I installed chump using:

pip install chump

Rebooted...

Still receive errors...

Thoughts?

Link to comment
Share on other sites

Ok. I did a pip3 install chump and it started. 

pip3 install chump

Now, there is a blue bar asking to follow the link to acknowledge which brings me to your acknowledge.md document. And, the only custom configuration is a acknowledge key with a Value which is blank. I don't know what to put in there. Or what to do next...

image.thumb.png.fe9b3a3e1108cc923208ce33f4f49f65.png

Link to comment
Share on other sites



Ok. I did a pip3 install chump and it started. 
pip3 install chump

Now, there is a blue bar asking to follow the link to acknowledge which brings me to your acknowledge.md document. And, the only custom configuration is a acknowledge key with a Value which is blank. I don't know what to put in there. Or what to do next...
image.thumb.png.fe9b3a3e1108cc923208ce33f4f49f65.png[/img]



The acknowledge.md should tell you what to put in for the value.

Sent from my Pixel 3 XL with Tapatalk

Link to comment
Share on other sites

  • 1 month later...

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...