Jump to content

Polisy with Ambient Weather node server


BMorris

Recommended Posts

I have had my ISY 994i for years now and have just added a new Polisy.  Generally, I'm having success with its implementation, but have some nagging issues. 

The ISY is running 5.0.16C and the first node server added was Ambient Weather to be able to use the data from my AW 2000 for some decision processing.  Of the 49 nodes set up in Polisy from my two PWS (one in Texas and one in Maine), only about half are "ported" across to the ISY.  In particular, I'm after the solar data and when I select it in the ISY Admin Console for addition, I get a "Bad Request" error message the first time, when I try it again, I get no message at all.  In either case, the Solar node is not added.  Also in the Admin Console, I've tried to "Add All Nodes" for Ambient Weather.  I'm asked to confirm the request which I do, but, again, nothing changes.

I've tried the "Re-Discover" and "Update Profile" in the ISY primary Ambient Weather node and neither appears to have any effect (BTW, I can find no Help on these selections along with the "Remove Notices" selection).

What am I doing wrong?

Also, my Polisy is running Polyglot 2.2.9-5.  A notice of a new version 2.2.10 is noted at the bottom of the screen and though I selected it and get a message that it's been successfully updated, the listed version and update notice persist as if I hadn't done anything.  Further, I used the menu selection to check for updates and it reports that I have the latest version and no updates are available.  I've restarted and rebooted Polisy, but no change.  What is the issue?

Thanks for any input...

Link to comment
Share on other sites

I have had my ISY 994i for years now and have just added a new Polisy.  Generally, I'm having success with its implementation, but have some nagging issues. 

The ISY is running 5.0.16C and the first node server added was Ambient Weather to be able to use the data from my AW 2000 for some decision processing.  Of the 49 nodes set up in Polisy from my two PWS (one in Texas and one in Maine), only about half are "ported" across to the ISY.  In particular, I'm after the solar data and when I select it in the ISY Admin Console for addition, I get a "Bad Request" error message the first time, when I try it again, I get no message at all.  In either case, the Solar node is not added.  Also in the Admin Console, I've tried to "Add All Nodes" for Ambient Weather.  I'm asked to confirm the request which I do, but, again, nothing changes.

I've tried the "Re-Discover" and "Update Profile" in the ISY primary Ambient Weather node and neither appears to have any effect (BTW, I can find no Help on these selections along with the "Remove Notices" selection).

What am I doing wrong?

Also, my Polisy is running Polyglot 2.2.9-5.  A notice of a new version 2.2.10 is noted at the bottom of the screen and though I selected it and get a message that it's been successfully updated, the listed version and update notice persist as if I hadn't done anything.  Further, I used the menu selection to check for updates and it reports that I have the latest version and no updates are available.  I've restarted and rebooted Polisy, but no change.  What is the issue?

Thanks for any input...

As of this writing the Polisy has a Beta check box enabled. This is why this version shows up. It doesn’t address the fact when invoking the update it fails.

 

UDI is aware of this problem and is working toward fixing it. Don’t worry about the .10 it doesn’t offer any new features for the end user as of yet.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

2 hours ago, BMorris said:

I'm after the solar data and when I select it in the ISY Admin Console for addition

I'm not sure what you're doing but there's no setup or configuration from the ISY Admin Console for ANY NodeServer.  NodeServer's are configured from the Polyglot web interface. 

The AmbientWeather has one configuration requirement which is your user and app API Keys from your account page from AmbientWeather.Net.  Once entered save and restart the NodeServer and all available nodes are created and will populate data based on the polling interval from AmbientWeather.Net service.

You will likely have to remove the NodeServer and start from a fresh install to get things to work. 

In Polyglot stop the NodeServer and delete it. 

If any nodes remain in the ISY Admin Console you will have to delete them manually.  Then in the NodeServer drop down in the ISY Admin Console you may have to delete the Nodeserver entry.  This is the only time you ever should be touching the NodeServer drop down in the ISY Admin Console in relation to any Polyglot NodeServer.  To forcefully/manually delete them.

Link to comment
Share on other sites

Well, I've tried all of the suggested procedures and the best I can get from Ambient Weather is 31 nodes rather than the 49 listed in the AW node server... the solar data I'd like to use is in the "unlisted" nodes.  Is there a limit to the number of nodes allowed from a given server?

Link to comment
Share on other sites

10 minutes ago, BMorris said:

Well, I've tried all of the suggested procedures and the best I can get from Ambient Weather is 31 nodes rather than the 49 listed in the AW node server... the solar data I'd like to use is in the "unlisted" nodes.  Is there a limit to the number of nodes allowed from a given server?

What do you mean listed in the AW node server?  What list?  From the Polyglot interface?  If the nodes are showing in Polyglot then the nodeserver is working.  Which leads to another question.  How many nodes do you have in your ISY in total?  Everything.

Link to comment
Share on other sites

The list is from Polisy's Dashboard with each node server having a "Details" selection which then lists the nodes.  I can only assume that the Polyglot interface is what I see when I browse to Polisy's URL.

 

I currently have 7 node servers:

  1. Ambient  Weather with 49 nodes (as seen in "Details"), one for each weather parameter, 2 PWS locations, + primary.
  2. HoneywellHome with 1 node, not yet configured.
  3. Ping with 5 nodes.
  4. Tesla with 6 nodes.
  5. ISY portal, unmanaged.
  6. Virtual with 1 node; not yet configured.

That's everything.

 

Link to comment
Share on other sites

1 hour ago, BMorris said:

The list is from Polisy's Dashboard with each node server having a "Details" selection which then lists the nodes.  I can only assume that the Polyglot interface is what I see when I browse to Polisy's URL.

 

I currently have 7 node servers:

  1. Ambient  Weather with 49 nodes (as seen in "Details"), one for each weather parameter, 2 PWS locations, + primary.
  2. HoneywellHome with 1 node, not yet configured.
  3. Ping with 5 nodes.
  4. Tesla with 6 nodes.
  5. ISY portal, unmanaged.
  6. Virtual with 1 node; not yet configured.

That's everything.

 

A "node" is any device in the ISY.  Insteon, Z-Wave, NodeServer "nodes" anything that shows up in the ISY Admin Console in the left hand panel including "Scenes" and nodes you created for organizing.  How many do you have and do you have the "Pro" license?  It sounds to me like you've hit the limit of "nodes" in the ISY.

If the node information is showing in the Polyglot web interface and has data the nodeserver is collecting the data.  If the "nodes" are not created in the ISY there's either a node limit you've hit which is why I'm asking about the "pro" license for the ISY or there's some other problem in the nodes not being created which sounds unusual if most of them were created but some not.

Link to comment
Share on other sites

Without counting folders, I count about 217 ... it's likely I'm at a limit.  I've just ordered the Pro upgrade, so if that's the problem, it should be resolved soon.

In the meantime, is it possible to delete some of the nodes defined in the Ambient Weather server?  For instance, I don't immediately need the nodes for my second PWS.  If I were to delete a few, how are they added back to Polyglot?

 

Thanks for helping an old newbie.

Link to comment
Share on other sites

13 minutes ago, BMorris said:

Without counting folders, I count about 217 ... it's likely I'm at a limit.  I've just ordered the Pro upgrade, so if that's the problem, it should be resolved soon.

In the meantime, is it possible to delete some of the nodes defined in the Ambient Weather server?  For instance, I don't immediately need the nodes for my second PWS.  If I were to delete a few, how are they added back to Polyglot?

 

Thanks for helping an old newbie.

The nodes are auto created during the discover process of parsing the data from Ambient Weather.  Currently there's no easy method to be selective of what nodes are created.  You can delete them from the admin console however it will generate errors in the nodeserver when it's trying to update the nodes and might cause other failures as I've not tested this scenario.

I had previously thought about having selections as that's how I did it with another system however.  I may revisit this.

 

Link to comment
Share on other sites

Yesterday, I upgraded my 994i to Pro (installed and verified).  I deleted and uninstalled AmbientWeather from Polyglot (running on new Polisy Pro).  I verified all reported remnants of AmbientWeather nodeserver were deleted from the admin console node and nodeserver list.  I rebooted both the ISY and the Polisy.  Following that, I reloaded AmbientWeather from the store and reinstalled it in Polyglot with APP and API from my account with AmbientWeather.net.  After that process, there's been no change in what nodes are reported in admin console.

I looked thru the Polyglot log and see that all AW parameters (48) are reported as being presented to the ISY, so I'm beginning to feel that the problem could be the ISY, more specifically, the admin console app.  I've also noted that the reported nodes are the ones preceeding log entries for extra sensors (temp & humidity) that I've deployed around my properties (5 at one property and 4 at another)... none of that data is present in the admin console.

Thanks for your help ...

Link to comment
Share on other sites

12 minutes ago, BMorris said:

Yesterday, I upgraded my 994i to Pro (installed and verified).  I deleted and uninstalled AmbientWeather from Polyglot (running on new Polisy Pro).  I verified all reported remnants of AmbientWeather nodeserver were deleted from the admin console node and nodeserver list.  I rebooted both the ISY and the Polisy.  Following that, I reloaded AmbientWeather from the store and reinstalled it in Polyglot with APP and API from my account with AmbientWeather.net.  After that process, there's been no change in what nodes are reported in admin console.

I looked thru the Polyglot log and see that all AW parameters (48) are reported as being presented to the ISY, so I'm beginning to feel that the problem could be the ISY, more specifically, the admin console app.  I've also noted that the reported nodes are the ones preceeding log entries for extra sensors (temp & humidity) that I've deployed around my properties (5 at one property and 4 at another)... none of that data is present in the admin console.

Thanks for your help ...

I don't have the AW 2000 but I do have a WS-2902 and WS-1401 and I did you the add on sensors with the WS-1401.  One item to suggest is trying the other AmbientPoly nodeserver and see if it works for you? 

Link to comment
Share on other sites

Thanks for the tip.  I installed AmbientPoly and was able to get the solar input I was originally seeking.  Still can't see any of the supplemental sensors, but that's an issue for another day.

What about a second location, ie, can another MAC address be entered?  Or a second instance of AmbientPoly?

Link to comment
Share on other sites

39 minutes ago, BMorris said:

Thanks for the tip.  I installed AmbientPoly and was able to get the solar input I was originally seeking.  Still can't see any of the supplemental sensors, but that's an issue for another day.

What about a second location, ie, can another MAC address be entered?  Or a second instance of AmbientPoly?

 @bpwwer wrote that NodeServer.  I don't know if he's supporting add on sensors or not.  I'm actually not sure if the WS-2000 sends that information to the AmbientWeather.Net for API access either.  I know the PWS's that use the ObserverIP module do, but for the others I don't know. 

I've shifted development to EcoWitt these days.  Having duplicate Ambient Weather nodeservers is well... redundant so I'm leaving Ambient and most other Weather NodeServers to Bob :)

 

Link to comment
Share on other sites

Thanks for all your input ... as you might have surmised, I'm not technically a novice, but my knowledge base is a bit aged, especially with this "node" stuff.  Your help has been invaluable.

Regarding AW and the supplemental sensors, according to the log, the AmbientWeather nodeserver creates an output for each of my 4 add-on sensors and their data ... the server is pitching, but the ISY is apparently not catching (but no error messages are created).

Good luck with EcoWitt.  Do you know if anyone is working on a nodeserver for SolarCity (now Tesla)?  I have a fairly large solar installation with output that's reported via Tesla's app...

Again, thanks

Link to comment
Share on other sites

3 minutes ago, BMorris said:

Thanks for all your input ... as you might have surmised, I'm not technically a novice, but my knowledge base is a bit aged, especially with this "node" stuff.  Your help has been invaluable.

Regarding AW and the supplemental sensors, according to the log, the AmbientWeather nodeserver creates an output for each of my 4 add-on sensors and their data ... the server is pitching, but the ISY is apparently not catching (but no error messages are created).

Good luck with EcoWitt.  Do you know if anyone is working on a nodeserver for SolarCity (now Tesla)?  I have a fairly large solar installation with output that's reported via Tesla's app...

Again, thanks

I still find it odd that the Nodeserver is collecting the data but it's not getting into the ISY.

There has definitely been talk about Tesla Wall but I don't know current status. 

Link to comment
Share on other sites

Hi @BMorris

I don't think my AmbientPoly supports all the additional sensors. It's been quite a while since I've looked at it. I also don't have any Ambient weather stations so I think @simplextech's AmbientWeather had better support there.   I have seen cases where the ISY silently ignores the node add request from the node server. Usually when the ISY is busy and the node server is trying to add a lot of nodes at one time, and 40 some odd nodes at one time is a lot of nodes.  Possibly there needs to be a delay added in the node server so it gives the ISY a bit of break.

For my AmbientPoly, I believe the log will dump the data it gets from the queries to AmbientWeather.net. So if the data is there, let me know and I can add it support for those fields into the node server.

Off topic, but yes, there is a Tesla PowerWall node server, but it is not publicly available because it has not been tested at all.  UDI was looking for someone to help test it so you might want to send a note to support@universal-devices.com and let them know if you're interested in helping test the node server.

Link to comment
Share on other sites

7 hours ago, bpwwer said:

Possibly there needs to be a delay added in the node server so it gives the ISY a bit of break.

That's something I didn't think about with it being local.  I had to do that with Polyglot Cloud... hmm.... I'll find some time over the weekend and look into that.  Should be a quick change.

 

Link to comment
Share on other sites

I have checked the logs of both AmbientWeather and WeatherPoly and both appear to be providing all supplemental sensor data.  However, none of that additional data is processed by my ISY.

Regarding AmbientPoly, does it support more than one PWS?  If so, how would I implement a second weather station (both are AW-2000 and both have supplemental sensors)?

Thanks for the tip on the Tesla PowerWall nodeserver.  I'll reach out to UDI today.

Link to comment
Share on other sites

I didn't ever consider supporting more than one station when I created AmbientPoly. I had a hard enough time getting things working at all since I don't have one of their stations.

We really should combine the two Ambient node servers and take the best of both (which means mostly use @simplextech's) but I don't think either of us want to spend the time.

Link to comment
Share on other sites

That's understandable, albeit, disappointing. 

If you think that adding some delay time might allow my ISY to accept all of the AmbientWeather nodeserver data, I'd appreciate you having a look.  The AmbientWeather version accepts all of the sensor data defined in my AW profile, hence all data from both AW-2000 PWSs is present in its log.

Thanks for your time and assistance.

Link to comment
Share on other sites

3 hours ago, BMorris said:

That's understandable, albeit, disappointing. 

If you think that adding some delay time might allow my ISY to accept all of the AmbientWeather nodeserver data, I'd appreciate you having a look.  The AmbientWeather version accepts all of the sensor data defined in my AW profile, hence all data from both AW-2000 PWSs is present in its log.

Thanks for your time and assistance.

I've got my office somewhat assembled again and the ISY's and Polisy online again.  So I'll take a look at this over the weekend.  The NS needs some attention anyways along with several others. 

Gotta work on the tractor first though.  Tractor.  Not lawn mower :)

 

Link to comment
Share on other sites

On 7/17/2020 at 5:39 PM, BMorris said:

Thank you and good luck with the tractor.  I'll be glad to test the nodeserver for you (two PWS WS-2000 + 9 aux sensors ... 49 nodes total)!  Wish I could help you with the tractor...

I added a pause in between adding of the nodes.  The release was pushed to Github 0.1.35.  If you can give that a try and create the nodes I'm curious to see if they all are created or not.  Or if more of them are at least. 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...