Jump to content

Temperature readings


garybixler

Recommended Posts

Hi

I just migrated to the Polisy ISY and installed the ELK node server. All is pretty much the same as with the ELK module on the ISY. The only two things lacking is the ability to send speech to the ELK and getting the temperature display from those zones set up for temperature.

Thanks Gary

Link to comment
Share on other sites

@Jimbo Hi, I just discovered that the analog or temperature zone voltage readings are not being updated with a query. Tried querying manually and with a program. Restarting the node server brought in the current voltages but won't respond to queries after that.

Thanks Gary

UPDATE: After turning on 'Set Poll Voltages True' I now see voltage updates. I guess that is for all zones. I normally only needed to query 1 zone every three minutes for outside light level but this works great now.

Thanks

Link to comment
Share on other sites

@JimboHi, if I may I would like to make a suggestion concerning polling zones. I like the fact that the NS does the polling for voltages on zones and I was wondering if polling zones may be set up like how range of outputs is configured. That is zone numbers that one would like to be polled could be entered as 10-12,14,16. for example. Seems that it would cut down on some ISY traffic and resources.  However just a suggestion. 

Thanks very much for the ELK NS

Gary

Link to comment
Share on other sites

@JimboHi, if I may I would like to make a suggestion concerning polling zones. I like the fact that the NS does the polling for voltages on zones and I was wondering if polling zones may be set up like how range of outputs is configured. That is zone numbers that one would like to be polled could be entered as 10-12,14,16. for example. Seems that it would cut down on some ISY traffic and resources.  However just a suggestion. 
Thanks very much for the ELK NS
Gary
Great idea..I was also thinking to make it an option on each zone that could be set in the admin console. But configuration option might make more sense.

Sent from my Pixel 6 Pro using Tapatalk

Link to comment
Share on other sites

  • 2 months later...
On 1/3/2022 at 5:18 AM, garybixler said:

@Jimbo Hi, I just discovered that the analog or temperature zone voltage readings are not being updated with a query. Tried querying manually and with a program. Restarting the node server brought in the current voltages but won't respond to queries after that.

Thanks Gary

UPDATE: After turning on 'Set Poll Voltages True' I now see voltage updates. I guess that is for all zones. I normally only needed to query 1 zone every three minutes for outside light level but this works great now.

Thanks

I tested this with latest version and when querying a zone it does sent back the voltage, this shows it sends CV=7.3

2022-04-01 19:24:36,160 Command    udi_interface.interface DEBUG    interface:send: PUBLISHING {'set': [{'address': 'zone_78', 
'driver': 'ST', 'value': 0, 'uom': 25}, {'address': 'zone_78', 'driver': 'GV0', 'value': 2, 'uom': 25}, 
{'address': 'zone_78', 'driver': 'GV1', 'value': 0, 'uom': 2}, {'address': 'zone_78', 'driver': 'GV2', 'value': 1, 'uom': 56}, 
{'address': 'zone_78', 'driver': 'GV3', 'value': 3, 'uom': 25}, {'address': 'zone_78', 'driver': 'GV4', 'value': '0', 'uom': 25}, 
{'address': 'zone_78', 'driver': 'GV7', 'value': 0, 'uom': 2}, {'address': 'zone_78', 'driver': 'GV8', 'value': 1, 'uom': 25}, 
{'address': 'zone_78', 'driver': 'GV9', 'value': 2, 'uom': 25}, {'address': 'zone_78', 'driver': 'CV', 'value': 7.3, 'uom': 72}]}

If you put logging in debug mode then you should see that.

Link to comment
Share on other sites

Thanks, but I have been using the global 'Set Poll Voltage True.  Works great and no need for a timer to be running on the ISY.

I am hoping the query voltage and temp could be a selection on the selected zone itself in the future.

Thanks Gary 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...