Jump to content

ISY Asleep?


Recommended Posts

Hello all, somewhat new to this all but getting familiar with everything none the less.


To the point:

I have a KPL in my kitchen, and each button has a program in my ISY-26.

Pressing said button will turn on lights.

If I have not touched anything in a while, pressing the button does nothing.

If I turn it off, and press it again (to make it execute the On Status ON) the lights behave normally and come on.


It seems that the system falls asleep after half an hour or so and the first command seems to "wake it up" but once its "awake" everything is just fine.


Anyone else had this issue?


I'm using the latest stable build 2.6

Have a "small" sized Insteon network (10 total devices), using Access points on both phases.

Link to comment
Share on other sites

Hello Falco:


I can't say that I've seen this problem before. But I've seen simialr issues. Here's something to try:


Wait for "a while", long enough so that the problem should occur on the next attempt, and then open the ISY Admin Console prior to pressing any KPL buttons. Look at the status of those KPL buttons. They should accurately reflect your current button statuses.


If they don't, or they are "blank", then there is a problem. You could try doing a "Restore Device" on that KPL. That should fix any flaky button status issues.


If that doesn't fix it, you can try removing the KPL completely from your system, and then adding it back in. But as of ISY firmware 2.6, the Restore Devices will probably fix issues such as this.


Best wishes,

Link to comment
Share on other sites

If I understand your issue correctly, you could simply create a scene for what you are trying to accomplish instead of using programs. Have you tried that?


See This Thread


In regards to the ISY being "asleep" it seems that the "trigger" for the program didn't like the "status" condition. Changing that to "control" solved everything.


Before then, I had not found any documentation on the differences of "status" vs. "Control" as to someone new coming in they may appear to do similar functions.


Issue Resolved.


Thanks for all your help!

Link to comment
Share on other sites

Hello Falco:


I also had a time when "status" didn't work correctly on certain KPL buttons.


There was a problem with the way the KPL had saved the links. The problem did seem to be reproducable, however. So if one button was not sending a status, it never would.


At that time, I and others who had this problem were able to fix it by removing the KPL completely from the network, and then re-adding it.


That was before Chris Jahn at UD fixed the "Restore Device" command. Now that "Restore Device" is working correctly (as of version 2.6), it would probably also fix said problem.


Otherwise, the ISY should receive "Status" and "Control" equally as well, IMO.


Unlike other Insteon device, I don't think you can actually "query" a KPL secondary button as to its status. The secondary button status command only gets detected by the ISY at the time that its status is actually getting changed, as far as I remember.


Best wishes,

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...