Jump to content

Output Status Blank At Startup


Recommended Posts

Last week we had lots of thunderstorms and the power was flickering a bunch. I have a UPS that powers my ISY, Router, Modem, and Elk XEP. Everything worked great through the storms, until a couple days later the UPS died. So much for the "U" in UPS!


This of course caused a reboot of the ISY and XEP unit. I then noticed my sprinkler didn't run.


       Time is  6:00:00AM
   And Elk Output 'Output 102' is Off

       Set Elk Output 'Output 066' On for 2 Seconds  [THIS CAUSES ELK TO EXECUTE THE SPRINKLER PROGRAM]

  - No Actions - (To add one, press 'Action')


The summary said the program was "false" at 6am when it should have been true. I checked the output status and it was blank (as were most of them). I assume "blank" does not qualify as "off" so it went "false" and didn't run.


My concern is that when power to the system restored, the outputs weren't queried. I don't believe there is a programmatic way to force an output query. Manually running the query seems to have put things in order, but if this had happened while I was out of town, trouble would have ensued.


This was reproducible as I ended up rebooting the system a couple times over a few days as I worked on the UPS.


Is there something I am missing here that can prevent this problem or would an ISY firmware change be needed?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...