Jump to content

Installed eKeypad, now all my programs are missing!


Recommended Posts

I installed eKeypad on my iphone last week. Immediately afterward all programs in ISY are gone, and I can't add any new programs to ISY. When I try to save a program it says Platform Errors 10108, and it won't let me save it. So where did all the programs go?

 

It looks like the went to eKeypad, but I don't seem to be able to manipulate them at all. Is this normal?

 

Thanks,

 

Chris

 

eKeypad ver 2.8.o

Link to comment
Share on other sites

Thank you Michel,

 

I cleared the Java cache and installed the program from the link. No change. I tried it two more times and I still have no programs under the ISY program.

 

I don't know if the following is relevant, but I'll include it just in case. When I try to add a new program I get and error message

"Platform Errors 10108

[Check log]" then if I click OK, I get

 

"Invalid/incorrect program key

[Http]" if I click OK, I get

 

"Bad Request"

 

Thanks,

Chris

Link to comment
Share on other sites

Michel,

I don't think I have any other Admin Consoles open. This began immediately after installing eKeypad Pro.

 

I access ISY through my notebook and desktop computers. The information in my previous post was from the notebook. I noticed last night that the desktop information differs.

 

Desktop computer:

I cleared the Java cache and went to the link you provided. Same reading on the PLM. Still, no programs, nor could I save a new program. When trying to save a new program the following error messages appear:

 

Invalid/incorrect program key

[HTTP]]

 

I click "OK" and I get:

 

"Bad Request"

Link to comment
Share on other sites

Well that's a good question! I know I can delete it and apple itunes will reinstall it. But I don't know about turning it off; I'll got through the menus again, but I don't think there are any instructions for this program.

 

I do have everything backed up on hard drive so if that helps us i can just restore it.

 

I'll try turning off or deleting.

 

thanks,

 

Chris

Link to comment
Share on other sites

Chris,

 

I am sorry you are having this issue. Michel emailed me last night and I have been looking into this issue to re-verify eKeypad interaction with the ISY.

 

I can confirm for you that I am not receiving any other reports of this behavior and I have been unable to replicate the same behavior on my system. In the email chain I see some speculation on possible actions that eKeypad may be performing but none of those could be the cause.

 

Michel suggested a possible issue with saving the programs. I am able to rule this out as eKeypad is focused on usage of the ISY system. It does not attempt to be a management platform. As such commands like creating new programs are not supported. eKeypad focuses on the much less invasive commands of running programs and enabling/disabling programs.

 

The re-sync button in eKeypad is also unlikely to be the root cause of the issue. This command only queries the ISY for its configuration details. It makes no configuration changes.

 

Now that your ISY has been restored. Have you reloaded eKeypad? I am very confident that you will not have this issue again. While I can not explain what caused the issue I am very confident that eKeypad was not the cause. I think it is more likely coincidence.

 

In either event please do not hesitate to email me for support. I will be more than happy to help you with any issues or questions you may have. You can email me directly from within eKeypad. Look on the support screen.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...