Jump to content

most of my kpls have record mismatches


johnnyt

Recommended Posts

I was checking device links tables using a KPL to generate traffic in an attempt to troubleshoot an intermittent comm trouble spot in my kitchen area. The area comm can vary from hops left 2 down to 0 depending on the time of day or the alignment of moon and sun - not sure what exactly. For fun I did a compare while I was there and it showed a couple of record mismatches. I went through and checked other KPLs and found only one that didn't have record mismatches. For the mismatches I checked, they were not insteon addresses I could find under My Lighting, i.e. not devices on my network, according to ISY anyway.

 

I religiously follow the prime directive and link all my devices to ISY, never to themselves outside ISY.

 

The ones I checked showed addresses like 15.A1.CF in the device and 15.A1.FF in the PLM. I didn't check them all but this was the case in a couple of instances. Seems like kind of a strange coincidence that the addresses were so close.

 

I have had some intermittent weird things happen in my (problematic) kitchen area like turning a scene on, having all the lights in it go on as expected, then having one of the lights go off. In one case that I investigated I attributed it to what I noticed in the log was a command to turn another device off at the same time or within a second. The rest of the time, I would just write it off as related to my intermittent powerline comm issues. Weird things don't happen that often (although enough to degrade the WAF a little) and not consistently enough to blame an errant link in the affected device.

 

I didn't investigate all mismatches but have restored all the devices, checked them again and they are fine now. Will check them again in the future but wanted to mention it here in case someone has a suggestion as to what might be happening.

Link to comment

by the way, sometimes when restoring the device, the green "writing" arrow would disappear rather quickly even though the event viewer was still showing lots of updates being sent out for quite a while after. Kind of a problem if one doesn't have the event viewer open, perhaps thinks things are done, and tries other stuff that struggles as it competes with the device restore traffic. This was intermittent - noticed it once or twice as I went through restoring 6 KPLs.

Link to comment

Ended up missing a couple of KPLs in my sweep. Both of those had at least one record mismatch. One had records missing. In the latter case I decided to take a before and after screenshot. For the others previously I did save the file but the XML produces means nothing to me, while screenshots I can read, even if I'm not clear on what all the codes mean. If the xml would be of use, I can post one of those from previous compare.

 

I tried to upload the before-and-after (restore) screenshots I took combined into one image but got the message that board attachment quota has been reached (which had been fixed a few days ago but I guess is back). In hindsight I think I should have tried reading the device table again - Could missing records be because the query quit midstream for some reason? Although most of the events were hops =2, there were some 1's and 0's, as well as a bit of normal (other) traffic happening.

 

I'll try again to upload tomorrow or in a few days...

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...