Jump to content

have to push mini remote button twice?


steffen707

Recommended Posts

I'm new to insteon and isy.

 

I got my isy all set up, and have the kitchen light set up with a in-line-linc. I have a motion sensor and just got a mini remote.

 

I had the kitchen light set to go on when the motion sensor sees motion, and then after the motion sensor stops seeing motion for 6 minutes it turns the light off.

 

I want to add in the mini remote, and its set at 8 scene toggle.

 

I created a scene called kitchen light, have the in-line-linc set up as the responder, button "H" as the controller. I made a program for if motion sensor is on, then nothing, else, turn the "kitchen light scene" off.

 

The light only goes on now if you push the button on the remote, and will go off if you push the button again, or 6 minutes after no motion detected; however....

 

When you walk back into the room and push the button the led blinks red, then you have to push it again to turn the light on, and the led blinks green, even though the scene controller and responder are both in the "off" position.

 

Is there a way to fix this, so that when the light goes off, i just have to push the button once to get it to turn on? I bet if i set it to 4 scene, and the H is for on, and g for off this will work, but i want to be able to use the other 7 buttons for more scenes, instead of limited to 4.

Link to comment

The Mini Remote is not very flexible when setting button modes. The only way to solve the problem is to have the Mini Remote button (both On and Off commands) trigger an ISY Program. The Program checks the Status of the in-line linc, turning it On if Off and Off if On. That way it does matter which command the Mini Remote sends.

 

The ISY Scene with the Mini Remote as a Controller has to be deleted.

Link to comment

Can it be fixed? Almost certainly. However, the cause could be a variety of things. Could be the program. Could be the scene definitions and on levels. I am not sure that I can positively identify the cause from what is written. It is often helpful to post the programs, and identify all relevent scenes, including controllers and responders.

I had the kitchen light set to go on when the motion sensor sees motion

The light only goes on now if you push the button on the remote

 

OK. It once worked and now does not. What changed? What originally caused the light to come on in response to motion...a program or a scene?

 

I created a scene called kitchen light, have the in-line-linc set up as the responder, button "H" as the controller.

By itself, I do not expect this to cause your light to stop responding to the motion sensor.

 

I made a program for if motion sensor is on, then nothing, else, turn the "kitchen light scene" off.

I don't expect this to cause your light to stop responding to your motion sensor. I am curious, however, where is your six minute wait period defined. Is this in a program somewhere?

 

Is there a way to fix this, so that when the light goes off, i just have to push the button once to get it to turn on? I bet if i set it to 4 scene, and the H is for on, and g for off this will work, but i want to be able to use the other 7 buttons for more scenes, instead of limited to 4.

 

Yes, I think I could come up with a program for this, but the other issues should be solved first.

 

My suggestion is to start by posting all the programs you have that are triggered by, or impact the kitchen lights, motion sensors, or scenes that include the kitchen lights or motion sensors. Also clarify how you have the 6-minute countdown enacted, if not by one of these programs.

Link to comment

The Mini Remote in 8 Scene mode has that characteristic. With a KPL the button could be turned Off from another Controller. With the Mini Remote (Old RemoteLinc2) going to sleep it is not possible to alter the On/Off/On/Off pattern of a button when in 8 Scene mode.

Link to comment
The Mini Remote in 8 Scene mode has that characteristic. With a KPL the button could be turned Off from another Controller. With the Mini Remote (Old RemoteLinc2) going to sleep it is not possible to alter the On/Off/On/Off pattern of a button when in 8 Scene mode.

Well i guess for making this the most user friendly for my wife, i'll just change it to a 4 scene, so she doesn't have to think about it. "Did it blink green, or red", lol

Link to comment
The Mini Remote is not very flexible when setting button modes. The only way to solve the problem is to have the Mini Remote button (both On and Off commands) trigger an ISY Program. The Program checks the Status of the in-line linc, turning it On if Off and Off if On. That way it does matter which command the Mini Remote sends.

 

The ISY Scene with the Mini Remote as a Controller has to be deleted.

I tried your suggestion, and while i got it to work by a simple if switch h is on, or if switch h is off, and inline linc is off, then inline linc on.

 

and made a seperate program, if switch h is on, or if switch h is off, and inline linc is on, then inline linc off.

 

It worked fine, but there is a delay when you push the button and it turns the light on or off, i suppose that's the nature of the signal going to isy, calculating the program, then spitting out the command over the network, where as a scene with a controller and responder just sends the command right over the network for faster response?

 

I think i'll change it to a 4 scene, because i like the light coming on ASAP and so would my wife, and it will be easier for her to know, H is always on, and G is always off.

Link to comment

steffen707

 

Yes, using a Program does add a delay. The 4 Scene Mini-Remote takes it back to a direct Controller to Responder message. As I mentioned earlier the Mini Remote is not very flexible. Because it is battery powered and sleeps to extent battery life some of the nice things that can be done with a KPL button cannot be done with the Mini Remote.

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...