Jump to content

Error - Cannot Determine Insteon Engine


Recommended Posts

Hi Everyone-


Happy Holidays!


I just received a #2450 I/O Linc (v2.3) for a garage sensor.  I tried to add the device in the 994i, and received the message:


New Device Error

Cannot Determine Insteon Engine


Device is connected to a magnetc switch on the Ground and Sense terminals. Also tried without switch connected. Any thoughts on what is going on, and how I can get the device linked?

Link to comment

The I/O Linc is powerline only (no RF) so good powerline communication is required.   The Query of the Insteon Engine is the first command issued so it sounds like powerline comm to the I/O Linc location is poor.   Run Tools | Diagnostics | Event Viewer at LEVEL 3.   Factory Reset the I/O Linc and use New INSTEON Device.   Post the event trace.


Be sure the 120v coupling is working as well. 

Link to comment

I also have an I/O Linc for a garage sensor. I tried to add the device to my ISY 99i firmware 3.3.10 and receive the same Cannot Determine Insteon Engine error message.


Factory reset has been performed and I still receive this error.


Here is the Diagnostic Event Viewer Level 3 output (pretty limited):


Mon 12/15/2014 10:18:46 PM : [1F A 2D     ] Added to list of devices to link to ISY
Mon 12/15/2014 10:19:07 PM : [1F A 2D 0   ] Failed to add device

I have over 30 Insteon devices in my house and this is the only one that the ISY 99i cannot add/see in the Admin Console.


Any ideas?



Link to comment



That is not a LEVEL 3 event trace.  With the IO Linc being powerline only and in the garage there is likely a powerline comm issue to the garage.  Could be something in the garage generating interference.  Could simply be poor powerline comm that far away.   

Link to comment



I removed the I/O Linc from the garage and plugged it into an outlet inside my house where I have connected all of my other Insteon devices to configure and enter them into the Admin Console. I still receive the same error message. Nothing has changed.



Link to comment

I had the exact same problem when I got my ISY, had no issues before or with the Vera's built in Insteon or the Insteon Hub app, but no luck with the ISY.  I did those tests to find out what phase everything is on, and found out the PLM was on a different phase than the garage (even though many devices are on the other phase and worked fine).  So I moved the PLM to a different outlet on the same phase, and the issue immediately went away.

Link to comment

416to305, your experience indicates the you (your devices) have not adequately bridged the opposite legs of the split, single-phase electric supply. A Range Extender or two should solve the problem and allow you to install the PLM in its original or any other convenient location.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...