Jump to content

KeyPadLinc LED light for button A-D 2334-2 v.45


stevewier

Recommended Posts

I have buttons A through D set to toggle on mode and would like them to stay lit/always on.  I tried setting the on level to 7 and off level to 15. I'm not sure what that settings is for but it did not work.  Is there another way to set the led to always on for these buttons?

 

Thank you

Steve

Link to comment

The maximum values for LED Brightness are

 

Off=7

On=15

 

Toggle mode is On/Off so as the button is pressed it cycles from On to Off to On to Off

 

Non-toggle mode can be non-toggle On where the the button press always sends an On command and the button LED is bright, or non-toggle Off where the button press always sends an Off command and the button LED is dim.

 

A Program can be triggered with a button press and the button LED turned On (max bright) or turned Off and the button LED is dim.

Link to comment

If I set the brightness at Off=7 and On=15 for the KeyPadLinc, that does function as expected an all the buttons are set to Off=7 and On = 15 or whatever settings I choose.  However, buttons A-D are at level 7 even though they are in non-toggle On mode.  I would like them to be at level 15 always.  Any ideas? 

Link to comment

The LED Brightness applies to all buttons.  Not possible to set individual button LED Brightness

 

Don't follow what is happening with A-D buttons.   In non-toggle On mode the button will blink twice when pressed and go to LED Brightness for an On button.

Link to comment

I have two that are configured the same way and behave in the same manner.  Both are brand new (ordered from smarthome)  and were factory reset prior to programming and again after programming (factory reset and restored) when the LED lights on button A-D would not go to level 15 when set to non-toggle ON mode.    

 

I was hoping the lights would work like the images in the Sonos thread

http://forum.universal-devices.com/topic/11716-insteon-and-sonos-with-isy-994i

Link to comment

Unless SmartLabs has changed the way non-toggle On works, and no other Scene/Program is adjusting On/Off state of button, the KPL is not working as described in manual.  All my KPL buttons in non-toggle On mode are bright after 2 blinks.  I may not the the latest KPL firmware.

 

What is the KPL firmware?

Link to comment

I don't recall the firmware version on my similarly-behaving kpls -- but I definitely have a pair of them where the LED indication does NOT always follow the always-on or always-off mode.

 

I fought with these for days, resetting and changing the mode with the buttons lit and not-lit, until finally I got them to the state where my LED would be always lit (which is what I wanted).

 

Then, one day I noticed that one of them had reverted.  So, I repeated the entire painful process several times until I got it back to behaving.  Weeks later, it reverted again - LED off, would blink on press, and return to off, which is exactly opposite of what I wanted.  I actually left it that way for months until a sudden flash of inspiration led to a solution:

 

a) set the KPL button to the correct mode (always-on, or always-off), ignoring the state of the LED.

b ) create a scene that to be used for nothing but resetting the state of the involved devices - it should include all the KPL buttons that need their backlight state adjusted as responders, with the level set correctly.

c) turn on the scene from the ISY admin console (which is the only way to do it, since it has not controllers listed).

 

If you're struggling with the same problem I've had, then this process will preserve your button "always-on" or "always-off" configuration while allowing you to control the LED light status independently.  Note that once in a while you may have to repeat step c above to reset the LED -- for me this seems to be associated with a comm error or something like that (the KPL will beep when I press a button, and the load won't change state, and the LED will end up in the wrong state again... 

 

I hope I've not interpreted your problem incorrectly - if so, just ignore this post entirely.

 

 

Edited to add: 2334-2 with v43 firmware on both of my odd-ball KPLs...

Link to comment

I believe the firmware is v.45.   I get two blinks and then the LED sets to the OFF level of 7.

 

That sounds like the button is set to non-Toggle Off, not non-Toggle On.

Link to comment

If you look at the attachment in one of my previous posts, you will see that they are configured non-Toggle On.  However, I did look at the status of the buttons and they are all "Off"  which would make sense with the LED light setting. I tried setting them to non-toggle off and the current state remained at "Off" .  If you look at your non-toggle On buttons, what is the current state? 

Link to comment

In looking at this further, it's as though the set to non-toggle On mode is not updating the "Current State" of the buttons. I added the four buttons into a scene as responders with no controller per mwesters suggestion.  I then switched the scene to "On" and all four non-toggle On buttons status went to "On".  I suspect a bug in the ISY994i firmware since the KPL responds to an On State command.  Perhaps the code to update the KeyPadDimmer is missing the "turn the state to On' when setting the button to Non-Toggle On.  My firmware version information is attached.

 

I don't recall the firmware version on my similarly-behaving kpls -- but I definitely have a pair of them where the LED indication does NOT always follow the always-on or always-off mode.

 

I fought with these for days, resetting and changing the mode with the buttons lit and not-lit, until finally I got them to the state where my LED would be always lit (which is what I wanted).

 

Then, one day I noticed that one of them had reverted.  So, I repeated the entire painful process several times until I got it back to behaving.  Weeks later, it reverted again - LED off, would blink on press, and return to off, which is exactly opposite of what I wanted.  I actually left it that way for months until a sudden flash of inspiration led to a solution:

 

a) set the KPL button to the correct mode (always-on, or always-off), ignoring the state of the LED.

b ) create a scene that to be used for nothing but resetting the state of the involved devices - it should include all the KPL buttons that need their backlight state adjusted as responders, with the level set correctly.

c) turn on the scene from the ISY admin console (which is the only way to do it, since it has not controllers listed).

 

If you're struggling with the same problem I've had, then this process will preserve your button "always-on" or "always-off" configuration while allowing you to control the LED light status independently.  Note that once in a while you may have to repeat step c above to reset the LED -- for me this seems to be associated with a comm error or something like that (the KPL will beep when I press a button, and the load won't change state, and the LED will end up in the wrong state again... 

 

I hope I've not interpreted your problem incorrectly - if so, just ignore this post entirely.

 

 

Edited to add: 2334-2 with v43 firmware on both of my odd-ball KPLs...

 

post-6305-0-94294900-1448910942_thumb.jpg

Link to comment

"Perhaps the code to update the KeyPadDimmer is missing the "turn the state to On' when setting the button to Non-Toggle On."

 

Changing the button mode does not change the state of the button.  It takes an activity, Scene On/Off, button press, etc to affect button state. 

Link to comment

Prior to running this trace, I added all the buttons to a scene and turned the scene On.  

All the LED's are at level 15 as I wanted.

 

However, I did run the trace....

 

Mon 11/30/2015 06:51:07 PM : [iNST-SRX    ] 02 50 3B.8E.85 00.00.03 CB 11 00    LTONRR (00)
Mon 11/30/2015 06:51:07 PM : [std-Group   ] 3B.8E.85-->Group=3, Max Hops=3, Hops Left=2
Mon 11/30/2015 06:51:07 PM : [D2D EVENT   ] Event [3B 8E 85 3] [DON] [0] uom=0 prec=-1
Mon 11/30/2015 06:51:07 PM : [  3B 8E 85 3]      DON   0
Mon 11/30/2015 06:51:07 PM : [D2D-CMP 001B] CTL [3B 8E 85 3] DON op=1 Event(val=0 uom=0 prec=-1) is Condition(val=0 uom=0 prec=-1) --> true
Mon 11/30/2015 06:51:07 PM : [D2D-CMP 0019] CTL [3B 8E 85 3] DON op=1 Event(val=0 uom=0 prec=-1) is Condition(val=0 uom=0 prec=-1) --> true
Mon 11/30/2015 06:51:07 PM : [iNST-SRX    ] 02 50 3B.8E.85 33.5E.50 40 11 03    LTONRR (03)
Mon 11/30/2015 06:51:07 PM : [std-Cleanup ] 3B.8E.85-->ISY/PLM Group=3, Max Hops=0, Hops Left=0
Mon 11/30/2015 06:51:07 PM : [iNST-DUP    ] Previous message ignored.
Mon 11/30/2015 06:51:07 PM : [iNST-SRX    ] 02 50 3B.8E.85 33.5E.50 41 11 03    LTONRR (03)
Mon 11/30/2015 06:51:07 PM : [std-Cleanup ] 3B.8E.85-->ISY/PLM Group=3, Max Hops=1, Hops Left=0
Mon 11/30/2015 06:51:07 PM : [iNST-DUP    ] Previous message ignored.
Mon 11/30/2015 06:51:07 PM : [iNST-SRX    ] 02 50 3B.8E.85 11.01.03 CF 06 00           (00)
Mon 11/30/2015 06:51:07 PM : [std-Group   ] 3B.8E.85-->11.01.03, Max Hops=3, Hops Left=3
Mon 11/30/2015 06:51:07 PM : [iNST-INFO   ] Previous message ignored.
Link to comment

Thanks.  Secondary Button A (03) is sending On command (11), regardless of final button LED level.

 

Mon 11/30/2015 06:51:07 PM : [iNST-SRX    ] 02 50 3B.8E.85 00.00.03 CB 11 00    LTONRR (00)

 

Although running 4.4.1 which should have no affect on result, I am going through all my KPLs to see if I can find a difference in button LED levels.  This will take some time.  I'll post back when tests are complete.

Link to comment

I have found a v.43 KPL that also has incorrect non-toggle On button LED response.   It does send an On command each time pressed but the LED goes to Off setting after blinking twice.  

 

The 2E command that sets the non-toggle On/Off setting is the same command that works with the older KPLs.  Since v.43 is sending an On command that part makes sense.   There is another variant of the 2E command (D2=09) that speaks to controlling the non-toggle button LED that is not needed by older KPLs but may be required by the later ones.   It will take some time to test the 2E 09 variant because the PLM address must match (I2CS device).

Link to comment

Archived

This topic is now archived and is closed to further replies.


  • Recently Browsing

    • No registered users viewing this page.
  • Forum Statistics

    • Total Topics
      36.6k
    • Total Posts
      367.9k
×
×
  • Create New...