Jump to content

Enerwave ZW15S Status and Control


Win10IoT

Recommended Posts

I have ZW15S and ZW500D Z-Wave switches that are included in my network. When these switches are turned on or off ISY gets the DON, DOFF and ST messages. However, the following program never gets executed.

 

Switch MBR Wall Switch - [iD 0008][Parent 0001]
If
        Control 'ZW 061 MBR Remote' is switched On
 Then
        Set 'ZW 065 MBR Table Lamp' On
 Else
        Set 'ZW 065 MBR Table Lamp' Off
 

Same happens with Ecolink LTM5 switches.

 

Only one ZW15S program works. This one.

Switch Family Room Fireplace Light - [iD 000B][Parent 0001]

If
        Control 'ZW 031 Family Fireplace Light' is switched On
 Then
        Set 'ZW 070 RGBW A' On
        Set 'ZW 069 RGBW B' On
        Set 'ZW 032 Family Room Lamp' On
 Else
        Set 'ZW 070 RGBW A' Off
        Set 'ZW 069 RGBW B' Off
        Set 'ZW 032 Family Room Lamp' Off
 

What am I messing up? What additional info can I provide to help diagnose? If I force a query on the devices in the if condition, the program gets executed. I have tried using Status in the condition as well.

 

ISY994 Zw Pro v.4.5.4

 

Thanks

Link to comment
Share on other sites

You can't use "if control" with Z-Wave devices. I see you tried "if status" and can't explain why that doesn't work, but "if control" will never work with Z-Wave. Maybe when you changed the program to use "if status" you didn't hit "save Changes"?

Link to comment
Share on other sites

Thanks for the reply. I hit save changes. Logged out. Verified that the changes stuck. No Luck! :cry:

 

 

Switch Backyard - [iD 000A][Parent 0001]
If
        Status  'ZW 034 Backyard Lights' is On
Then
        Set 'ZW 009 Northyard Lights' On
        Set 'ZW 007 Southyard Light' On
Else
        Set 'ZW 009 Northyard Lights' Off
        Set 'ZW 007 Southyard Light' Off
Link to comment
Share on other sites

This program works.
Switch Family Room Fireplace Light - [iD 000B][Parent 0001]
If
        Status  'ZW 031 Family Fireplace Light' is On
 Then
        Set 'ZW 070 RGBW A' On
        Set 'ZW 069 RGBW B' On
        Set 'ZW 032 Family Room Lamp' On
 Else
        Set 'ZW 070 RGBW A' Off
        Set 'ZW 069 RGBW B' Off
        Set 'ZW 032 Family Room Lamp' Off

 
The one below doesn't.
Switch Backyard - [iD 000A][Parent 0001]
If
        Status  'ZW 034 Backyard Lights' is On
Then
        Set 'ZW 009 Northyard Lights' On
        Set 'ZW 007 Southyard Light' On
Else
        Set 'ZW 009 Northyard Lights' Off
        Set 'ZW 007 Southyard Light' Off
Here's the Node Show:
 
Sun 10/30/2016 19:39:47 : [ZW-SHOW         ] ----------------------------------------------
Sun 10/30/2016 19:39:47 : [ZW-SHOW         ] ZW031_1 uid=31 type=4.16.1 mid=282 tid=257 pid=258 model=0
Sun 10/30/2016 19:39:47 : [ZW-SHOW         ]    -  x25  V0  SWITCH_BINARY
Sun 10/30/2016 19:39:47 : [ZW-SHOW         ]    -  x27  V0  SWITCH_ALL
Sun 10/30/2016 19:39:47 : [ZW-SHOW         ]    -  x70  V1  CONFIGURATION
Sun 10/30/2016 19:39:47 : [ZW-SHOW         ]    -  x86  V0  VERSION
Sun 10/30/2016 19:39:47 : [ZW-SHOW         ]    -  x72  V1  MANUFACTURER_SPECIFIC
Sun 10/30/2016 19:39:47 : [ZW-SHOW         ]    -  x85  V1  ASSOCIATION
Sun 10/30/2016 19:39:47 : [ZW-SHOW         ]
Sun 10/30/2016 19:39:47 : [ZW-SHOW         ] ----------------------------------------------
Sun 10/30/2016 19:40:01 : [ZW-SHOW         ] ----------------------------------------------
Sun 10/30/2016 19:40:01 : [ZW-SHOW         ] ZW034_1 uid=34 type=4.16.1 mid=282 tid=257 pid=258 model=0
Sun 10/30/2016 19:40:01 : [ZW-SHOW         ]    -  x25  V0  SWITCH_BINARY
Sun 10/30/2016 19:40:01 : [ZW-SHOW         ]    -  x27  V0  SWITCH_ALL
Sun 10/30/2016 19:40:01 : [ZW-SHOW         ]    -  x70  V1  CONFIGURATION
Sun 10/30/2016 19:40:01 : [ZW-SHOW         ]    -  x86  V0  VERSION
Sun 10/30/2016 19:40:01 : [ZW-SHOW         ]    -  x72  V1  MANUFACTURER_SPECIFIC
Sun 10/30/2016 19:40:01 : [ZW-SHOW         ]    -  x85  V1  ASSOCIATION
Sun 10/30/2016 19:40:01 : [ZW-SHOW         ]
Sun 10/30/2016 19:40:01 : [ZW-SHOW         ] ----------------------------------------------
 

That's the one and only switch of the 25 others that works. Any additional information I can provide?

Link to comment
Share on other sites

Forcing a query and getting the updated status executes the associated program. This is baffling! Help, please.

 

A query will cause the program to run if the resulting status of the switch stored in the ISY gets changed to 'On' (if it was already 'On' in the ISY it wouldn't run).  We'd have to test this switch, but its likely its not sending a message we recognize as a button press.

 

The existing scene support in 4.5.x is very limited.  When you see inconsistency, its mostly due to the many different ways that scenes are (not) supported across and within product lines of the various device manufacturers.

Link to comment
Share on other sites

Thanks for the reply, Chris.

 

I have 25ish Z-Wave on-off switches from three manufacturers Enerwave, Ecolink, Lutron. Same behavior across them all. Lead me to believe I am misconfiguring something or, ISY isn't picking something up. I do see device on/off and status messages in the ISY event viewer. eKey ISY on my iPhone correctly shows the on/off status of the light.

 

BTW, I migrated from SmartThings Hub v2 and the switches were functioning as expected. I don't know enough of the details to say whether ST had special sauce to handle these.

 

Finally, I am not sure how to interpret the scene support comment. These are just z-wave switches and not part of any scene.

Link to comment
Share on other sites

 

Finally, I am not sure how to interpret the scene support comment. These are just z-wave switches and not part of any scene.

 

Yes, but even if the device is not part of a scene, scene support (generically) is used by ISY to detect key presses.  Unlike Insteon, there are several ways of trying to figure out if a key was pressed on a Z-Wave device, and for some devices its not always (or ever) possible to know which key was pressed.

Link to comment
Share on other sites

 
Thu 11/10/2016 16:30:17 : [     ZW034_1]      DOF   0 (uom=51 prec=0)
Thu 11/10/2016 16:30:19 : [     ZW034_1]       ST 100 (uom=51 prec=0)
Thu 11/10/2016 16:30:19 : [     ZW034_1]      DON 100 (uom=51 prec=0)
Thu 11/10/2016 16:30:19 : [   ZW034_155]       ST 100 (uom=78 prec=0)
Thu 11/10/2016 16:30:19 : [   ZW034_155]      DON 100 (uom=78 prec=0)

 

The above log output show that ISY is getting DON/DOF and Status message, right? Yet, I still can't get these triggers to fire and the program to execute.

 

If
        Status 
'ZW 034 Backyard Lights' is On
Then
        Set 'ZW 009 Northyard Lights' On
        Set 'ZW 007 Southyard Light' On
Else
        Set 'ZW 009 Northyard Lights' Off
        Set 'ZW 007 Southyard Light' Off

 

​Help!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...