Jump to content

Trouble linking I/O 2450 to ISY994i


Recommended Posts

Good day everyone, I am having an issue when trying to link the I/O 2450 to my ISY.  I keep getting an error (see picture).  I have tried multiple times, both manually and automatically, same error.  I have installed multiple light switches, outlets, keypads without an issue so I am at a loss to what to do.  Any suggestions would be greatly appreciated.

For the device type, I have been using: (7:00)(2450)IOLink



Link to comment

One thing to know about the iolinc is that it hasn't changed over time... meaning its still single band, no insteon rf. Even if you have a good insteon RF mesh, this may be too far away for the ISY to see it.

I had a problem with mine in my detached garage for that reason.

  • Do you have a spare lamplinc / appliancelinc to plug into the back of the iolinc and try again?
    • If no, can you move the iolinc to an outlet near the PLM or other working dualband device to see if that works?


Link to comment

Thanks for the feedback.  As for the distance between the IOlink and the hub and PLM, its no more than 12 feet. The hub is literally on the other side of the wall. (garage is attached).

I do have a spare lamp plug in, maybe I'll add that to see if it helps.  I will update this post once I have had a chance to try it.

Link to comment

Did you try to link using

Link Management / Add a ControlLinc  and select 07.00 2450 I0Linc ?

Fill in the device address and name and then OK it.

I've found that some devices do not link correctly using standard linking (Click on start linking and then press button on device)

I've always had good results when doing  manual linking from Link Management, especially after the "cannot determine Insteon engine" error shows up, or when Automatic discovery in manual linking does not yield the desired result.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...