Jump to content

Current Version of nodesetup.zip may cause IllegalArgumentException killing programs tab load


BillB66

Recommended Posts

Looks like the current, and possibly the last few versions of nodesetup.zip is causing an unhandled exception in ISY when you click on the programs tab and the programs initially load in 5.0.12+.  I reverted back to an old version I had laying around from 2017 to resolve locally after a complete reinstall did not solve the problem.  After reverting to an old version I was able to edit programs normally.  The only device I have configured is a Honeywell Alarm Panel:

Installed Devices
Ademco     hwalrm1    Honeywell Alarm Panel   

When I updated back to the current the problem reappeared:

2018-12-02 00:11:37 - ISY Receive: ISY node profile editor/I_EDIT.XML updated successfully
2018-12-02 00:11:38 - ISY Receive: ISY node profile nodedef/I_NDEFS.XML updated successfully

I am attaching a screenshot of the stack dump from x,13D, also seeing it from x14.  IllegalArgumentException  I_STAT_VENHCS...  VenstartC

Versions:

2018-12-01 22:55:42 - ISY NodeLink Server v0.9.23 started
2018-12-01 22:55:42 - OS: Linux cairo 4.14.79+ #1159 Sun Nov 4 17:28:08 GMT 2018 armv6l GNU/Linux
2018-12-01 22:55:42 - Mono version: 5.16.0.220 (tarball Mon Nov 26 17:53:18 UTC 2018)

ISY994:  

5.0.12, x.13D, x.14   (5.0.11B and earlier versions seems unaffected)

Error from ISY994.png

Link to comment
Share on other sites

It is puzzling.  Something about my ISY configuration is exposing it.  However, I would rather not have to wipe ISY and restart so I do appreciate you putting out a fix while I wait for the next x.15. 

If I start seeing other issues with isy, that will be my only path.

Thanks,

Bill B.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


  • Recently Browsing

    • No registered users viewing this page.
  • Forum Statistics

    • Total Topics
      36.6k
    • Total Posts
      368.1k
×
×
  • Create New...