Jump to content

Scene with only Zooz ZEN23 switches


DaveStLou

Recommended Posts

I am running 5.0.15a and I'm trying to create a scene with two Zooz ZEN23 switches - one as the controller and one as responder. I've tried various configurations but can't get the scene to respond when I turn on the controlling switch. I do have the controller switch set to Z-Wave Association within the scene.

I thought this switch was compatible with version 5. Am I mistaken or is there something different I need t do with the scene creation or configuration?

Link to comment
Share on other sites

1 hour ago, DaveStLou said:

I am running 5.0.15a and I'm trying to create a scene with two Zooz ZEN23 switches - one as the controller and one as responder. I've tried various configurations but can't get the scene to respond when I turn on the controlling switch. I do have the controller switch set to Z-Wave Association within the scene.

I thought this switch was compatible with version 5. Am I mistaken or is there something different I need t do with the scene creation or configuration?

I have the same question. I dont think that I ever succeeded to have a scene with two (or more) switches, one as controller the other as responder.

BTW last week I purchased my first Zooz switch and when I had a question on parameters, their customer service responded within two hours. Excellent service.

The only remaining issue with that switch is that in my AC it shows the green icon that it needs to be updated. But when I click on Write Updates to Device, nothing happens.

ISY-Events-Log.v5.0.15A__Mon 2019.04.29 05.24.23 PM.txt

Link to comment
Share on other sites

20 hours ago, DaveStLou said:

I am running 5.0.15a and I'm trying to create a scene with two Zooz ZEN23 switches - one as the controller and one as responder. I've tried various configurations but can't get the scene to respond when I turn on the controlling switch. I do have the controller switch set to Z-Wave Association within the scene.

I thought this switch was compatible with version 5. Am I mistaken or is there something different I need t do with the scene creation or configuration?

We haven't tried this specific switch, but looking at its documentation it should work fine.  Can you open the Admin Console Event Viewer to level 3, and then turn the switch you are using as a controller on and off.  Please post the results here or send them to me in a DM.

Edit:  Oops, I missed this in the documentation:

This on/off switch supports Group 1 with up to 5 devices for lifeline communication. This device will send BASIC REPORT to Group 1 when operated manually.

It sounds like all this ever sends is a BASIC REPORT message, and most other devices require something like a BASIC SET, or BINARY SWITCH SET command to be sent to them to turn on/off.  You may have to use the 'Command' or 'Default' option in your scene.

(Please do post the output I requested in my original post so we can verify this is indeed happening).

Link to comment
Share on other sites

10 hours ago, Chris Jahn said:

We haven't tried this specific switch, but looking at its documentation it should work fine.  Can you open the Admin Console Event Viewer to level 3, and then turn the switch you are using as a controller on and off.  Please post the results here or send them to me in a DM.

Edit:  Oops, I missed this in the documentation:

This on/off switch supports Group 1 with up to 5 devices for lifeline communication. This device will send BASIC REPORT to Group 1 when operated manually.

It sounds like all this ever sends is a BASIC REPORT message, and most other devices require something like a BASIC SET, or BINARY SWITCH SET command to be sent to them to turn on/off.  You may have to use the 'Command' or 'Default' option in your scene.

(Please do post the output I requested in my original post so we can verify this is indeed happening).

Here you go. I included both On and Off -- 

Tue 04/30/2019 09:08:02 PM : [ZWAVE-RX ZW057_1] [20/03] Basic Report val=0xFF ACK,AUTO,EXPLORE From=0x39
Tue 04/30/2019 09:08:02 PM : [ZWAVE-RX ZW057_1] [25/03] Binary Switch Report val=0xFF ACK,AUTO,EXPLORE From=0x39
Tue 04/30/2019 09:08:02 PM : [D2D EVENT   ] Event [ZW057_1] [ST] [100] uom=78 prec=0
Tue 04/30/2019 09:08:02 PM : [     ZW057_1]       ST 100 (uom=78 prec=0)
Tue 04/30/2019 09:08:02 PM : [D2D-CMP 003E] STS [ZW057_1] ST op=1 Event(val=100 uom=78 prec=0) is Condition(val=100 uom=78 prec=0) --> true
Tue 04/30/2019 09:08:02 PM : [D2D-CMP 0034] STS [ZW057_1] ST op=1 Event(val=100 uom=78 prec=0) is Condition(val=0 uom=78 prec=0) --> false
Tue 04/30/2019 09:08:02 PM : [D2D-CMP 008F] STS [ZW057_1] ST op=1 Event(val=100 uom=78 prec=0) is Condition(val=100 uom=78 prec=0) --> true
Tue 04/30/2019 09:08:07 PM : [ZWAVE-RX ZW057_1] [20/03] Basic Report val=0x00 ACK,AUTO,EXPLORE From=0x39
Tue 04/30/2019 09:08:07 PM : [ZWAVE-RX ZW057_1] [25/03] Binary Switch Report val=0x00 ACK,AUTO,EXPLORE From=0x39
Tue 04/30/2019 09:08:07 PM : [D2D EVENT   ] Event [ZW057_1] [ST] [0] uom=78 prec=0
Tue 04/30/2019 09:08:07 PM : [     ZW057_1]       ST   0 (uom=78 prec=0)
Tue 04/30/2019 09:08:07 PM : [D2D-CMP 003E] STS [ZW057_1] ST op=1 Event(val=0 uom=78 prec=0) is Condition(val=100 uom=78 prec=0) --> false
Tue 04/30/2019 09:08:07 PM : [D2D-CMP 0034] STS [ZW057_1] ST op=1 Event(val=0 uom=78 prec=0) is Condition(val=0 uom=78 prec=0) --> true
Tue 04/30/2019 09:08:07 PM : [D2D-CMP 008F] STS [ZW057_1] ST op=1 Event(val=0 uom=78 prec=0) is Condition(val=100 uom=78 prec=0) --> false

 

Link to comment
Share on other sites

11 hours ago, DaveStLou said:

Here you go. I included both On and Off -- 


Tue 04/30/2019 09:08:02 PM : [ZWAVE-RX ZW057_1] [20/03] Basic Report val=0xFF ACK,AUTO,EXPLORE From=0x39
Tue 04/30/2019 09:08:02 PM : [ZWAVE-RX ZW057_1] [25/03] Binary Switch Report val=0xFF ACK,AUTO,EXPLORE From=0x39
Tue 04/30/2019 09:08:02 PM : [D2D EVENT   ] Event [ZW057_1] [ST] [100] uom=78 prec=0
Tue 04/30/2019 09:08:02 PM : [     ZW057_1]       ST 100 (uom=78 prec=0)
Tue 04/30/2019 09:08:02 PM : [D2D-CMP 003E] STS [ZW057_1] ST op=1 Event(val=100 uom=78 prec=0) is Condition(val=100 uom=78 prec=0) --> true
Tue 04/30/2019 09:08:02 PM : [D2D-CMP 0034] STS [ZW057_1] ST op=1 Event(val=100 uom=78 prec=0) is Condition(val=0 uom=78 prec=0) --> false
Tue 04/30/2019 09:08:02 PM : [D2D-CMP 008F] STS [ZW057_1] ST op=1 Event(val=100 uom=78 prec=0) is Condition(val=100 uom=78 prec=0) --> true
Tue 04/30/2019 09:08:07 PM : [ZWAVE-RX ZW057_1] [20/03] Basic Report val=0x00 ACK,AUTO,EXPLORE From=0x39
Tue 04/30/2019 09:08:07 PM : [ZWAVE-RX ZW057_1] [25/03] Binary Switch Report val=0x00 ACK,AUTO,EXPLORE From=0x39
Tue 04/30/2019 09:08:07 PM : [D2D EVENT   ] Event [ZW057_1] [ST] [0] uom=78 prec=0
Tue 04/30/2019 09:08:07 PM : [     ZW057_1]       ST   0 (uom=78 prec=0)
Tue 04/30/2019 09:08:07 PM : [D2D-CMP 003E] STS [ZW057_1] ST op=1 Event(val=0 uom=78 prec=0) is Condition(val=100 uom=78 prec=0) --> false
Tue 04/30/2019 09:08:07 PM : [D2D-CMP 0034] STS [ZW057_1] ST op=1 Event(val=0 uom=78 prec=0) is Condition(val=0 uom=78 prec=0) --> true
Tue 04/30/2019 09:08:07 PM : [D2D-CMP 008F] STS [ZW057_1] ST op=1 Event(val=0 uom=78 prec=0) is Condition(val=100 uom=78 prec=0) --> false

 

Thanks, that verifies it.

Link to comment
Share on other sites

22 hours ago, Chris Jahn said:

Edit:  Oops, I missed this in the documentation:

This on/off switch supports Group 1 with up to 5 devices for lifeline communication. This device will send BASIC REPORT to Group 1 when operated manually.

It sounds like all this ever sends is a BASIC REPORT message, and most other devices require something like a BASIC SET, or BINARY SWITCH SET command to be sent to them to turn on/off.  You may have to use the 'Command' or 'Default' option in your scene.

I think I understand what you mean by "use the 'Command' or 'Default' option" but it doesn't seem to work. Here's what I have from the controller switch viewpoint

image.png.5be5b5c1ce2ddc074a5b8b5d4f569bc1.png

and I've tried both of these settings in the scene:

image.png.3d30fee1405a4f82606e33c0f62df640.png

image.png.6cd5fd610e865f84bff5bd92950ce40b.png

In neither case does the responder switch change when the controller switch is turned on.

Link to comment
Share on other sites

I had a look at the code, and we currently do not automatically map BASIC REPORT as key press.  Unfortunately the use of these command classes is quite inconsistent across devices, and having a single rule for mapping isn't ideal.  We are working on things to make this more customizable per device, but for now, I don't think using the Zooz ZEN23 as controllers in scenes will work for you.  Your best option is to use status conditions in programs.

Link to comment
Share on other sites

7 hours ago, Chris Jahn said:

I had a look at the code, and we currently do not automatically map BASIC REPORT as key press.  Unfortunately the use of these command classes is quite inconsistent across devices, and having a single rule for mapping isn't ideal.  We are working on things to make this more customizable per device, but for now, I don't think using the Zooz ZEN23 as controllers in scenes will work for you.  Your best option is to use status conditions in programs.

That's what I'll do. Keep me in mind if there's any testing I can do. This configuration isn't going away. It ties together two sets of three way switches.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...