Jump to content

Zooz ZEN27 Feedback Problems


Stik

Recommended Posts

I have several Zooz ZEN27 S2 dimmers on their latest firmware and am having problems with them communicating their status to the ISY when the switches are manually activated.  Queries will correctly update the status, but the ISY is not updated when the switches are physically activated.  The event viewer shows the following communications when the switch is turned on:

    Fri 06/12/2020 02:51:12 PM : [ZWAVE-RX ZW040_1] [20/01] Basic Set val=0x63 ACK,AUTO,EXPLORE From=0x28
    Fri 06/12/2020 02:51:13 PM : [ZWAVE-RX ZW040_1] [20/03] Basic Report val=0x63 ACK,AUTO,EXPLORE From=0x28

When the switch is queried,  the following is communicated from the switch:

    Fri 06/12/2020 02:51:32 PM : [ZWAVE-WAKEUP  40.000] Query device ZW040_1
    Fri 06/12/2020 02:51:32 PM : [ZWAVE-TX ZW040_1] [26/02] Dimmer Switch Get ACK,AUTO,EXPLORE To=0x28
    Fri 06/12/2020 02:51:32 PM : [ZWAVE-RX ZW040_1] [26/03] Dimmer Switch Report val=0x63 tgt=0x63 rr=0x00 ACK,AUTO,EXPLORE From=0x28
    Fri 06/12/2020 02:51:32 PM : [D2D EVENT   ] Event [ZW040_1] [ST] [100] uom=51 prec=0
    Fri 06/12/2020 02:51:32 PM : [     ZW040_1]       ST 100 (uom=51 prec=0)
    Fri 06/12/2020 02:51:32 PM : [ZWAVE-TX ZW040_1] [5B/01] Central Scene Get Supported ACK,AUTO,EXPLORE To=0x28
    Fri 06/12/2020 02:51:32 PM : [ZWAVE-RX ZW040_1] [5B/02] Central Scene Supported Report: 2 buttons, 1 masks (identical) m1=0x0000007F ACK,AUTO,EXPLORE         From=0x28

I am guessing the ISY is parsing the ST 100 to get the status and since this information isn't included in the status update when the switch is turned on, it is not able to update the status.  Zooz tech support, however, assures me that the two lines without this information is the normal status update and that the dimmer is operating normally.  While troubleshooting, I installed an older Zooz ZEN22 dimmer and it works flawlessly.  It shows the following in event viewer when the switch is turned on:

    Sun 06/14/2020 04:33:14 PM : [ZWAVE-RX ZW043_1] [20/03] Basic Report val=0x63 ACK,AUTO,EXPLORE From=0x2B
    Sun 06/14/2020 04:33:14 PM : [ZWAVE-RX ZW043_1] [26/03] Dimmer Switch Report val=0x63 tgt=0x63 rr=0x00 ACK,AUTO,EXPLORE From=0x2B
    Sun 06/14/2020 04:33:14 PM : [D2D EVENT   ] Event [ZW043_1] [ST] [100] uom=51 prec=0

    Sun 06/14/2020 04:33:14 PM : [     ZW043_1]       ST 100 (uom=51 prec=0)

Note the additional two lines not included from the ZEN27.  Can anyone confirm what the ISY is looking for to update the dimmer status?  Does it need the ST information to parse?  Is this a problem with ISY or the dimmer?

Thanks for the assistance.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...