Jump to content

RainMachine HD16 Error?


GDavis01

Recommended Posts

I recently acquired a RainMachine HD16 and set it up on my network and set it up as a device on NodeLink.

I actually haven't hooked it up to my sprinklers yet because I still have to get the valve wiring, previously connected to an outside RainBird controller, inside the house, and I'm trying to figure out how to wire the existing Hunter Wireless Rain Clik sensor! In the RainMachine settings, I have not set a sensor. I don't think that any of this should have any bearing on the linkage with NodeLink.

My issue is that when I select, in NodeLink, to 'Enable the Weather Node' is get the error "RainMachine: Poll Error - Index was outside the bounds of the array. [rain1]" and NodeLink stops communicating with the ISY (the heartbeat stays the same). When I uncheck the 'Enable the Weather Node' option the heartbeat resumes.

Here is the output of the log... the first part was when the Weather node was selected, and the second part was after I disabled it and rebooted NodeLink (the stale node is obviously the Weather node):

2020-07-07 11:31:33 - ISY resolved to 10.0.2.141 (5.0.16C)
2020-07-07 11:31:33 - ISY Node Server config detected (profile 1)
2020-07-07 11:31:36 - Location: Web server started on port 8995 [loc1]
2020-07-07 11:31:36 - Relay Server: Started on port 2405
2020-07-07 11:31:37 - RainMachine: Response data - {"access_token": "e1af22fb05f4fa1834e82f6d1294a48fba804ac431ecc8119dc8fddd", "checksum": "7ffd7945efdebfee040500812b203de83a662f1cb9a5eace9236b468c4baba6d69a146b8cfaf580011d291ef780fa0c19542affe01663346", "expires_in": 157680000, "expiration": "Sun, 06 Jul 2025 15:31:37 GMT", "statusCode": 0}(P) [rain1]
2020-07-07 11:31:37 - RainMachine: Poll Error - Index was outside the bounds of the array. [rain1]
2020-07-07 11:32:08 - RainMachine: Poll Error - Index was outside the bounds of the array. [rain1]
2020-07-07 11:32:38 - RainMachine: Poll Error - Index was outside the bounds of the array. [rain1]
2020-07-07 11:32:58 - Relay Server Error: Error: OnClientConnection - Cannot access a disposed object.
Object name: 'System.Net.Sockets.Socket'.
2020-07-07 11:32:58 - DSC Error: Data Arrival Init - Cannot access a disposed object.
Object name: 'System.Net.Sockets.Socket'. [dsc1]
2020-07-07 11:32:59 - ISY resolved to 10.0.2.141 (5.0.16C)
2020-07-07 11:32:59 - ISY Node Server config detected (profile 1)
2020-07-07 11:33:01 - Location: Web server started on port 8995 [loc1]
2020-07-07 11:33:02 - Relay Server: Started on port 2405
2020-07-07 11:33:08 - RainMachine: Login Error - Timeout [rain1]
2020-07-07 11:33:38 - RainMachine: Response data - {"access_token": "acbc69bd042af11871c0b08d04791953996db95e85bd856bbf76e719", "checksum": "7ffd7941663346ee04050a5eace90812b20fa0c19542affe0b8cfaf5236b46862f1cb95efdebfc4baba691ef78080011d2d69a1463de83a6", "expires_in": 157680000, "expiration": "Sun, 06 Jul 2025 15:33:38 GMT", "statusCode": 0}(P) [rain1]
2020-07-07 11:33:38 - ISY Warning: Stale node exists on the ISY (n001_rain1_w)

(I'm not sure what the Relay Server and the DSC errors are... but I get them whenever I reboot NodeLink!)

Any thoughts on what is happening?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...