Jump to content

Java.lang.StringIndexOutOfBoundsExceptions (another one)


MMcGinnis
Go to solution Solved by MMcGinnis,

Recommended Posts

Hi everyone,

I'm having a heck of a time with the Admin Console as of late.   I've been getting a bunch of errors when launching it on my main laptop.   Keeps throwing "socket open java.lang.stringindexoutofboundsexception" which is followed by a slew of other error windows with blank messages (see pic).   The other errors I think are a result of this main one though.   I can kind of punch my way through the other errors and poke around in Admin Console for a few seconds, and I see that the Zwave dongle isn't recognized.   I get Subscription errors.  etc.   (Picture attached for reference)

What's weird is that I can load admin console from my work laptop and it works fine.   (Not perfect though.   The ISY launcher takes FOREVER to load the ISY selector screen.  Like several minutes to load.   But once it comes up, everything works fine.)

Laptop config:  Windows 11... Java version Version 8 Update 351 (removed all old versions/cache for clean install)... using fresh ISY Launcher from https://isy.universal-devices.com/start.jnlp.  Antivirus = Kaspersky Free version.  But during troubleshooting here, I have DISABLED both the Kaspersky Free AV program, as well as Windows Defender (for good measure).  

ISY config:   firmware version 5.3.4... which matches the version of the admin console.  (pic attached to prove)

Router configuration is fine.   No Port Forwarding of any kind.  IP address matches what it should in the router and on the ISY.   

I'm a LONG time user of ISY-99 and now ISY-994 (for last 5-ish years), so I generally know all of the usual pitfalls. This one is stumping me.   I saw that there was a previous thread like this, but they solved by correcting something in the antivirus program.   But if I have everything disabled, I don't know what more I'd be able to do.   

ANY HELP would be appreciated.   Again... important to note that the admin console and ISY functionality work fine on my work laptop.  

Best regards,

-matt m.

blank-errors.png

ISY-version.png

socket-error.png

Link to comment

Have you done this?

Java runtime memory (when Admin Console is very slow to respond)

-      If the admin console is slow to respond, it is likely you need to increase the amount of memory allocated to the Java runtime (JRE).

-      Open the Java Control Panel, select Java tab, press View button, then add or modify the Runtime Parameter -Xmx to the following:

o   -Xmx512m

-      Press Ok to close the window, then Press Apply to save the changes

Link to comment
  • Solution

... and had I read the thread that I just posted, I would have noticed that the answer was in there all along.   (Ugh.)   Credit to @DennisC for his comment (below) on it being likely firewall issue.   I resolved my situation on my personal laptop by connecting to the ISY through HTTPS instead of HTTP.   The connection was successfull, and everything loaded correctly. 

 

  • Like 1
Link to comment
Guest
This topic is now closed to further replies.

×
×
  • Create New...