Jump to content

JRE issues and solution for M2 mac


Recommended Posts

I just updated my laptop that I'll be using for installs and I had a hell of a time figuring out getting the Java JRE installed and running so that the JNLP could launch. 

What I ran in to:

  1. The current JRE installer would not install on MacOS 13.6.1; Installer returned error: "OS error code 1".
  2. Installation of the current JDK was successful. However new versions of Java don't support the web start protocol so the JNLP would not launch. It took me a while to actually read the error message when launching the JNLP to realize that it didn't find a JRE that supported javaws.
  3. After all of that I came across OpenWebStart that promised to be my solution.
  4. After install I tried to launch again but still got the error.
  5. After digging through the documentation I found that I need to associate the .jnlp extension with the new app located in the Applications folder. 
  6. After I did this OpenWebStart was able to download and install the correct JRE and launch IoX finder.

Hope this helps others.

  • Like 1
Link to comment

After some fighting with this install due to some OpenWebStart proxy errors I went back to my original jre 8 installers and they magically worked this time around. I uninstalled OpenWebStart and installed the regular jre and now working well. 

I dropped the start.jnlp file in my applications folder, changed the default Java Icon to the UD logo, and then changed the name so it looks like a regular application. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...