Jump to content

KeypadLinc Main button Control


Recommended Posts

I have a KPL8 in the kitchen. Main controls the kitchen overhead lights.


I have a scene on that same KPL-D to make the kitchen overhead lights dim to 35% when "KPL-D" is on.


I want to have it where if the lights are on at 35% and if "Main" is pressed, the kitchen overhead lights turn on full blast. If the "MAIN" button is pressed again, the lights will return to 35%. Instead what's happening is if the lights are dim to 35% and "main" is pressed, the lights shut off, and then turn on full blast. (However, when they are full blast and then "main" is pressed, the lights dim to 35% which is only half of the behavior I desire). The half of the program that does not work is below:




Status 'Kitchen / Kitchen Keypad D' is On

Or Status 'Backyard / Backyard Keypad D' is On


And Status 'Kitchen / Kitchen Overhead Lights' is 35%

And Control 'Kitchen / Kitchen Overhead Lights' is switched Off



Set 'Kitchen / Kitchen Overhead Lights' 99%



- No Actions - (To add one, press 'Action')


There is another program that [successfully] controls the return to 35% dim level from 100%.


I used to have a different KPL controlling the dimmed scene while the kitchen overhead lights had a regular SwitchLinc. Since there are distinct ON/OFF paddle selections, the programming for that worked perfectly with regard to what I want to accomplish. Please assist and TIA.

Link to comment

If the lights are connected to the Red load wire on the KeypadLinc what you describe is the expected result. When Main LED is On (the KPL load is On) pressing the Main button directs the KPL to turn the load Off. That happens immediately, much faster than the Program can be triggered and change the On Level to something else.


Try changing the Local Ramp Rate to something slower, a few seconds to start with, perhaps slower will be needed. That way the lights will begin to fade down to Off slowly. The Program will have a chance to trigger and change the On Level to 99%. The down side is the load will be slow to ramp on to 99%.


That might be resolved by having the Program turn On a Scene which has Main as the Responder and a fast ramp rate for the Scene Ramp Rate.


Another approach is to put Main into non-toggle On mode so that Main only sends On. The example did not say what is being used to actually turn the KPL load Off. Using non-toggle On mode might present a problem turning the load Off when it should be Off rather than to a different dim level.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...