Jump to content

Basic timer, not working


marvel

Recommended Posts

Hello again,

 

I have a program that isn't working as expected. I have an 8 button keypad in my bathroom; button A is connected to the keypad's relay, which turns my bathroom fan on & off. Button C (right under A), I want to use as a timer to turn A off. So here's the program:

 

If
  Control 'Bathroom KP : C' is switched On
Then
  Set 'Bathroom KP : A' On
  Wait 15 minutes
  Set 'Bathroom KP : A' Off
  Set 'Bathroom KP : C' Off
Else
 - No Actions -

 

Simple enough. The timer works, turns the fan on and shuts it off after 15 minutes, but button C doesn't turn back off when it's done. Any thoughts? I tried reversing the order of the last two items, setting C off first; A still turns off and C doesn't.

 

I tried the same program on a different keypad that's controlling another bathroom fan and had the same results, so I don't think there's a problem with the keypad itself.

 

Thank you for your help!

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...