Jump to content

Comm issues after adding 2334-2 KeypadLinc


mck35222

Recommended Posts

I have a whole house of insteon devices including plugs, switches, dimmers, and keypads.  This has worked without issue for several years, and is now controlled by an ISY 994i.

 

A couple months ago, I had a 2486D v.36 Keypad Linc go bad (lights began continually flashing), and on advice of Smarthome replaced it with a newer 2334-2 v.43 Keypad Linc.  Once I did that, I seem to have lost reliable communication with all of the 2476D SwitchLinc Dimmers w/Beeper v.38.  All devices respond reliably to manual input, but may or may not respond to programs or links made in the ISY program.

 

I contacted Smarthome support and frankly don't feel they really cared to fully understand the problem.  Their first suggestion was to add more dual band devices so I added several dual band access points.  That did not solve the issue.  They now suggest that the v.36 dimmers are very old so "it just may not work."  

 

They had me manually link the devices and test them.  This did work.  Because I could manually link the devices - they declared the insteon devices to be working properly and declared it an ISY issue.

 

I have tried to update a few devices and it does seem to resolve the problem.  However, to upgrade every 2476D v.38 device that is not responding would be cost prohibitive.  Before I even consider that as the solution (which will frankly result in moving to something more reliable), I wanted to take Smarthome's advice and seek the help is UDI.

 

Other things I've tried:

1. Removing the new v.43 keypad at which point reliable communication seems to be restored

2. Restore the devices that are having issues - I can not get through a restoration of the devices without experiencing a communication issue and ISY marking the devices as unreachable.

 

I have searched the forum to see if anyone else has experienced such issues and cannot find any.  Any help of suggestions would be appreciated.

 

Thanks.

Link to comment

It sounds like noise or maybe a plm problem that coincidentally showed up at the same time as the switch problem.

  • Did you have a power outage or spikes around the time the keypad went bad?
  • Are the manually linked devices all near their keypads? This would explain why they worked.
  • Is the PLM relatively far from the keypads in question?
  • Is the PLM near anything noisy like low voltage lights, a TV, a motor of some kind?
  • Is there any chance that something happened to your PLM, did you replace it recently?

Paul

Link to comment

Manually linking a single node at a time versus trying to Restore Device is like comparing Apples and Oranges.  The commands that Set button link a single node are very simple and different than what is needed to programmatically create a single link let alone update a complete KPL data base.  The V.43 Keypad is an I2CS Dual Band device where the v.36 KPL is I2 and powerline only.  It suggests there is some issue with the existing Insteon network now having a Dual Band device where it did not exist before.

 

If the plan is to move away from Insteon there is no sense analyzing the existing Insteon.

 

If the desire is to maintain the Insteon investment paulbates ideas are a great place to start.  Folks on the forum are happy to help in this effort if that is your choice.

Link to comment

Thank you all.  My strong desire is to resolve the Insteon issue and maintain the investment.  The suggestion of moving away from Insteon is only relevant if Smarthome's solution of rebuying newer devices is the solution (which I doubt).

 

For Paul's questions:

  • Q-Did you have a power outage or spikes around the time the keypad went bad?
  • A-Not that I'm aware, but it is possible.
  •  
  • Q-Are the manually linked devices all near their keypads? This would explain why they worked.
  • A- the distance varies.  But they are the same devices that are having comm issues.  However, in response to LeeG, they manual linking I performed at the direction of Smarthome Tech Support was the simplest of links.  
  •  
  • Q-Is the PLM relatively far from the keypads in question?
  • A-Within a 30 Ft radius.  The installation is a converted commercial building, so it is a 25'x50' box on 2 floors.  I lost contact with all 2476D devices which are installed on both floors.
  •  
  • Q-Is the PLM near anything noisy like low voltage lights, a TV, a motor of some kind?
  • A-It is where it has always been, in a closet with an Elk panel.  Regardless, I have a router on the second floor, so I am going to move it there just to try that angle
  •  
  • Q-Is there any chance that something happened to your PLM, did you replace it recently?
  • A-I suppose this is possible.  The PLM with the 99i system did have to be replaced once during the 99i days.  This PLM came with the 994I kit so it is relatively new.  Is there a way to test a PLM or should I just replace it to rule that out?

I failed to say earlier that I have:

1. moved the keypad to another location (two actually) without any change in behavior (StusViews suggestion), and

2. removed the 2476D devices that were having issues and re-added them; also without any change in behavior.

 

The system is on release 4.2.30.

 

 

Thanks again for your suggestions.

Link to comment

Stu's point makes sense. Your answers to my question pretty much eliminates the plm, if other insteon devices continue working as normal. The size of your space is fairly contained for an insteon network.

 

There was a period of time where there were manufacturing problems with kepad lincs, I think the 2011 timeframe? I think that was also accompanied by buzzing and noises coming from the keypad itself.

 

Paul

Link to comment

Being a previous commercial building does it now have residential power (split single phase - 2 120 volt legs) or something from the commercial days?

 

What does Tools | Diagnostics | PLM Info/Status show for PLM firmware (xx.xx.xx ???/Connected)?

 

With likely little Dual Band devices running a PLM beacon test may be limited. Tap the PLM Set button 4 times. How are the Dual Band devices reacting as far as Status LED (color and blinking)?

Link to comment

Like LeeG, your comment on this being an old Commercial building caught my attention:

 

1) Possible that you have "true 3-phase" power.  Voltage across the mains (legs) would be 208 rms rather than 240.

2) Possible that your RF communication is being blocked by fire-breaks, metal, and other construction materials not commonly found in residential construction.  As LeeG indicated, check your coupling between RF devices - make sure your phases are STILL coupled.

 

 

Link to comment

paulbates

 

Having network wide issues from adding a single Dual Band device is very odd. I've not seen anything related to how coupling is being performed (is it RF or passive) which would even be more odd if RF coupling is used but a single new Dual Band device creates such issues. Need more information about the electrical environment which might add clarity. When such an odd situation exists there is often some additional information not yet known that allows the pieces to fit together.

Link to comment

Thank you for all the great suggestions. 

 

Fortunately the problem seems to be resolved.  Unfortunately, I'm not exactly sure why or how.

 

While performing the steps you guys suggested above (specifically getting the Firmware of the PLM), the admin console hosed up and I had to restart Chrome.  I continued to get comm issues with these devices.  Due to an unrelated issue - I rebooted the server.  A java update was offered, so I updated Java and restarted Chrome.   The applet, of course would no longer run.  In the interest of time - I fired up IE and went about my business.  I noticed, one by one, the green 'write pending' icons were slowly disappearing.'  Long story short, I was then able to drop the troubled devices, add them, and they updated without issue.  Another interesting thing was that the update process was remarkably faster in the IE session than Chrome. 

 

Now - I don't for a minute believe this was the totality of the resolution, but this really is the only thing that I (knowingly) changed.

 

Thank you all for your input and suggestions.  I am truly sorry that I am unable to provide better information as to what the resolution really was.

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...