Jump to content

Problem with light % at different hours


djboombox

Recommended Posts

Hi,

 

Thank you for your assistance and also sorry for my English.

 

I have a 2477d Insteon switch in my bathroom ans it is link to an isy994i. (by a serial PLM).

 

What i would like to do is when i hit the switch, if it is from 8 pm to sunrise, my light will open at 40% . Otherwise (example at 1 pm) if i hit the switch it will open at 100%.

 

My program work well but on the evening, when i hit my switch my light goes to 100% for about a second and then it goes to 40%.

 

In my program i try to call direct the switch and the problem is there.

So i try to call a scene that include my switch and the problem is still there.

 

I have a lot of 2477d in my house. so i try to open my bedroom light (so it is my 2477d switch for my bedroom) with my bathroom switch and my bedroom light does not doing the same problem. But, if i try to do the same thing (same program) from my bedroom switch (i mean open my bedroom light with my bedroom switch at different level depending the time in the day) i have the same problem.

 

So my thinking is, when you hit a switch that is direct link to a light it open it is so fast that the isy994i is not enought fast to respond before that happen so that's why it goes to 100% then 40% 1 second after.

 

Is there a way to fix that ?

 

Thank you for your time :-)

 

DjBoomBoX

Link to comment

Lum. salle de bain soir - [iD 0021][Parent 000F]

If
        From     8:00:00PM
        To      Sunrise (next day)
    And Control 'Lumieres / Lumieres interieures / Lum. salle de bain' is switched On
 
Then
        Set 'Lumieres / Lumieres interieures / Lum. salle de bain' 40%
 
Else
   - No Actions - (To add one, press 'Action')
 

Link to comment

If
          From     8:00:00PM
        To      SUNRISE (next day)
    And Control 'Lumieres / Lumieres interieures / Lum. salle de bain' is switched On
 
    Then
            In Scene 'Scéne_Nommer' Set 'Lumieres / Lumieres interieures / Lum. salle de bain' 40% (On Level)

           Set 'Scéne_Nommer' On
Else
       
 

Link to comment

I dont know whether your problem is related to the speed of the ISY (doubt it) or the nature of insteon devices to complete one task before starting the next. Yes, this can be fixed, and I think stusviews is on the right track here.

 

I believe that you should change responder levels at 8:00pm to 40% and back to 100% at sunrise. Modifying stusviews ideas:

 

If

From 8pm

To

Sunrise (next day)

Then

In scene 'scene nommer' set 'luminieres/liminiers ineriures/lum salle de bain' 40%

Else

In scene 'scene nommer' set 'luminieres/liminiers ineriures/lum salle de bain' 100%

 

Sorry for my language skills. I dont speak anything but english, and probably not well.

Link to comment

Hi guys,
 
Thanks for your help and patience :-)
 
I tested both program above.
 
The program of Stusview is not working for my task because it change the scene when you hit the switch. So when i hit the switch i can see in my isy994i the "system busy" Windows that pop. That mean it make the change in the scene at this point but the light is already on without the new information in the scene.
 
The program of Oberkc could work but the problem is at 8 pm, it change the scene to 40% and at sunrise it change it to 100% (which it is ok) but there is the problem.

 

In my scene "soir" my device "Lum Salle de bain" on the "on level" the program make the proper change depending the time.

But if i click on my device "Lum. Salle de bain" Under the scene "soir" the "On level [Apply locally]" cursor stay to 100% all the time. so when i hit my switch in my bathroom it open my light all the time to 100%.

 

If i change manually the "On level [Apply locally]" cursor it is working (i mean it does not go to 100% then 1 second after to 40%) but in that program it doesnt not change the "On level [Apply locally]" cursor when it is 8 pm to 40%. It only change the "on Level" in the scene". 

 

It is hard to explain. i hope it is understand well from you guys. I try to attach print screen of what i explain above but i cannot see anything here that make that possibility.

 

So at least, there is the program:

 

Soir - [iD 002D][Parent 0001]

If
        From     8:00:00PM
        To      Sunrise (next day)
 
Then
        In Scene 'soir' Set 'Lumieres / Lumieres interieures / Lum. salle de bain' 40% (On Level)
 
Else
        In Scene 'soir' Set 'Lumieres / Lumieres interieures / Lum. salle de bain' 100% (On Level)

Link to comment

Ok. So...instead of changing scene responder level of 'lum. salle de bain' , we need to find a programmatic way to change responder levels when applied locally. I have never needed to do this, so I am uncertain how. The ISY user manual claims that the "adjust scene" action can be used to adjust the ON levels for devices or scenes, so I assume it can be done. Unfortunately, I see no instructions how this is done.

 

is "lum. salle de bain" already a scene controller? If so, use the adjust scene like:

 

In scene 'lum. salle de bain set lum. salle de bain" XX%.

 

If not already a scene controller, perhaps creation a new scene with the single device as controller and use the same action, above.

Link to comment

You cannot set the scene level. You can set the level of a device in the scene.

 

In Scene 'name_of_scene' Set 'name_of_device' 40% (On Level)

Link to comment

You cannot set the scene level. You can set the level of a device in the scene.

 

In Scene 'name_of_scene' Set 'name_of_device' 40% (On Level)

A more accurate statement of this action context would be:

 

In Scene 'name_of_scene_controller' Set 'name_of_scene_responder' 40% (On Level)

 

Of couse, "name of scene controller" can be the name of the scene, itself, if looking to adjust the response to ISY programs or commands.

Link to comment

Hi guys,

 

Stusview: This exactly what i need. I want to update the device level in the scene but when i run that line:

"In Scene 'soir' Set 'Lumieres / Lumieres interieures / Lum. salle de bain' 40% (On Level)" if i click on my scene "soir" i can see "Lum. Salle de bain" "On level" "40%". but if i click on my device "Lum. Salle de bain" Under my scene name "soir"  The "On level [apply locally]" stay at 100%. And the result of that, when i hit the switch it light up at 100%.

 

Oberkc: "In Scene 'name_of_scene_controller' Set 'name_of_scene_responder' 40% (On Level)" are you sure yoy would like to say "In Scene 'name_of_scene_controller' Set 'name_of_DEVICE_responder' 40% (On Level)" ? Because as i can see we cannot "set" a scene but only a device.

 

Thanks :-)

Link to comment

I ran a minor experiment.  In fact, if a device is a scene controller, you can use it in both places (controller and responder).

 

Assuming that 'lum. salle de bain' is a scene controller, I suggest the action:

 

in scene 'lum. salle de bain' set 'lum. salle de bain' 40%

 

If it is not currently a scene controller, create a scene, with it as scene controller, and no other device.  Then use the action statement, above.

Link to comment

Hi sub routine,

 

That would be a good way to do it.

 

The only thing (that I have not mentioned here) is when it will work when I want to go further by managing 3 light intensities by day:
 

- One for day 100%
- One at 40% during evening (between 8 pm and when my "good night" is not on)
- And one for night 20% (while the "good night" is on)

 

Thank you :-)

 

DjBoomBoX

Link to comment

Hi sub routine,

 

That would be a good way to do it.

 

The only thing (that I have not mentioned here) is when it will work when I want to go further by managing 3 light intensities by day:

 

- One for day 100%

- One at 40% during evening (between 8 pm and when my "good night" is not on)

- And one for night 20% (while the "good night" is on)

 

Thank you :-)

 

DjBoomBoX

Have a look at this for three levels. Perhaps this will totally confuse you but it works well.

Help will be  here too as many use this secret technique.

 

I would use a double tap On to get the 100% level.

 

http://forum.universal-devices.com/topic/17495-how-to-use-a-ms-with-lights/

Link to comment

Hi Everybody,

 

Thanks all for your help.

 

A special thanks to Oberkc. He found the solution by discussing offline with him.

 

Basicly the problem was in my program, in "adjust scene", in the field "In scene" a choose the name of the scene BUT when i create my scene and add my bathroom light switch as a controler, in the dropdown list of the same field, it appear my bathroom switch (the device itself). So in the field "In scene" i have to choose the device, not the scene. (i did not saw that before Oberkc told me)

 

Thank you again Oberkc and all the other guys that try to help me :-P

 

DjBoomBoX

Link to comment
  • 4 months later...

OK guys my intention is not to hijack this thread but since I am having the same issue figured we keep this discussion going unless you prefer I start a topic. From searching seems like my program should work but its not. I created a scene with 3 light switches, I have tried adding them all as controllers and responders but its not working, they still come on at 100%:

 

Night Lights - [iD 000E][Parent 000D]
 
If
        From    10:30:00PM
        To       6:00:00AM (next day)
 
Then
        In Scene 'MasterBath NightLight' Set 'MasterBath Toilet Light' 25% (On Level)
        In Scene 'MasterBath NightLight' Set 'Master Bath lights' 25% (On Level)
        In Scene 'MasterBath NightLight' Set 'Master Bath Accent Lights' 25% (On Level)
 
Else
        In Scene 'MasterBath NightLight' Set 'Master Bath Accent Lights' 100% (On Level)
        In Scene 'MasterBath NightLight' Set 'Master Bath lights' 100% (On Level)
        In Scene 'MasterBath NightLight' Set 'MasterBath Toilet Light' 100% (On Level)
Link to comment

 

OK guys my intention is not to hijack this thread but since I am having the same issue figured we keep this discussion going unless you prefer I start a topic. From searching seems like my program should work but its not. I created a scene with 3 light switches, I have tried adding them all as controllers and responders but its not working, they still come on at 100%:

 

Night Lights - [iD 000E][Parent 000D]
 
If
        From    10:30:00PM
        To       6:00:00AM (next day)
 
Then
        In Scene 'MasterBath NightLight' Set 'MasterBath Toilet Light' 25% (On Level)
        In Scene 'MasterBath NightLight' Set 'Master Bath lights' 25% (On Level)
        In Scene 'MasterBath NightLight' Set 'Master Bath Accent Lights' 25% (On Level)
 
Else
        In Scene 'MasterBath NightLight' Set 'Master Bath Accent Lights' 100% (On Level)
        In Scene 'MasterBath NightLight' Set 'Master Bath lights' 100% (On Level)
        In Scene 'MasterBath NightLight' Set 'MasterBath Toilet Light' 100% (On Level)

 

In your scene adjustment you need to scroll the scene pull down list  to the other end, and select the controller units, that are not really scenes.

Link to comment

Does this actually change the local on level depending on time of day? Allowing immediate response when using switch?

 

If so, do you have to create some dummy scenes first? 'MasterBath NightLight' in the example above? Without this, the switch in question doesn't show as an option to adjust a scene?

 

Sent from my HTC6525LVW using Tapatalk

Link to comment

Does this actually change the local on level depending on time of day? Allowing immediate response when using switch?

If so, do you have to create some dummy scenes first? 'MasterBath NightLight' in the example above? Without this, the switch in question doesn't show as an option to adjust a scene?

Sent from my HTC6525LVW using Tapatalk

Yes.

 

but you have to have a scene with a controller and a responder.

 

http://forum.universal-devices.com/topic/17495-how-to-use-a-ms-with-lights/

Link to comment

 So when I create a scene and add a device I add it twice? Once as a controller and once as a responder? 

No.

 

Two different devices. One contrller, like an MotionSensor or a SwitchLinc, and one responder, like a LampLinc or SwitchLinc light controller.

 

Note that a switchLinc is really two devices, a paddle controller, and a dimmer, responder. 

Link to comment

No.

 

Two different devices. One contrller, like an MotionSensor or a SwitchLinc, and one responder, like a LampLinc or SwitchLinc light controller.

 

Note that a switchLinc is really two devices, a paddle controller, and a dimmer, responder. 

So if I understand correctly I would had my switchlinc twice-one for controller and one for responder, bc when I push the button(controller) it will respond with the dimmer in the same switch? Since I am not using a MS just the switch that I want to turn on. Or am I not following? If that is the case could you give me an program example for using a single dimmer switch  that is wired to the load to have a different On-Level during certain times.

 

Thanks

Link to comment

That is pretty difficult, using the same SwitchLinc dimmer paddle and the dimmer circuit. hey are connected inside and the dimmer will turn on to whatever level it is set to when the paddle is clicked at the top. This will result in initially turning your light on to whatever the local level is, and then make a program or scene take over and may result in annoying flashes at 100%.

 

However I have done it by setting a slow ramp into the Switchlinc dimmer...say 2.0 seconds and then beating the ramp  response  with an ISY program.

 

You need to access the admin console devices page and set the ramp speed to about 2.0 seconds.

 

If

... control Switchlinc is switched 'ON'

Then

... run program2 (If)

Else

... ---

 

Program2    (disabled)   <--- we don't want these times triggering this by itself

If

.... from 8:00 AM

... to 8:00 PM

Then

... set Switchlinc  100%

Else

... set Switchlinc  20%

 

Get rid of the scenes in the devices as they will confuse the response and the owner. :)

 

OR

 

You can keep the scenes without a controller item installed and use the above programs to run you scenes instead of just one SwitchLinc.

You will have to program the scenes to preset your bulbs to levels desired first.

Link to comment

That is pretty difficult, using the same SwitchLinc dimmer paddle and the dimmer circuit. hey are connected inside and the dimmer will turn on to whatever level it is set to when the paddle is clicked at the top. This will result in initially turning your light on to whatever the local level is, and then make a program or scene take over and may result in annoying flashes at 100%.

 

However I have done it by setting a slow ramp into the Switchlinc dimmer...say 2.0 seconds and then beating the ramp  response  with an ISY program.

 

 

Okay... I think that I understand better now... This can modify a scene that you call.... but NOT modify the local 'on level' of a switch.  So to have the local 'on level' different depending on the time of day would require some tricks with timing, calling a program, etc.  Would be nice if we could schedule changes to a local switch, but I suspect that this has other challenges.

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...