Jump to content

New ISY user from Insteon Hub, question/problem regarding FanLinc and KeypadLinc...


Recommended Posts

I just installed my new ISY-994i, and have added all my Insteon devices (While removing all old links.)


I Have 6 FanLincs controlled by 6 KeypadLincs.  I've programmed each button to be either a controller or responder so that only one of the fan control buttons (Scene A,B,C,D) is lit at a time.  It's all working, but I don't want the individual buttons to be toggles.  When I press button D (Off), I want the fan to turn off. If I hit button A (High) I want it to either set the fan to high, or keep it as high if it is alrreay in that state.


I've found the "Button toggle" menu under each button, but when I set the buttons to "Non-toggle," the buttons stop working completely (specifically, the buttons behave as intended, but the FanLinc does nothing.)


What am I missing?

Link to comment

Yes, there are 4 scenes for each fan (plus one scene for the fan light, so 5 total.)


It's all working as it should until I turn the toggle off on the KeyPadLinc.  When I turn off button toggle, the keys work as expected, but the FanLinc does nothing.


With Toggle on, the buttons control the fan, but the button behavior is not what I want.

Link to comment

Non-toggle 'ON' is the correct mode for the buttons.


In your admin console - select one of the scenes and post a screenshot. This is what my 'Off' scene looks like:




The button that triggers the scene (in my case 'A') is red - identifying at the only controller in the scene.

Additionally, the scene 'ON' levels are set - with the 'A' button being set to 100%, and all other scene members being 0%.


The other 3 scenes do the same - but with a different button being the scene controller, and that same button being the one that is set to 100%.


Post a similar picture of your 4 scenes, I'm sure we'll be able to spot whats wrong (make sure to make the window big enough to see it all!)



Link to comment

Yes - your button modes are toggle. The High,Med,Low and Off buttons need to be non-toggle 'ON'.


When pressed - it will always turn on. It will also send the scene on command - which also turns the button on - and the other buttons off. This will be true for all 4 buttons.



Link to comment

Set A, B, C and D to Non-Toggle On.


Best regards,

Gary Funk


OK, thanks, the way you worded it got me through it.  I was assuming the "All Non-Toggle" button was just a way to switch the "Toggle On/Off" button for all buttons.


Thanks Again!

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...