Jump to content

Devices cannot be Discovered


Recommended Posts


I've posted this in Mobilinc Support and Alexa support...but thought I'd also try the forums and maybe get an earlier answer. Steve


First, some information:

1.       I run Mobilinc on IOS (v12+).

2.       Mobilinc is set up to run with Alexa using the Mobilinc skill.

3.       I run Universal Devices ISY firmware & UI 4.7.3.

4.       I use Alexa only for commands that run ISY programs (i.e. I have/run no scenes or spokens).

5.       I have followed all of Mobilinc’s troubleshooting steps found on the internet.


My Problem:  In a nutshell, Alexa cannot discover any of my voice programs.


I’ll explain below:

A.      My initial issue with Mobilinc and Alexa,

B.      Things I did to almost fix my initial issue,

C.      My current problem, and

D.      Things I’ve done to try to fix my current problem.




There were some annoyances with Alexa's understanding of some of my commands which were mostly not recognizing differences between similar names.  It also seemed like there were too many devices for the number of voice commands. I decided to "start over" and re-discover my devices on Alexa.  So I “forgot” my devices and tried to “discover” them. Alexa wouldn’t discover any of my voice programs.




I tried several methods to fix this issue but then I finally discovered that Mobilinc required voice programs to be in a “Voice” folder that was directly under the “My Programs” folder.  (See my Side Note below.)  I moved all voice programs to that new “Voice” folder, but it still didn’t work.


What finally worked to nearly fix this issue is that I:

1.       Forgot all my devices under Alexa Smart Home,

2.       Uninstalled the Mobilinc Smart Home skill,

3.       Reinstalled my Mobilinc Smart Home skill,

4.       Re-saved my programs in the ISY Administrator,

5.       Cleared my browser’s cache,

6.       Re-booted my PC.


This worked but created a different problem (which I call my current problem, below).




The actions I took in Section B almost solved my problem. My devices were decreased as I expected. However, Alexa would keep saying there were duplicate devices when in fact there were NO duplicates found in either the ISY administrator or the Alexa devices list. For example, when I’d ask Alexa to turn on Kitchen, it would tell me there were multiple kitchen devices and ask me which kitchen device I wanted to turn on. Again, there is only one voice program in ISY that uses kitchen in the name and there are no multiple kitchen voice devices in Alexa.



So I decided to remove all my Smart Home devices and re-discover them again. Alexa would not find any of the ISY voice programs. I again removed all Smart Home Devices, disabled and re-enabled the Mobilinc Smart Home skill, and tried to re-discover the ISY voice programs. Alexa would still not discover any of the ISY voice programs.


I went one step further by emptying the browser cache before doing the steps above and Alexa STILL will not find the ISY voice programs.


What’s up with this?????





A SIDE NOTE:  The earlier version of Mobilinc instructed me to set up of voice programs said I should create a folder under “My Programs”…can’t remember the name…with two folders, “Mobilinc” and “Voice”, in it and put the programs into the “Voice” folder. I couldn’t find any communication that told me there was a change which said I had to put the “Voice” folder directly under “My Programs”. I’m wondering if this was the cause of the initial problem. In any case…and maybe I missed this…I am disappointed that I didn’t get a clear and direct email to tell me of this change. 

Link to comment
Share on other sites

Thanks atmarosi...

I used the setup guide and went through it a couple times. 

I don't used any spoken or scene names at all.  I only use Voice programs. I have double checked that the "Voice" folder is in only under "My Programs" and all program names are simple (Kitchen, Family Room, etc). I've waited at least 5 minutes for Mobilinc to sync.

The skill I'm using is "Mobilinc Smart Home". I do not use the "Mobilinc" skill. 



Link to comment
Share on other sites

19 minutes ago, atmarosi said:

Sounds like you’ll need some more advanced help from Wes (@InsteonNut) maker of MobiLinc. Have you opened a support ticket?

Yes! Wes reads this group and usually responds very quickly.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...