Jump to content

Failure on Start, Won't Reinstall, Won't Install after Upgrade to PG3x 3.2.1

Recommended Posts

Version 3.1.3 had been working in PG3x 3.1.37.  Upgraded today to 3.2.1 and after reinstalling all nodeservers as instructed in the release notes, only the Ecobee ns is failing to start.  I have tried reinstalling and it failed with the error in the attachment.  Then I removed the ns and tried to install fresh and I get the same error.  Any thoughts on how to remedy this?


8/14/2023, 15:15:45 [pg3] error: createNS: SqliteError: table nodeserver has no column named requestId at Database.prepare (/var/polyglot/node_modules/better-sqlite3/lib/methods/wrappers.js:5:21) at Object.add (/var/polyglot/node_modules/@universaldevices/pg3x/lib/models/nodeserver.js:287:6) at Object.createNs (/var/polyglot/node_modules/@universaldevices/pg3x/lib/services/nodeservers.js:177:16) at process.processTicksAndRejections (node:internal/process/task_queues:95:5)

Ecobee Install Error.jpg

Install Dialog.jpg

Edited by OffToSeeTheWizard
Link to comment
This topic is now closed to further replies.

  • Create New...