Jump to content

Persistent KPL Secondary LED's...

Tom Marek

Recommended Posts

I have a tabletop KPL 6 on a nightstand in the Master BR configured as follows:

Main - headboard reading lamp

A - Master Bath lights

B - Master BR main can lights

C - Kitchen lights

D - All off (set to non-toggle, LED normally off)


I finally figured out a program that seems to shut everything off:


Control 'Tabletop KPL - D Goodnite All' is switched On

Or Control 'Tabletop KPL - D Goodnite All' is switched Off


Set Scene 'My Lighting' Fade Down (hopefully this completely turns off the lights)


When I press the KPL-D key, it flashes twice and everything turns off as expected except the secondary LED's on all my KPL's around the house (assuming the light was on at the time of the all off command). Pressing the secondary buttons turns off the LED's but I want them to turn off when their load turns off. When I use the load's SWL or another KPL secondary button, all the other KPL LEDs track properly. Only when Isy99 issues a command from a program do the LEDs get out of sync.


I created a scene for each load and included all the controlling KPL buttons and appropriate SWL's into the scene. Per ISY support all switches are set to controller so the LED's track.


I've read that the KPL secondary buttons need to be responders but would that not allow them to be linked to the remote loads anymore? Is there a way to easily change from controller to responder? So far the only way I've been able to do that is to delete and recreate the scene. Scene edit capability would be useful...or have I just missed it? :)


Isy Version is 2.6.5. Any suggestions?



Thanks in advance for any suggestions.


Link to comment

Hello Tom, and welcome to the forum.


What you need to do is to create a scene which will be used to turn the KPL button LEDs off. Into this scene, place as a responder every KPL button which controls any of the loads being turned off by the All Off button.


In the Then portion of your program, in addition to turning the My Lighting scene off, also turn off the KPL button scene just created.


There are many other ways to created All Off KPL button controllers, some of which are discussed in this thread: 'All Off' button/status -- one more twist.

Link to comment
Thanks Darrell.

It worked. I guess I don't understand the reletionship between controllers and responders and how that relates to ISY and programming. I appreciate your help.

Hi Tom,


My pleasure! I'm so glad you have it working to your satisfaction.


The reason for the scene is because KPL secondary buttons cannot be directly controlled; they can be controlled only as members of a scene.


Don't worry, you'll very quickly pick it up through usage and through reading the forums and the wiki!

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...