Jump to content

Restore ISY994i after catastrophic failure, can't downgrade firmware for Restore


Recommended Posts

Had a catastrophic failure of my ISY994i, I believe due to a power glitch, forcing a factory reset which was successful. I thought this restored/downgraded the firmware to the current one at the time of manufacture, apparently I was mistaken... Anyway I did an automatic upgrade to 4.3.26, realized I need to downgrade to 3.3.10 in order to restore from my backup. When I try, this happens:


1. Select Manually Upgrade ISY in Java.

2. Defaults to my Documents folder and displays an incomplete list of its contents, a couple random folders.

3. Using a Mac laptop, copious bugs navigating through folders, won't go into detail but when navigating to any folder it displays a small number of subfolders only and not the 3.3.10 zip file no matter where I put it.

4. Tried doing another factory reset thinking it would downgrade the firmware and evidently it doesn't, it's stuck at 4.3.26.


So I can't get to my downgraded firmware 3.3.10 in order to do a restore. Do I need to downgrade to the Java version present with 3.3.10 was the current one or something else?


By the way, if I can't get that restore done, what's the most expeditious to walk the devices and download them and start from scratch with linking and programming if I have to? BIG JOB.



Link to comment

I'm afraid clearing the Java cache (all 3 checkboxes selected) had no effect, the dialog box to find the Firmware 3.3.10 (on the desktop of my Mac) still misbehaves. Not sure how helpful the details are, but it goes as follows:

1. Defaults to "Documents"

2. Select pulldown to go to use mitch (me) does nothing.

3. Go back to pulldown, wait cursor appears, and a small subset of folders appears (no documents).

4. Painfully getting to the desktop folder via these means shows only 3 subfolders from the desktop.

5. Tried workaround placing a copy of the 3.3.10 into the Documents folder (which it defaults to) and it still does not appear.


That second link above opens an empty browser, takes no action, could that be a significant clue?



Link to comment


This topic is now archived and is closed to further replies.

  • Create New...