Jump to content

Failed Enabling Internet Access


branko

Recommended Posts

I am frustrated trying to connect to Amazon Echo in my ISY portal. 

 

Here is my setup:

 

ISY994izw Pro Firmware v.4.5.1

 

My ISP is Verizon FIOS with static IP address

I have Web Server with my Domain on this static IP address that uses Port 80

My router is D-Link DIR-868L

Router DHCP IP address range is 150-200

My ISY is configured with static IP address xxx.xxx.xxx.100

ISY ports are:

Http 8040 and

Https 8041

I try DNS xxx.xxx.xxx.1 (my Router) and as UDI suggested for static ISY IP address DNS 8.8.4.4 (no changes)

My ISY Internet access status is "Disabled" (Do not tell me to ignore this error. You better send email to UDI and tell them to fix that)

When I try to "Enable Internet Access [iSY]" I am getting Error "Failed Enabling Internet Access"

In my router I put ISY IP address and port numbers in "Virtual Server" and "Port Forwarding" but I still can not enable internet access in ISY

 

When I try to access ISY thru cellular network with my cellphone using my domain and port 8040 or 8041 and I can access my ISY even that in Console Help/About it still shows that internet is Disabled. (That probably mean that ISY internet is working and ISY firmware needs to be fixed) 

 

This is important. When I Log in in ISY portal ( my.isy.io) and try to connect to "Amazon Echo" I am getting error "ISY is not online". How in a hell I can put ISY online?

 

If you know solution please post it to help me and to help others. Please do not answer with guessing or if you do not fully understand what is written above. There is to many guessing answers on this forum.

 

We are all buying ISY because there is nothing else on the market that works. UDI knows that and they do not care to fix known issues they just pushing new features.

They do not bother to even fix documentation. All documentation mentioning ISY99i product they don't even support :cry: . 

Link to comment

 

 

My ISY Internet access status is "Disabled" (Do not tell me to ignore this error. You better send email to UDI and tell them to fix that)

When I try to "Enable Internet Access [iSY]" I am getting Error "Failed Enabling Internet Access"

Why not tell you to ignore? That setting is about having upnp auto-enable port forwarding. It has nothing to do with hooking ISY up to the Portal. I won't tell you to ignore the message, but I will tell you this menu option and the message you are getting have nothing to do with the problem you are having connecting ISY to the portal.

 

Most problems getting ISY to connect are either DNS related, or SSL cipher strength related. Please post the error log and I'm sure something can be gleaned from it to assist.

Link to comment

Internet Access as shown in Tools should be disabled. Select Configuration, Portals. You may need to wait a few seconds. What does it show under Portal Configuation?

Link to comment

OK, First response to MWareman.

Thank you.

If Enable Internet Access does not do that it should not be in a menu

If ISY is connected to internet there should NOT be in Help/About "Internet Access Disabled"

Link to comment

Ok, you're right -- "Enable Internet Access" is a poorly-named menu item that does not do what the name suggests.  And even worse, what it DOES do is not supported by most current routers any more.  And you're right about the Help/About text -- it too should not read "Internet Access Disabled", but should probably say something about your router not supporting UPNP.

 

But since portal access has nothing whatsoever to do with either of those two items, just forget about those.  The portal works in the OPPOSITE direction -- my.isy.io does NOT contact your ISY, rather it is your ISY that connects OUTWARD to the my.isy.io portal, and establishes the connection.  So that message is telling you that your ISY has not contacted the portal.  Which has nothing to do with the ability for you or anyone else to connect INWARD to your ISY from the internet.

 

Since your ISY is responsible for establishing the connection to the portal, not the other way around, the error logs and information to debug this are on your ISY.  The error logs, as MWareman suggested, are a good place to start.  When mine refused to connect, it turned out that the problem was exactly as suggested -- the cipher set on my ISY was incorrect, and it was unable to establish a secure connection to the portal until I fixed it.  The logs on your ISY tell the story.

Link to comment

Here is my Error Log. I do not see what I can do here.

 

Time                                          User     Code Message
 
Mon 2016/10/24 10:54:59 AM System -170001 [HTTP:0-29-5] 10.10.10.72:63789->8040
 
Mon 2016/10/24 10:54:59 AM System -170001 [HTTP:0-29]: POST[1]-->/services
 
Mon 2016/10/24 10:54:59 AM System -170001 <s:Envelope><s:Body><u:GetSysConf xmlns:u="urn:
 
Mon 2016/10/24 10:54:59 AM System -170001 [sLF] FileOpen Failed: /CONF/NET/WOL.CFG
 
Mon 2016/10/24 10:55:01 AM System -170001 [HTTP:0-29-5] 10.10.10.72:63790->8040
 
Mon 2016/10/24 10:55:01 AM System -170001 [HTTP:0-29]: GET-->/rest/portal/status
 
Mon 2016/10/24 10:55:01 AM System -170001 [HTTP:0-24-5] 10.10.10.72:63791->8040
 
Mon 2016/10/24 10:55:01 AM System -170001 [HTTP:0-24]: GET-->/rest/portal-server/requests
 
Mon 2016/10/24 10:55:01 AM System -170001 [HTTP:1-29-5] 10.10.10.72:63792->8040
 
Mon 2016/10/24 10:55:01 AM System -170001 [HTTP:1-29]: GET-->/rest/portal-server/active
 
Mon 2016/10/24 10:55:05 AM System -170001 [HTTP:0-29-5] 10.10.10.72:63793->8040
 
Mon 2016/10/24 10:55:05 AM System -170001 [HTTP:0-29]: GET-->/rest/portal/status
 
Mon 2016/10/24 10:55:05 AM System -170001 [HTTP:0-24-5] 10.10.10.72:63794->8040
 
Mon 2016/10/24 10:55:05 AM System -170001 [HTTP:0-24]: GET-->/rest/portal-server/requests
 
Mon 2016/10/24 10:55:05 AM System -170001 [HTTP:0-24-5] 10.10.10.72:63795->8040
 
Mon 2016/10/24 10:55:05 AM System -170001 [HTTP:0-24]: GET-->/rest/portal-server/active
 
Mon 2016/10/24 10:55:12 AM System -170001 [HTTP:0-24-5] 10.10.10.72:63796->8040
 
Mon 2016/10/24 10:55:12 AM System -170001 [HTTP:0-24]: POST[1]-->/services
Link to comment

Thank you all for help.

Let me summarize issues and solutions.

Internet access:

Problem: Help/About shows "Internet Access Disabled" This does not mean anything except if you are using older router. I hope UDI will fix that in a new firmware.

Solution: Do not use File/Enable internet access if you do not have router listed in in Wiki help.

Instead go to you router virtual server or port forwarding if router do not have virtual server. Type in name (https isy) for your ISY, IP address, port number and select TCP.

Enable virtual server you just created.

UDI suggested that you do this only for https. This will require log in on your remote device.

 

Alexa interface

Problem: Create account in my.isy.io Click on connection/Alexa Echo and you are getting "ISY is not online

Solution:You need to buy ISY portal from UDI not network module as I did. In Alexa app or log in online to alexa and select "smart home".  Select "Get More Smart Home Skills" and select "Universal devices"

Go to my.isy.io portal, log in, select tools/connect/Amazon Echo. You should see that is connected.

Click "My profile" link Amazon Echo account. You will need to log in to Amazon Echo account. Log off from portal and Log in again.

Click on Tools/Connect/Amzon Echo. Click on Device and start linking devices. Give them spoken commands.

In Alexa app select Discover devices. There should be same number of devices you are linked in portal.

Try to use Alexa to control devices.

If some device do not work try to change spoken command in ISY portal. Select refresh in Portal and repeat Discover devices in Alexa app. I found that longer command works better with Alexa. For example "Backyard light (ON) works better then "Backyard" (ON).

I do not know if in ISY console when right click on device select "Notes" and in "Spoken", the command needs to be same as in ISY portal,

Dashboard on your cellphone will not update and show status of your device when you use Amazon Echo. I hope UDI will fix this in next app revision.   

 

I hope this will help someone.

I spend lot of frustrating hours trying to resolve this issues. 

Link to comment
  • 3 weeks later...

I am having same issue...so far none of the steps here are working for me.

The networking screen shots on http://www.universal-devices.com/docs/production/ISY994%20Series%20Network%20Security%20Guide.pdf do not seem to match what I see when I log into the ISY Portal.  Have the screen shots changed? Are the instructions in this PDF still valid?

When I go to my ISY  with HTTPS I get a security certificate error, so maybe I am still missing parts of the setup.  I can connect...with I click through the security warnings.

 

I have access to the ISY through the Portal as well as the Mobile APP.  I do not believe I have successfully setup external web access.  my.iso.io shows my ISY as never connected.   I can not connect to the Echo.

 

Any suggestions?

 

 

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...