Jump to content

Adding Razberry Zwave unit as secondary controller


Recommended Posts

Has anyone tried to add a razberry zwave device to their network as a secondary controller?

 

According to what I have read, I thought I would start the isy listening for zwave devices to add, then tell the razberry to include into network on the expert UI -- but so far no success.

 

Thanks!

 

Mitch

Link to comment
Share on other sites

  • 2 weeks later...

Well I had some success tonight -- turned out the Razberry software was set to the wrong frequency -- I got the ISY to add the Razberry board as a secondary controller but it complained about not being able to add it securely, and then added about 19 devices -- 16 dimmer switches, a binary switch, a multi-level switch, and a PC Controller.  None of these devices exist so the ISY is misinterpreting something it is receiving from the Razberry.

 

post-675-0-29168100-1499400184_thumb.png

Link to comment
Share on other sites

yes, I tried this a couple of times and factory reset the Razberry, the ISY Zwave dongle, and one of my other Z-Wave devices an Aeotec multisensor.   BTW, the ISY got confused and refused to add new Z-wave devices afterward and I had to factory reset the Z-Wave  dongle.   Another thing weird about it is the properties of the dimmers all shows the same data as my aeotec multisensor, until I clicked on another device, then they changes to on off -- so the UI was confused too.

 

Now that I have reset everything and rebuilt my zwave network its all working, but the dimmer devices still show up in the ISY, but with no properties.  The Razberry is now secondary controller and sees all my real zwave devices (it does not see the 'not real' dimmer devices)

 

Not a big deal for me at this point as I am just experimenting with Z-wave, but I thought you guys might want to look at it to understand what might be happening.  if you want to see logs or to access my isy, just let me know.

Link to comment
Share on other sites

Michel,

 

Here is the information in screenshots:

 

post-675-0-84228800-1499631803_thumb.png

 

post-675-0-55394000-1499631815_thumb.png

 

You can also see in the Zway expert UI / expert commands where the 16 comes from:

 

post-675-0-35233600-1499632132_thumb.png

 

Whenever I try to execute on of those expert commands, I get error not implemented, so it looks like the zway is reporting something that maybe it shouldn't

Link to comment
Share on other sites

Hi mitchmitchell,

 

Thank you. This switch seems to be multi-channel and that could be the root cause. Most probably this is solved in 5.0.10 but I am not sure whether or not you want to upgrade to an alpha.

 

With kind regards,

Michel

 

Michel -- if you see the about screen I posted, I am already on 5.0.10 -- is there a new 5.x build in the works?

 

BTW, there is no actual z-wave switch involved, only the RazBerry device itself.

Link to comment
Share on other sites

Hi Mitch,

 

Can you try removing (exclude) the Razberry from the ISY and the do a Z-Wave -> Tools -> Synchronize Nodes -> All.  If after the synchronize the Z-Wave nodes still exist, but you don't have any actual real devices in your Z-Wave network then the ISY Z-Wave dongle has incorrect information in it.

 

Factory reset the Z-Wave dongle itself by doing Z-Wave -> Advanced -> Factory Reset Z-Wave dongle.  Although it should be automatic, following this, do a Synchronize Nodes again and you should see all the Z-Wave nodes disappear.

 

Now try adding (include) back the Razberry and see what happens.  If all these nodes appear again then it is definitely (bad?) information coming from the Razberry. 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...