Jump to content

TCP timeouts and SSL connectivity issues to ISY994i ZW/IR Pro

Recommended Posts

Running an ISY994i ZW/IR Pro on v4.7.3; lots of Insteon and ZWave; some x10

Been seeing increased trouble in the past several weeks accessing my admin console - and I noted that my Agave app on my phone stopped being able to access my ISY from the Internet at all. I leave my console running on an always-on workstation and it's frequently hanging up or disconnecting. It also looks like the last several times I attempted to backup the ISY that timed out and failed as well. My workstation and the ISY are 1 hop(switch) away from each other on a gigabit hardwired network - both in the same room. 

My ISY in on an internal(home) network using SSL with a self-signed certificate; I have a firewall with a port open specifically to the ISY which had been working for a year or two. I don't know of anything relevant that's changed in my configuration - though I suppose there have been new Java JREs pushed to my workstation in that timeframe (I have to use IE to access the console at all and it complains about the self-signed cert on the ISY but does allow connections - unlike Chrome); I've added a lot of (mostly ZWave devices) in the past several months though. The ISY itself is controlling my devices - though there are more delays nowadays than there used to be.

I hoped the new release would help things; updated to v4.7.3 a couple weeks ago but that hasn't helped.

I get popups on my workstation (where I'm accessing the admin console) stating:

Socket Open Failed javax.net.SSLHandshakeException: Remote host closed connection during handshake.
Socket Open Failed java.net.SocketTimeoutException

Also tried to access my device from the UDI portal at https://my.isy.io/ - and it says my license is ok/etc; shows my device on the list - but shows offline. I refresh on my admin console (configuration-->portals) and it will sometimes show online for a minute or two - then drops offline again.

Also tried a netcat (nc) from one of my Linux servers on my internal network to both my inside port and the firewall-forwarding port on the ISY and both timeout even with a 45 second timeout.

Also seem to be getting a popup when I reconnect to the console about agreeing to the license agreement... which I click "agree" on each time - but it reappears each time I restart.

So sounds like I have a SSL issue; or my ISY is bogged down and not handling the authentication overhead well anymore?

Suggestions? Not going to factory reset if I can help it - especially with dubious backups... but I obviously need to do something. I have power cycled the ISY a couple times.. that didn't seem to make any difference either.

Thanks in advance;


Link to comment

I would be interested in the solution, as I'm having a lot of the SocketTimeOut exceptions on a ISY I have installed in my vacation home.  Mostly when I access the programming features from the Admin Console.

I use the same Laptop on my main home ISY to access the Admin Console and I don't get the SocketTimeOut's, so I don't think it's the laptop or the version of Java etc.


Scott MacBride

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...