Jump to content

SolarEdge integration?


Pascal

Recommended Posts

Hello,

I am trying to get the SolarEdge server working with my ISY.

  1. I went to Polyglot Cloud and added the SolarEdge notes with the api_key. As far as I can tell this part seems to be working OK.
  2. My ISY shows a new SolarEdge controller but the panel is empty.
  3. The Node Servers menu has a new entry for SolarEdge that let me "Add Node" and this is where I have problems:

I suppose I need to add an Inverter? Then I am asked Name/Node Address/Primary Node Address?

What are those? The SolarEdge API seems to indicate that the query are do to the SolarEdge Cloud with the API key? Are the addresses IP address of my Inverter, SolarEdge website?

Thanks!

 

Link to comment
  • 6 months later...
  • 4 months later...

Hi all, just upgraded to V5.0.15A and am taking my first adventure into Polyglot. I am working on adding WeatherFlow and SolarEdge to my ISY. I was successful with WeatherFlow and that seems to be working correctly, my issue is with SolarEdge. I am seeing the message in the log: Please specify api_key in the NodeServer configuration parameters and did some searching on this forum for that info. I am the administrator of my site so I have the site ID which looks to me like a seven digit number. I see the comments referring to both site_ID and API_key. I am assuming these are one and the same? My question is: add it where? In the NodeServer configuration, I tried adding that seven digit number as a custom configuration parameter under both site_ID and api_key but that has not been successful. What am I missing?

image.thumb.png.e267dfa21b709cf4656d9cae404a869d.png

Link to comment

Where can I find some documentation on setting this thing up so I don't have to keep posting questions? The wiki has very little info and nothing on SolarEdge that I can find. I entered the api_key, the controller node shows up in the ISY but is blank with no information. I see the 4 nodes available to install under the node server configuration but when I select Add all, nothing happens. I'm clearly missing more setup info.

Link to comment

I do know for a fact Michel that I do have Admin Access as that was a struggle with SolarEdge to acquire and I had to use a separate email account to do that. I have the ability to create, modify, and assign profiles to my inverter which requires admin access. I'm going to try to start over and delete what is there and add it again now that I have the api-key value. It's also possible once I generated that key it may have taken some time on the SolarEdge side for everything necessary to propagate. 

Link to comment

I just deleted the SolarEdge from the ISY, re-added it, generated a new api_key, added that to the config parameters, same result.

I don't speak Python but it looks like there may be some errors in this log data (attached), anyone speak Python that can take a quick look? Screen shot from SolarEdge below showing the new api-key, screen shot of the configuration page, and text file of the log.

image.thumb.png.3f960d3620c3c3dacb73bb2774f33d3f.png

image.thumb.png.bf858cb4bf6343b4b3edd8f67986a32c.png

 

solaredge-0021b90250ef-2.txt

Link to comment

I've been following this because I'm going to have a SolarEdge inverter soon and would like to use this node server after it's installed.   So I took a look at your log.  I think the problem is the way that polyglot (and specifically the cloud version) is handling the parameter update.  The node server doesn't get the updated value after you enter it.  Try doing things in this order:

 

1) Install the node server

2) Enter the api_key parameter key and value.  Save the changes

3) Stop the node server

4) Restart the node server

5) Check the admin console to verify the nodes exist.  You should see a SolarEdge Controller node, a Quackenbush1 node with two subnode for battery.

Since you already have the key entered (per screen shot), just start with step 3, stop and restart the node server and it should discover your inverter. 

Link to comment

bpwwer, you are da man! That was exactly it, Polyglot did not act on the api-key it received until stopped and then restarted. I now have 4 entries, 1 for the controller, 1 for the site plus 2 sub-notes under that, 1 for the battery and 1 for the inverter.

Thank you so much! Hope this helps you as well when you get your system.

Link to comment
  • 3 weeks later...

Does anyone else use Sunrun? I was on hold for 2 hours with SolarEdge and they said they can't provide access to the Admin tab to get the API key and that I needed to ask SunRun instead. I purchased the system (not lease) from Sunrun. I called Sunrun, and the best way to describe their support is "confidently deliver complete mis information while frequently putting you on hold". After a wasted morning, they refused to enable to admin tab. Has anyone had success with them or know of the magic phrase?

Link to comment
  • 2 months later...

I'm new to Polyglot and SolarEdge. just added the node server, created the "api_key" <xxxxxxxxxxxxxxxxxxxxxxx> perameter, restarted node server & it did discover 1x controller, 1x site & 1x inverter, however the logs via polyglot show "2020-03-11 19:01:33,574 [NodeServer] [ERROR] Model SE10000H-US000BNU4 is not yet supported: 

when I view controller node in isy, field <NodeServer Online> = True, node Site most fields are blank except for <Production> which shows aproximately "6202.893w"

Will you be adding support for my Model inverter??

Link to comment
  • 1 month later...

My SolarEdge NS has been working just fine for the past couple months at v0.05.  Today I noticed an update was available, so I went through the update process.  The update to V0.06 wouldn't take.  Tried several things (updating Polisy, restarting NS, etc etc) and finally just deleted the old NS and restarted Polisy,  Then Installed SolarEdge NS V0.06, re-entered my api_key and saved it, and restarted the NS.  Admin Console reported V0.06.

Now I'm getting error messages when the program attempts to load my two inverters:

2020-04-23 11:08:39,362 [NodeServer] [INFO ] Requesting site inventory...
2020-04-23 11:08:39,629 [NodeServer] [ERROR] Failed to connect to SolarEdge API: Request-sent
2020-04-23 11:08:40,091 [Controller] [DEBUG] {'powerDetails': {'timeUnit': 'QUARTER_OF_AN_HOUR', 'unit': 'W', 'meters': [{'type': 'Production', 'values': [{'date': '2020-04-23 10:00:00', 'value': 3576.6985}, {'date': '2020-04-23 10:15:00', 'value': 3890.752}, {'date': '2020-04-23 10:30:00', 'value': 3941.508}, {'date': '2020-04-23 10:45:00', 'value': 4051.7908}, {'date': '2020-04-23 11:00:00', 'value': 4620.88}]}]}}
2020-04-23 11:08:40,092 [Controller] [INFO ] Updating Driver xxxxxx - ST: 4620.88, uom: 73
2020-04-23 11:08:40,744 [NodeServer] [INFO ] Found: 0 meters, 0 sensors, 0 gateways, 0 batteries, 2 inverters
2020-04-23 11:08:40,744 [NodeServer] [INFO ] Adding inverter 7F12xxxx-A8
2020-04-23 11:08:40,745 [NodeServer] [ERROR] Model SE3800A-US000NNU4 is not yet supported
2020-04-23 11:08:40,745 [NodeServer] [INFO ] Adding inverter 731Cxxxx-C1
2020-04-23 11:08:40,746 [NodeServer] [ERROR] Model SE3800H-US000NNV2 is not yet supported

Obviously this is an update programming snafu - those exact same inverters have been reporting data for the past two months on V0.05, and I seriously doubt the NS has declared two inverters suddenly obsolete.  I'd say the "fix" offered in the v0.06 update, where "-" was ignored in parsing the inverter IDs, has broken something.

From the Admin Console:

Version 2.2.9-5 Status: Connected
Frontend Version: 2.2.9-5
ISY Version: 5.0.16B
Uptime: 26 Minute(s) 29 Second(s)
(c) 2020 UDI
Running on Polisy
Documentation

Suggestions?

[ Edit: I see the problem in your GitHub code - my inverter model is 'SE3800A' once the alpha-numerics after the '-' are removed.  But you've not included the 'A' at the end of my model name as part of the SINGLE_PHASE set, so when my truncated model 'SE3800A' is checked, it fails and I get that WAY too generalized an error "LOGGER.error('Model {} is not yet supported'.format(inverter['model']))"  Same issue for my second inverter, which has a truncated model = 'SE3800H'.  The error should at least tell me what your code thinks the failed model name is after truncation.

Not sure how v0.05 was working, because the SINGLE_PHASE set didn't include my 'SE3800A-US000NNU4' or 'SE3800H-US000NNV2' model names either. ]

Link to comment

"cd ~/.polyglot/nodeservers/udi-solaredge-poly"

From where? inside github?  I don't understand your instruction.  I can ssh into polisy using admin/admin as un/pw, but there is no .polyglot folder there or above it in the folder hierarchy.

"moved repositories" - I wish I'd received a note or anything when that happened.  I assume that all the github links in the NodeStore now point to the new repo location?  It appears they do, as when I went to SolarEdge's NodeStore link, I ended up on "udi-solaredge-poly/solaredge-poly.py"

If you can be just a tad more explicit I can probably fix this,  or at worst just edit the code running in polisy.

 

Link to comment

Yeah, well ... that might be a problem.  When I ssh into Polisy using admin/admin, and go to /var/polyglot/nodeservers, there is no "udi-solaredge-poly" folder.

What I see there is:

Welcome to Polisy!
[admin@polisy ~]$ cd /var/polyglot/nodeservers
[admin@polisy /var/polyglot/nodeservers]$ ls -alt
total 7
drwxr-xr-x  5 polyglot  polyglot  16 Apr 23 12:53 SolarEdge
drwxr-xr-x  7 polyglot  polyglot   9 Apr 23 11:38 ..
drwxr-xr-x  5 polyglot  polyglot   5 Apr 23 11:03 .
drwxr-xr-x  6 polyglot  polyglot  18 Apr 16 01:15 WeatherPoly
drwxr-xr-x  6 polyglot  polyglot  14 Jan 11 18:28 EnvisaLink-DSC

I'm getting the impression I've missed some kind of big update on the polisy device, if my folder structures don't match what's current.  Should I be resetting Polisy back to its default state, then start over loading NS's from the new repo location?  If there are instructions somewhere in the forum on all this activity, just point me at them and I'll do the rest.

Or did you intend that I should mkdir udi-solaredge-poly from inside /var/polyglot/nodeservers ?

Should I be logging in as polyglot, or some other user, considering any changes are going to be assigned to admin:polyglot?

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...