Jump to content

Failed Uploading file (reported written size is invalid)


Recommended Posts

I am attempting to upgrade from firmware 5.3.1 to 5.3.4.  The process proceeds to about 9%, then I get the two popups in the attached image.  

BACKGROUND:  My ISY is a 994i/IR Pro (with 500 Z-Wave).  I do not have any Z-wave devices yet.  Today I noticed the ISY was not functioning (programs were not running).  Visual inspection revealed the red Error LED was flashing (memory LED OK) which indicates the SD card had failed.  I then went through process to replace the SD card.
1. Connected with TELNET and did FS command to format SD card. 
2. Then logged into admin console and loaded firmware 5.3.1, which was the level of the last good backup I have. 
3. After loading firmware 5.3.1, I then restored my last good backup.
4. At this point the ISY appeared to be working.  I then made a few changes that were not in the last backup file.  For example, I had changed three Motion Sensor II's from battery power to AC power.  (I removed the Battery node).
5. After making a few minor changes, I performed another backup.
6. After this, I attempted to upgrade the firmware to 5.3.4 and received the 2 errors.

1. I read on this forum that I may need to reboot the ISY.  I rebooted via the admin console but still received the 2 errors.  I then rebooted by cycling the power to the ISY but still received the 2 errors.
2. I downloaded the 5.3.4 zip file again from this forum but still received the 2 errors.
3. I downloaded the 5.3.3 zip file and tried upgrading to it.  I got the same 2 errors.  \

Does anyone have any ideas?

ISY Errors.png

Link to comment

The replacement SD card is a PNY 16GB SDHC device.  I have had this card for a year or two.  I have ordered two SanDisk Industrial 16GB cards but they will not arrive until Tuesday.  I mention this in case this card is not fast enough.


Link to comment

@EVictory Do you happen to be running any firewall or antivirus software on the computer? Disable both and try again. 

It's odd because you were able to get a version of the firmware installed, but having the issues when you're trying to upgrade. Though I can see firewall or antivirus being the cause to that. Make sure both are off.

Also, make sure that you're using the ZIP file that you downloaded of the firmware. Do not extract the files from the firmware and try to update that way. 

Did you clear java cache along the way then download a new launcher start.jnlp? Make sure you're selecting all 3 boxes in the clear cache process! (this should remove prior ISY Launcher icons)

What type of computer are you using to try this? (Win/Mac/Linux?)

The only other thing I can think of is perhaps the replacement SD card you are using was corrupt. Was it new from the package (even though you said it was a few years old) or had it been used for something else previously? 

It might be easiest to open a ticket with UD to get specific help. 


Link to comment

I am running malwarebytes AV and I disabled it and firewall on all attempts.  This is standard practice anytime I upgrade firmware.

Yes, I am using the ZIP file and not decompressing it.

Yes, I always download the launcher, dashboard, and admin jnlp files along with the firmware.

Yes, I tried clearing the java cache, all three boxes as always.

I am on a Windows 10 Pro PC.  Have used this PC many times to do upgrades in the past.

I have had the replacement SD card for a few years which is why I used the FS command to format it during the rebuild.  Right now, I suspect the SD card.  I do have new Sandisk cards on order.  They will arrive Tuesday I will try it with a brand new card.

This one has me stumped.

Link to comment

I have figured this out.

The problem was that I needed to add the Java Runtime Parameter -Xmx512m to my Java.  I had done this in the past due to slow response but had not realized the setting is removed when you upgrade from one version of Java to the next.

Now that this is figured out, I am upgrading to a faster micro SD card.  I am going to try a SanDisk Industrial 16GB card at 50/80mb/s.  The Industrial grade supposedly is tougher card. 

Thanks to all that offered help.  This forum is awesome.

Link to comment

@EVictory interesting observation and hopeful solution for this.

As an additional note if your system has a lot of memory you can change that parameter up to 1024. 

 -Xmx specifies the maximum memory size.

I haven't specifically heard of (or experienced) this setting being removed from regular Java upgrade. It might have been removed if you uninstalled Java. 

Glad you seem to be back in business though. Post back if you run into more issues.

Link to comment
2 hours ago, Geddy said:

I haven't specifically heard of (or experienced) this setting being removed from regular Java upgrade. It might have been removed if you uninstalled Java. 


I've had Java remove the memory setting during a Java update. It's best to check the setting anytime Java updates

Link to comment
15 minutes ago, gzahar said:

In my experience, it removes it every update and you have to remember to add it back

Interesting. I guess I don't really ever have issue maxing out Java. I know I've set the parameter in the past, but haven't checked after each update. Since it's normally not a problem for me I assumed it stayed in place, but just checked after a recent update and it is, in fact, gone. Shame. Glad I don't have to alter it for my system so one less thing to have to keep up with.

The parameter setting is certainly something users that experience a laggy or sluggish admin console should update. 

Hopefully for @EVictory the setting and the new SD card keep the system running as expected.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...