Jump to content

Replaced my PLM - I really need some help here...


Recommended Posts

With a number of odd problems I finally decided to just replace my PLM. I picked up a new one from the SH store plugged it in and ran the "Restore Modem (PLM)" from the ISY console (2.7.9).


Everything seemed to go fine, and I watched the event log as it ticked along for about 20 minutes. I did a few manual device restores on motion sensors, remotelincs, etc. afterwards. Everything looks fine and I can control the devices from the ISY. The little weird problems seem to also be more or less gone. So far, so good.


The problem - a big one - I'm having is that the ISY doesn't now see any device changes. I've even tried re-restoring individual devices and comparing the links, but it doesn't make any difference. If I turn a light on the ISY thinks it's still off (at least until I query it.)


The KPL buttons don't flash as they would for a missing PLM or scene device (they definitely did when I had the old PLM out), so I assume they're talking to the PLM. So what's going on? What do I do now?


I be stumped and frankly a little nervous about trying anything else. I still have the old PLM though I don't see any useful road backwards.

Link to comment

Hi ergodic,


I am so very sorry to hear this. I can think of two reasons:

1. 2.7.9's bug ... now that 2.7.10 is out, you might want to try 2.7.10, restore your 2.7.7 backup, and retry

2. But, before doing that, please go to Tools | Diagnostics | Show PLM Links Table ... if you see nothing, then, in all likelihood you have a defective PLM


With kind regards,


Link to comment

Well, I can pass along more information:


I tried restoring a few devices individually and started seeing "Failed writing" in the event log (writing on that device ID, not a pending batch write). So with nothing else to try, I rebooted the ISY. Note I did NOT repower the new PLM.


After the ISY restart I was able to restore devices with no errors, and after doing so that device would then communicate status. I can see no difference in the device link tables - they compared OK before the restart and after. I've now manually gone through them all, restoring one by one. I saw no errors (save the occasional "unexpected..." line).


Having restored all the devices including RLs and MSs, I now can do a full query on the entire house with no delays or errors - the whole thing takes about 35 seconds. Just the way it used to be. How long it will stay that way I won't know for a few days. I'm saying my prayers.


So at various times over the last couple of weeks I've speculated this was:


A comm problem,

The dreaded V.35 problem,

A bad PLM,

Corrupt link tables,

Some damage from the power failures we had.


But I'm now starting to believe that some - or most - of my issues were with the 2.7.9 update which I perfomed about the same time. The old PLM may well have had an issue that precipitated things but I'm not exactly anxious at this point to put it back in and try to find out.


There is definitely something not entirely right about the Restore PLM feature in 2.7.9. Of that I'm almost 100% positive. All I can suggest here is to try replacing the PLM in your test network or home or where ever you field test this sort of thing with one the ISY hasn't seen before and watch what happens.


The batch mode feature seems to need a little tweaking. On my menu it shows "turn batch mode on" with a greyed-out icon. But from what I see it IS in batch mode that way.


Also, batch mode tries to write RemoteLincs and Motion Sensors in the background which is sort of hopeless since these have to be put in link mode manually. I'd suggest possibly just leaving these out of the background batch write attempts.


The whole RL/MS thing is a bit of a problem in a restore PLM operation. It tells you to put all of them into link mode, which in my case at least is more or less impossible since there's quite a few and they time out of link mode long before the restore PLM is finished. Possibly just prompt for each one by name with "OK"/"Skip".


If there's a 2.7.10 ready, I'm game. I'm not going back at this point so forward is the only direction :D

Link to comment

Hi ergodic,


I am so very sorry that you had to go through all this trouble. It must have been quite disheartening.


I agree with you that 2.7.9 might have been the problem.


As far as RL/MS, you now have a choice to do them separately (the button right next to the batch mode is for battery operated devices). Please do give that a try.


With kind regards,


Link to comment


This topic is now archived and is closed to further replies.

  • Create New...