Jump to content

ISY-99 hears some KPLs, not others, talks to all


Recommended Posts

Hi Michel and others,


Running ISY-99i/IR Pro with Release 2.7.6.


Scenes working fine, and virtually all of my 6-button KPLs and toggle-linc dimmers (along with some relays) can be controlled by the ISY.


I can program the scenes through the ISY, and can read status of everything through the ISY.


But I was wondering why certain button-presses on the KPLs would not work as an "IF" condition to trigger a program. It is as if the ISY can't hear the KPL.


So, I thought, perhaps we have a communications issue. Tried plugging the ISY into the same branch circuit breaker as some of my KPLs. Guess what? It can hear some of them, but not others! (by watching the Event Viewer, and by putting the different buttons into the "IF" control... section of programs).


So I explored a little bit further into the KPLs that the ISY seems to not hear. The ISY can read their status, can put them into (and take them out of) scenes, and can remotely control them (on/off/dim/bright). As it does all of these things, you see the activity in the Event Viewer. Keep in mind that all of these actions were initiated by the ISY.


The problem is button pressing on the KPL itself. Well, the ISY does not hear a single-tap "On" or "Off" command, but (and this is indeed strange) it CAN hear a "Brighten" or "Dim" command that is sent when I hold the button down for a while. (Have not tried "fast on/fast off" double-taps yet.) And this behavior goes for both the big on/off buttons at the top and bottom of the 6-button KPLs and the four auxiliary (A-B-C-D) buttons in between.


Interestingly, on other KPLs that do not display this problem, any single-tap "On" or "Off" command is heard by the ISY and programs are triggered as would be expected, and the activity is displayed in the Event Viewer.


The "Universal Devices Administrative Console" reports the devices as "(2486D) KeypadLinc Dimmer v.2D" and is consistent for all of them -- the ones that ISY hears and the ones it doesn't hear.


If this has been addressed in later releases of the ISY-99i firmware please advise. I have not upgraded that yet because of all the various postings about the issues with 2.7.9 and I'm holding off 2.7.10 pending testing and release etc.


Curious if this is a known issue.




Link to comment

Hi Jim,


I have one question:

Do you also have symptoms such as different lights turning on/off by themselves (especially those linked to your KPL versions 2D)?


If so, I think I know the problem. Version 2D is firmware 1.5 of the KPL some of which exhibited quite strange and intermittent behavior. To verify that the problem is NOT noise, all you have to do is to swap the LOCATION (not scenes/programs and/or anything ISY related) of the working KPL with the non-working KPL. If the non-working KPL still exhibited the same issues, then for sure this is related to the KPL itself.


With kind regards,


Link to comment

Hi Michel,


Unfortunately, no, I have never experienced lights turning themselves on/off at unexplained times. Thank goodness that's not going on as well.


I will try moving them around, as you suggest, but the reasons I suspect that noise is not the issue are:

1) programming them (into and remove from scenes) not a problem.

2) controlling them from ISY: not a problem

3) holding down the button (DIM/BRIGHT) works ok, ISY hears that

4) I can reproduce the problem with the KPL and ISY connected to the same circuit breaker

5) I can show a "heard" KPL and an "ignored" KPL wired to the same branch: one works, the other doesn't.


It has to be some idiosyncratic behavior of the KPL. This scares me because I have about FORTY of the KPLs installed!





I'll let you know if/when I come up with more info.

Link to comment

I found a workaround (not the real solution) to this problem. My workaround gets me what I need, while not necessarily "fixing" the issue of some KPL button presses being "heard" by the ISY99i and others not.


To recap, the problem is that the ISY99i doesn't hear button presses from certain (some) KPLs, even though the ISY can query them just fine, and can control them just fine.


The workaround is to write two "programs" in the ISY99i. The first is a polling program which runs continuously and repeatedly "queries" the KPLs that I want to monitor. The query look program reads something like this:


Repeat every (minute? two minutes? Five... etc.)

Set 'Favorite KeypadLinc' Query

Run Program 'Adjust something else' (If)


Note that this program has no conditions, and I have it set to "Run at Startup." Thus it is a never-ending loop.


The second program, referred to as 'Adjust something else' reads something like this:



Status 'Favorite KeypadLinc Btn A' is On



Set 'Living Room Thermostat' 70 (Heat Setpoint)

Send X10...etc.



Set 'Living Room Thermostat' 65 (Heat Setpoint)

Send X10...etc.


...end code...


The "Then" and "Else" can be anything; I just used a simple example here.


What is relevant here is that every my ISY queries the KPL whose buttons I need to see, and updates its local copy of the status of that KPL's status. From there, it's easy to run appropriate programs to send Insteon or X10 commands based on those buttons.


Hope someone out there finds this useful.




Link to comment

Hi Jim,


Thanks for the update. I must say that I am not satisfied with this workaround! We need to get to the bottom of this issue.


Few questions:

1. What is the firmware version and the ID of your PLM (Tools | Diagnostics | PLM Status/Info)

2. Please go to Tools | Diagnostics | Show ISY Links Table and then choose the problematic KPL, and then click Start. Please let me know how many link records you find with the PLM ID (you found in 1) for this KPL


With kind regards,


Link to comment
  • 7 months later...

I have this same problem with 2 v.29 switchlincs. I can swear that I used to be able to hear the button presses because in the past I used them in programs. ( no longer using these programs )


I have around 50 devices and more than 35 scenes. Many of my new devices are dual-band (which marketing messages tell me should improve communication).


My primary issue is that 2 keypads button presses are not seen by the ISY. These buttons are programmable through the ISY and I have 'restored' the keypads several times to clean them out. They participate in scenes successfully.


Any ideas?

Link to comment

Hello aaronb,


Please go to Tools | Diagnostics | Event Viewer on Level 3. Turn on/off the questionable button and let's see if you get any events in the event viewer (INST-SRX).


If not, there could be three explanations:

1. The signal is not getting from the KPL to the PLM

2. The PLM has reached its link capacity and thus you are not hearing status updates


If other buttons on the same KPL work, then may I humbly recommend:

1. Removing KPL from ISY

2. Doing a factory reset on it

3. Adding it back


With kind regards,


Link to comment

I used the event viewer on level 3 and could not see any traffic from either of the two KPLs in question. They are next to each other, but I don't see how it could be a communication issue. I can program them and get their status successfully from the PLM. I have filters on nearly everything in the house.


I have a brand new PLM that I recently purchased to get the dual-band functionality. What is the link capacity and how can I see how much I am using?

Link to comment

The 2413S Dual band PLM, is 1023 links.

The later revision 2412S PLM was 2016 links, but >800 seemed to be a problem for many.

Original 2412S PLM was 417 links.




Show PLM Table

When the table is read. There is a count button on the test screen.


Note: It seems that any X10 or Insteon traffic on the power line during the test. Messes the count up.

Link to comment

Thanks Brian. I did a count and I am only at 158. So it sounds like it must be something else.


Michael suggests removing the PLM from the ISY if only some buttons on the KPL act this way. However, all the buttons on 2 kpls in the same box can't be heard by the ISY. Would the factory reset still be a good idea or a waste of time?


I don't see how this could be communication issues when I can program and control the KPLs with no issues.

Link to comment

It does not sound like a communication problem if you can reliably control the KPL load button from the ISY Admin Console. The KPL has to ACK the Insteon Direct command so two way communication seems to exist.


When an Insteon device is not presenting the Group On/Off command when the paddle/button is pressed (assuming no communication problem) it is either a missing link in the device (KPL) or the PLM. You have restored the PLM. Try restoring one of the KPLs.


The next step would be to “Show†the links in the KPL and the PLM to confirm the needed links between the KPL and PLM exist. It might be easier to follow Michel suggestion and Remove the KPL and add it back to the ISY. This would reestablish the links in both the KPL and the PLM. If the Remove/Add of the KPL does not resolve the problem, Remove/Add it again with the Event Viewer at change level 3 active to trace the link creation process during the device add.

Link to comment

I removed the KPL and re-added it. Now the PLM can see that KPL!


But now, two others that were previously working are having the same problem. :cry:


It seems like adding the new ones pushed others out


Can there be some system limit I have hit?


My PLM is 2413S v1.0

My ISY is a 99i-PRO says v92 on the about screen

~50 devices including a few motion sensors, remotelinc and triggerlincs

~36 scenes


I do have some Icon switches which are supposed to be limited to 30 scenes. Would this be the problem? No Icon switches are in every scene, but I believe the PLM is a part of every scene.

Link to comment

However, the end result is hard to explain. Deleting the KPL should have freed up the link records associated with the KPL. Adding it back would have written the new link records back into the same slots or maybe other deleted slots. It would not push otherwise active links out. Have you replaced the PLM lately.

Link to comment

It is only a guess at this point but I'm thinking something does not complete fully during that PLM change. Every link in every device that points to the PLM has to be rewritten to change the Insteon address to reflect the new PLM address and of course the links in the new PLM itself have to be established. If something in this process does not occur on either end the Insteon device will not be able to communicate paddle/button activity to the PLM.



I would feed your configuration information into the UDI tool for estimating PLM link record counts to see if it exceeds the 1000 number for the 2413 PLM. You may have to Restore the other devices that no longer communicate paddle/button activity.

Link to comment

Could a device link table like the following be the reason my PLM / ISY doesn't 'hear' a device:


0FF8 : A2 00 00.00.00 FF 1F 00

0FF0 : E2 01 00.00.00 FF 1F 01

0FF8 : 00 00 00.00.00 00 00 00


This is on an icon switch that doesn't trigger programs anymore like it is supposed to. I assume I should at least see my PLM address and not zeros.


Could this be a product of replacing my PLM errors occuring?

Link to comment

You are correct. Those link records are bad. The 00.00.00 in the first two records should contain the PLM address.


0FF8 : A2 00 00.00.00 FF 1F 00

0FF0 : E2 01 00.00.00 FF 1F 01



The rest of the information in the link records is correct.


EDIT: since it is the PLM address that is bad it raises the question about what happened when the PLM was replaced. Only way to know for sure would be to trace the PLM change process but it looks suspicious.

Link to comment

This is consistent across many devices that the PLM cannot see. I have not been able to fix this by a Restore. It has required removing and re-adding the devices. Not fun, but at least it is fixable.


Any idea how this could have happened? PLM replacement? It looks widespread in my system.


Thanks for your help in resolving my issue and helping me understand the problem.

Link to comment

I already replaced that one, but on the others I am finding, the ISY links matched the device links with a zero address.


Restore didn't help. Remove and re-added and now it has my PLM address.


I am pretty sure I did something wrong when I replaced my PLM, but will never know for certain.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...