Jump to content

Enbrighten Smart Switch - Parameter Setting


pjjameso

Recommended Posts

Okay, issue solved but will leave write up below in case it helps someone.  The issue for me was I was trying to set and query the parameter on the main page... one would think this would work but it does not.  I was able to set and query the parameters by right clicking on the first node, selecting zwave, set configuration parameters.  The set and query function worked perfectly from there....  So would assume this is a bug??  BTW the 5-60 in parameter 3 is in minutes.

------------------------------------------------------------------------------------------

Have installed a ZWave switch for my well pump. All is working correctly and Polisy added the device with no issues.  I just have a few questions as to how in Polisy to set the parameters.... or at least they dont seem to stick.  If I query  a parameter 1-3 shouldnt Polisy return the value?  I doesnt seem to do anything.  Next assuming, dangerous, that when i select a parameter eg 1 and set the value to 0, I press Set Configuration, and then Write Changes, correct? If i then query parameter 1 it does not show the value that I set....

Also Polisy showing for each Parameter it is 1 Byte (Unsigned). I was under the impression you need 4 Bytes for an integer?  A bit out of my depth of understanding at this point.  Any help would as always be appreciated.

The manual says it supports the following

  • Association Command Class (3 Groups)
  • Group 1 supports Lifeline, Basic Report
  • Group 2 supports Basic Set and is controlled with the load load
  • Group 3 support Basic Set and is controlled by pressing the Programming button
  • Each Association Group supports 5 total nodes.

Parameter 1: Product State after Power Reset
Product State after Power Reset

The following option values may be configured -:

Value    Description
0    Return to last state
1    Return to off
2    Return to on
The manufacturer defined default value is 0 (Return to last state).

This parameter has the configuration ID config_1_1 and is of type INTEGER.

Parameter 2: Energy Report Mode
Energy Report Mode

The following option values may be configured -:

Value    Description
0    Once monthly
1    Reports based on Parameter 3 setting
2    Once daily
The manufacturer defined default value is 0 (Once monthly).

This parameter has the configuration ID config_2_1 and is of type INTEGER.

Parameter 3: Energy Report Frequency
Energy Report Frequency

Values in the range 5 to 60 may be set.

The manufacturer defined default value is 5.

This parameter has the configuration ID config_3_1 and is of type INTEGER

Screenshot 2022-12-04 153654.png

 

Screenshot 2022-12-04 153844.png

14285-1_spec.pdf

Edited by pjjameso
1. Added spec sheet and parameters. 2. Solved!
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.

  • Recently Browsing

    • No registered users viewing this page.
  • Forum Statistics

    • Total Topics
      36.6k
    • Total Posts
      368k
×
×
  • Create New...