Jump to content

Plugin for Eisy to Philips Hue interface


gschoffstall
Go to solution Solved by Geddy,

Recommended Posts

Gentlemen, When attempting to get the plugin for Philips Hue via PG3x, first the link presents with a certificate issue. Next, after going there anyway and selecting HUE, it errors with failure message 404 and not loading. It references Github. Whats up? Is there a work around, or am I doing something wrong.......again?

Link to comment

@gschoffstall Would you be able to share some screen shots of these errors? What "certificate issue"? What's the reference to Github?

404 is an authentication issue. When you log into PG3x you're using the same credentials used to access Admin Console. 

How are you accessing PG3x? I use: http://eisy.local:3000/ (you might need to replace "eisy.local" with the IP address of your eisy. If you're using https://you.eisy.IP.address:3000 then you're probably getting this certificate error:

image.png

Click "Advanced" (I already had in screenshot above). Then click "Proceed to...". Then log into the web access for Polyglot (PG3x). 

Things to check:

  • Is the eisy registered with your portal account?
  • Just to be sure your portal is connected correctly try this
    • Click "System"
    • Click "Switch Portal Profile"
    • Login to current portal account
  • Make sure Admin Console is closed while added plugins (I keep typing node servers!!!)

The "More Info" button does not link to the correct location. Once you get it installed refer to this for setup if you have further issues:  https://github.com/exking/udi-hue-pg3

 

I've already got this one installed, but when I go to the hue node server plugin screen this is what I see:

image.png

 

You should be able to click on "Install" and then you should get this window:

(Make sure you SELECT A SLOT to install to using the lowest drop down marked "Select Slot"!)

image.png

 

Link to comment

@Geddy, here's what I get:

image.thumb.png.18c831c82c34dfd783dae5cd7c76966e.png

I generally tried to get to the plugins by going to Admin Console>Node Servers>Launch Polyglot V3 (PG3). That gives me the certificate error like what you show above. Going past that with Advanced, I log in. Usually without closing the console. I then pick Plugins Store and scroll to Hue. The above screen shot is what I get when trying to actually get it loaded. I also just tried by using your direct polyglot link and closing the admin console. Same difference. You said something about registering the EISY with the portal. I did try your maneuver "Switch Portal Profile". It didn't help. Thanks. 

 

Link to comment

@gschoffstall I forget that you can open PG3x dashboard from within admin console. I never go that way and just go directly to it on the browser. Shouldn't make a difference though.

Just know that if you add plugins with admin console open you'll have to restart admin console for new nodes to display in the admin console. It only picks up changes from PG3x on launch. I usually make the suggestion not to have both open/logged in at the same time. 

The 404 error is not one I've seen before. You should open a support ticket on that unless @bmercier or @bpwwer might chime in to give an idea on that error. Not sure where "AxiosError" would play into this.

 

Link to comment

@gschoffstall I never suggested to clear Java Cache. That won't work for this issue. That's only good step for admin console issues.

I think you would be best served by a support ticket. It's late in the day on Friday. If you opened a ticket now you might get a reply Sunday or Monday. 

 

In the meantime...

Just out of curiosity though try installing another free plugin (like ping).  I wonder if it's the Hue trying to install or if your system won't let anything install.

Have you successfully installed any other plugins or was hue your first attempt?

I just tried installing the Hue into a different slot and it installed without issue. My feeling is you might have a corrupt file on your system somewhere. 

Not sure when you last updated your eisy, but have you performed a full power cycle of the eisy?

  • Click the power button 6 times
  • The blue light should turn red
  • Pull the power supply cord
  • Wait 20-30 seconds
  • Plug it back in
  • Wait 2-3 minutes (maybe more)
  • Try only logging into the web dashboard (http://eisy.local:3000)
  • Attempt to install Hue - try a different slot than you've been trying.

 

Link to comment
  • Solution
5 minutes ago, gschoffstall said:

Their portal doesn't show the EISY, just the Isy994's. And my EISY doesn't show up in my devices.

HA! That might be the issue right there. If the eisy isn't registered on the portal then you can't install plugins! That's why I asked "Is the eisy registered with your portal account?"

Instructions: https://wiki.universal-devices.com/index.php?title=ISY_Portal_Installation_Instructions

Quote

ISY Portal Account Setup

There are three steps for having ISY communicate through ISY Portal:

1. Creating an account on " ISY Portal if one does not exist (click on the Create new account link). If one already exists, simply login

2. Registering ISY with your account in ISY Portal using ISY's UUID (Help | About - also included in your invoice). To do this click on the Add ISY button and copy/paste the UUID from your invoice or order notification

3. Giving permission to ISY to communicate with ISY Portal

  • Login to the Admin Console
  • Click Configuration | Portals tab
  • You will see a request for access from your account in ISY Portal
  • Approve it
  • You are done!

If you're not using the ISY994 anymore you can migrate that portal subscription over to the eisy. 

Portal Migration instructions: 

https://wiki.universal-devices.com/index.php?title=ISY_Portal_Migrate_configurations_to_a_new_ISY

 

Once you get the eisy registered in the portal it should work as expected. 

 

If you're stilling having issues start a support ticket go here: https://www.universal-devices.com/my-tickets

 

 

2 minutes ago, gschoffstall said:

And Ping gives me the same Axios 404 error.

Yep...device isn't registered with Portal. That's the issue. Once it is you should be able to install without issue.

Link to comment

@gschoffstall woohoo! That was "easy"! :)

It's my understanding that you don't need an "active" license for plugins to work. You just need to have the device registered on the portal since all installations use the portal process to assign the license. I'm like you and prefer to do most stuff local, but it is nice to have the access that the portal license adds (my family likes to use Alexa to control a few lights here and there).

For the cost of 2 years for only $39 it's a steal! (look at others that have similar offerings and they're like 10+/month. UDI offers a lot of benefit with the portal license for less than $2 per month. It's an amazing deal. Plus, with UD Mobile in active development it's even easier to do so much more from the mobile device while away from the property. But, I get it. 

Glad that worked out. Happy automating! :)

Link to comment

@ Geddy. thanks for bearing with me. I have one more question. I have configured the node for slot 1 (Since I have nothing else). Is there a "How to" on configuring the lights that are already found by the Hue Hub in the EISY Admin Console? In the console, I went to node servers > Configure and made Hue Network 1. To add lights as nodes, it looks like it wants the light's node address. Just where is that? When the hub finds them it doesn't share that information and I can't find it in the Philips mobil app.

Link to comment

@gschoffstall Have you closed/restarted Admin Console? You should NEVER have to setup anything in Admin Console as you're suggesting. If you have it could have overwritten something the node server was pushing there. 

Did you see my comment above about not having Admin Console open when you add plugins? Nodes are only added to Admin Console on launch. So if you added Hue and AC was open then you have to close and restart it. The nodes should be pushed into the primary tree of devices. It's been so long since I added mine I forget how they were entered. But you shouldn't have to do anything in Admin Console to make the lights appear in the device list. 

I put all devices that use a plugin (formerly Node Server) in a "NodeServer" folder. Just easier for my preference. 

image.png

Once the node server finds the lights they should be nodes in the plugin screen.

From the dashboard you should now have this: (disregard the number on my Nodes and your screen will say "Hue (1)")

image.png

 

Your dashboard (assuming you got the hub to connect to the plugin) should display the node count for your system and should be for all lights and rooms you might have setup previously in the Hue app. 

You can click on "Nodes" or "Details" (they take you to the same place). Then click on "Nodes" again and it should take you to a list of items it found when it synched with the hub. 

image.png

Look in the "Address" area. That should now correspond to a device in the IoX Admin Console with a "n001_" prefix. That means it is a node from node server (now plugin) in slot 1 and the address is the identifier for that device.

In the Admin Console you should see it by a common name seen in "Node Name 1". If you click on that device on the right side of the screen under that name you should see the "n001_#######" information.

 

Now...since you said you did something in Admin Console to make Hue node server 1 it might be okay just to re-launcher admin console. Or you might need to delete what you did there by clicking on that listing and clicking "Delete" at the bottom of that window. Do THAT as last resort! Just close and re-launch admin console to see if it fills in nodes/items in your device list. 

Link to comment

AAARRRRG. I have restarted the Admin console and nothing has changed. I deleted what I had entered. I closed the Admin console and went back to the store and reloaded the plugin over top of where it was (slot 1). I restarted the Admin console and, again, nothing had changed. Here's what reloading accomplished:

image.thumb.png.157478cd7fa1577b26f9fe8e643c1124.png

Selecting Node Servers and Hue, This is what I get:

image.png.d895cc22ec650b0102c71bcb7d20c20e.png

Selecting Configure gets me this:

image.png.c490ac46ebc80f1697b1e5ec2489d87f.png

And Selecting [01] to [20] gets me this:

image.png.c755cbd3159b2fc461fe877916d695f2.png

 

Sorry, I am so confused. Thanks for any suggestions. Nothing was added to my network display after the Hue plugin was loaded, even though it appeared to have loaded successfully - Both times it was tried. The only thing that has changed is that Hue was added to the Node Server list. And Query does nothing.

Link to comment

@gschoffstall what does the node server look like on the PG3x dashboard? Does it show nodes? If not then the hub hasn’t linked. If you reinstalled the plugin you might have to link the hub again. Restart the plugin then press the hub button again. 

If you have nodes being displayed on the web dashboard for Polyglot they should push to IoX when admin console is reloaded. 

You have been doing a lot of different settings changes…please make sure you haven’t altered the IoX configuration in Polyglot. Click on “IoX Configuration” then “Edit Current IoX” and make sure the IP is 127.0.0.1 (or maybe localhost). 
 

Beyond this point it might be best to get help directly from UDI. I’ve got you this far along. I’m not sure why it’s not working and they can diagnose with you to get you running. See link in a post above to start a ticket. 

Link to comment
Guest
This topic is now closed to further replies.

×
×
  • Create New...