Jump to content

Variables not updating


n4bos
Go to solution Solved by n4bos,

Recommended Posts

I'm a long-time user of an isy994i.  I have been running 5.3.4 firmware for some time.  I have a number of Insteon leak detectors in my home that are all monitored and have been working well for a number of years.  The system generates a report every night of the heartbeat verification and emails it to me so I know all the detectors are on line and working.  A few days ago, the report showed that about 8 of the leak detectors had not reported.  Assuming it was some kind of bug, I ignored it but the next day, the report showed ALL the detectors to be off line and has every day since.  Since then, I have restored the ISY to my latest (good) backup and rebooted it.  It made no difference.  If I manually FORCE a heartbeat from a detector, the LED indicates it was sent but the variables data is not incremented.  If I run the THEN portion of the heartbeat detection program, it DOES increment the stored data.  I was originally thinking maybe a bad SD card but since running the program DOES store the data, it would appear the ISY is not seeing the report from the leak detector.  My PLM is several years old so maybe that's dying?  Is this a symptom of a failing PLM?  I have a spare but it's a bit laborious to replace with all the leak detectors so I didn't want to undertake that without consulting the "experts".

So, any ideas?

Thanks,

Steve

Edited by n4bos
Link to comment
  • 1 month later...

And MORE information for those that might find this down the road....  Replacing the PLM DID "appear" to fix the problem but in a few weeks, the problem came back!  So, I suspect the PLM was NOT bad but rather, rebooting the ISY had fixed it (temporarily) earlier.  When it came back this time, I started troubleshooting and could find NO reason for the issue however, after reading several posts about the SD card becoming unreliable, I removed and reinstalled it several times, rebooted the ISY and it has now been running for several weeks with NO issue.  At this point, I would have to say I suspect the contacts on the SD card were becoming faulty and removing and reinstalling appears to have fixed it.  I DO have a second card to try if it comes back.

Hope this helps someone in the future.

Link to comment
Guest
This topic is now closed to further replies.

  • Recently Browsing

    • No registered users viewing this page.
  • Who's Online (See full list)

    • There are no registered users currently online
  • Forum Statistics

    • Total Topics
      36.6k
    • Total Posts
      368.1k
×
×
  • Create New...