Jump to content

Problem w/ I-pod touch resolved


Zellarman

Recommended Posts

When I saw that HTML was being introduced for use w/mobile devices, I got all warm and fuzzy inside, after discovering that despite apple claiming their I-pod Touch runs Java, I was unable to access my ISY's admin console through the local network, I thought this latest release would solve this issue, but it didn't. The universal devices webpage opens, and accepts my user id and password, but then only goes forward to a blank page. Is the HTML to complicated for the i-pod touch?

 

Second, I can't access my isy externally. I've followed Michel's instructions

 

 

 

The first thing I suggest is:

1. Go to https://www.universal-devices.com/ssl/insteon/

2. Login using your ISY credentials

3. Choose Generate and Install New Self Signed Certificate; this will install a new certificate in your ISY and reboots ISY

 

Doing so, will eliminate the problem of being warned all the time about the default certificate.

 

If your router is complaining about 443 already being used, it means that you already have another network device (in your LAN) which uses 443 and thus the router will only forward the requests to that device. To rectify:

1. Make sure this is the case (port 443 is forwarded to another device)

2. Change your ISY's HTTPS port

a. Telnet to ISY

b. Issue CWP

c. Change the HTTPS port to some other number. This will reboot ISY

3. Reconfigure your router (or let ISY do it for you after reboot)

4. Your remote access URL will be https://your.external.ip.address:new_https_port

 

at step 3 when I select generate and install new SSC a new window opens, wheich I've tried two different ways 1) leaving the IP that automatically appears, and 2) by using the DynDNS that was working for me before this beta version "myname.homeip.net"

 

I don't think the problem is so much within the ISY as much as it is me doing something wrong, or missing a step somewhere, but what am I doing wrong or missing?

 

Previously, to access my ISY remotely I'd enter "http://myname.homeip.net:35651/0/x" now what am I supposed to enter? Does http vs. https make a difference to DynDNS? When I try typing "https://myname.homeip.net:443/0/x" and this might be wrong anyway the 443 gets lost.

 

Also after closing my ISY and again accessing it, despite checking the save box in the window that opens when generating and installing a new certificate, I still get the warning about using the default certificate.

 

I can't seem to either assign a certificate, or access remotely.

Link to comment

Zellarman,

 

My comments below ...

 

With kind regards,

Michel

 

When I saw that HTML was being introduced for use w/mobile devices, I got all warm and fuzzy inside, after discovering that despite apple claiming their I-pod Touch runs Java, I was unable to access my ISY's admin console through the local network, I thought this latest release would solve this issue, but it didn't. The universal devices webpage opens, and accepts my user id and password, but then only goes forward to a blank page. Is the HTML to complicated for the i-pod touch?

As you already know, 2.6.1 is still in Beta; we are doing everything in our power to make it work with all phones. There have been reports that the HTML does not work on some phones (TREO/ipod) and we are resolving them.

 

Second, I can't access my isy externally. I've followed Michel's instructions

 

 

 

The first thing I suggest is:

1. Go to https://www.universal-devices.com/ssl/insteon/

2. Login using your ISY credentials

3. Choose Generate and Install New Self Signed Certificate; this will install a new certificate in your ISY and reboots ISY

 

Doing so, will eliminate the problem of being warned all the time about the default certificate.

 

If your router is complaining about 443 already being used, it means that you already have another network device (in your LAN) which uses 443 and thus the router will only forward the requests to that device. To rectify:

1. Make sure this is the case (port 443 is forwarded to another device)

2. Change your ISY's HTTPS port

a. Telnet to ISY

b. Issue CWP

c. Change the HTTPS port to some other number. This will reboot ISY

3. Reconfigure your router (or let ISY do it for you after reboot)

4. Your remote access URL will be https://your.external.ip.address:new_https_port

 

at step 3 when I select generate and install new SSC a new window opens, wheich I've tried two different ways 1) leaving the IP that automatically appears, and 2) by using the DynDNS that was working for me before this beta version "myname.homeip.net"

 

 

I don't think the problem is so much within the ISY as much as it is me doing something wrong, or missing a step somewhere, but what am I doing wrong or missing?

Does ISY reboot after this step?

 

Previously, to access my ISY remotely I'd enter "http://myname.homeip.net:35651/0/x" now what am I supposed to enter? Does http vs. https make a difference to DynDNS? When I try typing "https://myname.homeip.net:443/0/x" and this might be wrong anyway the 443 gets lost.

Would you be kind enough to telnet to your ISY, issue CWP, and let me know what ports it uses for both HTTP and HTTPS?

 

Also after closing my ISY and again accessing it, despite checking the save box in the window that opens when generating and installing a new certificate, I still get the warning about using the default certificate.

 

I can't seem to either assign a certificate, or access remotely.

 

see above.

Link to comment

Michel, I saw the same blank page while accessing my ISY through my local network using my laptop. I would do the same steps as Zellarman and once I logged in I would end up at a blank web page at http://local IP/1/a.

 

If you simply select the Administative Console without logging in, then the Java Aministative Console is launched correctly.

 

I decided that I didn't ever want to see the Devices or Scenes locally and switched to a http://local IP/0/p address to launch the Administrative Console automatically.

Link to comment

The first thing I suggest is:

1. Go to https://www.universal-devices.com/ssl/insteon/

2. Login using your ISY credentials

3. Choose Generate and Install New Self Signed Certificate; this will install a new certificate in your ISY and reboots ISY

 

Doing so, will eliminate the problem of being warned all the time about the default certificate.

 

If your router is complaining about 443 already being used, it means that you already have another network device (in your LAN) which uses 443 and thus the router will only forward the requests to that device. To rectify:

1. Make sure this is the case (port 443 is forwarded to another device)

2. Change your ISY's HTTPS port

a. Telnet to ISY

b. Issue CWP

c. Change the HTTPS port to some other number. This will reboot ISY

3. Reconfigure your router (or let ISY do it for you after reboot)

4. Your remote access URL will be https://your.external.ip.address:new_https_port

 

at step 3 when I select generate and install new SSC a new window opens, wheich I've tried two different ways 1) leaving the IP that automatically appears, and 2) by using the DynDNS that was working for me before this beta version "myname.homeip.net"

 

 

I don't think the problem is so much within the ISY as much as it is me doing something wrong, or missing a step somewhere, but what am I doing wrong or missing?

Does ISY reboot after this step?

NO, ISY does not reboot after step 3

 

Previously, to access my ISY remotely I'd enter "http://myname.homeip.net:35651/0/x" now what am I supposed to enter? Does http vs. https make a difference to DynDNS? When I try typing "https://myname.homeip.net:443/0/x" and this might be wrong anyway the 443 gets lost.

Would you be kind enough to telnet to your ISY, issue CWP, and let me know what ports it uses for both HTTP and HTTPS?

HTTP port 80, & HTTPS port 443 Since when trying to access the ISY externally, my computer was imediately dropping the :443 but not 444 or 442, I changed the HTTPS port number using CWP to 444, then tried generating and installing a self signed certificate. Still no reboot, or external access.

 

Also after closing my ISY and again accessing it, despite checking the save box in the window that opens when generating and installing a new certificate, I still get the warning about using the default certificate.

 

I can't seem to either assign a certificate, or access remotely.

Link to comment

Hello d_l,

 

This is quite odd ... is this on your regular laptop? There are a few bugs which we're trying to fix and we'll look into this one as well.

 

With kind regards,

Michel

 

Michel, I saw the same blank page while accessing my ISY through my local network using my laptop. I would do the same steps as Zellarman and once I logged in I would end up at a blank web page at http://local IP/1/a.

 

If you simply select the Administative Console without logging in, then the Java Aministative Console is launched correctly.

 

I decided that I didn't ever want to see the Devices or Scenes locally and switched to a http://local IP/0/p address to launch the Administrative Console automatically.

Link to comment

Zellarman,

 

What operating system are you using (Vista)?

 

If you don't mind, please:

1. Go to https://www.universal-devices.com/ssl/insteon

2. Click on Generate and Install a Self Signed Certificate

3. Choose the "Save" check box

4. When prompted, save your certificate

5. Then choose Install and Existing Certificate

 

Please let me know if your ISY reboots.

 

As far as port 443, it is the default port for HTTPS and that's why your computer drops it. Have you checked your router to see if any other devices in your network are port forwarded to 443?

 

With kind regards,

Michel

Link to comment

Michel, yes this is on my regular laptop. That is the only computer I've ever used to access my ISY. This blank page problem is when using Netscape 7.2 which I use regularly. I just tested with IE 6.0 and it works properly and doesn't give the blank page. So maybe the problem is something with Java and that version of Netscape.

 

 

Hello d_l,

 

This is quite odd ... is this on your regular laptop? There are a few bugs which we're trying to fix and we'll look into this one as well.

 

With kind regards,

Michel

 

Link to comment

Hi Dave,

 

Thanks!

 

We did find some stray html tags which caused problems on ipod and treo so I wonder if this is the same issue!

 

With kind regards,

Michel

 

Michel, yes this is on my regular laptop. That is the only computer I've ever used to access my ISY. This blank page problem is when using Netscape 7.2 which I use regularly. I just tested with IE 6.0 and it works properly and doesn't give the blank page. So maybe the problem is something with Java and that version of Netscape.

 

 

Hello d_l,

 

This is quite odd ... is this on your regular laptop? There are a few bugs which we're trying to fix and we'll look into this one as well.

 

With kind regards,

Michel

 

Link to comment
Zellarman,

 

What operating system are you using (Vista)?

Windows XP

 

If you don't mind, please:

1. Go to https://www.universal-devices.com/ssl/insteon

2. Click on Generate and Install a Self Signed Certificate

3. Choose the "Save" check box

4. When prompted, save your certificate

Nothing happens! I'm gonna bet this is my problem. When I select save, or not, nothing happens. I'm not prompeted to select where to save it or anything. When I select OK, the window just closes. Once, I was asked about the "bouncy castle" certificate, but that's it.

5. Then choose Install and Existing Certificate

since I was unable to successfully save the cert. I can't find it anywhere!

 

Please let me know if your ISY reboots.

NO, my ISY has never rebooted on any of my numerous tries to assign a certificate

As far as port 443, it is the default port for HTTPS and that's why your computer drops it. Have you checked your router to see if any other devices in your network are port forwarded to 443?

Despite not having any devices other than my router, laptop, and ISY, I still looked around on my router, to see if I could find anything on 444, this is what I've been going with since reassigning the port. Is that OK?

Link to comment

Hello Zellarman,

 

Did you accept to run the Bouncy Castle package? This is the free encryption package. If not, please go to Java Control Panel, click on security, delete this certificate, and retry (make sure you close all your browsers before doing so).

 

Yes, port 444 is fine ... if you cannot find anything for port 443, then I would assume that that port is also OK. If you can tell me what's the actual error on port 443, then I might be able to better help out.

 

With kind regards,

Michel

 

 

Zellarman,

 

What operating system are you using (Vista)?

Windows XP

 

If you don't mind, please:

1. Go to https://www.universal-devices.com/ssl/insteon

2. Click on Generate and Install a Self Signed Certificate

3. Choose the "Save" check box

4. When prompted, save your certificate

Nothing happens! I'm gonna bet this is my problem. When I select save, or not, nothing happens. I'm not prompeted to select where to save it or anything. When I select OK, the window just closes. Once, I was asked about the "bouncy castle" certificate, but that's it.

5. Then choose Install and Existing Certificate

since I was unable to successfully save the cert. I can't find it anywhere!

 

Please let me know if your ISY reboots.

NO, my ISY has never rebooted on any of my numerous tries to assign a certificate

As far as port 443, it is the default port for HTTPS and that's why your computer drops it. Have you checked your router to see if any other devices in your network are port forwarded to 443?

Despite not having any devices other than my router, laptop, and ISY, I still looked around on my router, to see if I could find anything on 444, this is what I've been going with since reassigning the port. Is that OK?

Link to comment

Hello Zellarman,

 

Did you accept the Bouncy Castle certificate? This is the free encryption package. If not, please go to Java Control Panel, click on security, delete this certificate, and retry (make sure you close all your browsers before doing so).

 

Yes, port 444 is fine ... if you cannot find anything for port 443, then I would assume that that port is also OK. If you can tell me what's the actual error on port 443, then I might be able to better help out.

 

With kind regards,

Michel

 

 

Zellarman,

 

What operating system are you using (Vista)?

Windows XP

 

If you don't mind, please:

1. Go to https://www.universal-devices.com/ssl/insteon

2. Click on Generate and Install a Self Signed Certificate

3. Choose the "Save" check box

4. When prompted, save your certificate

Nothing happens! I'm gonna bet this is my problem. When I select save, or not, nothing happens. I'm not prompeted to select where to save it or anything. When I select OK, the window just closes. Once, I was asked about the "bouncy castle" certificate, but that's it.

5. Then choose Install and Existing Certificate

since I was unable to successfully save the cert. I can't find it anywhere!

 

Please let me know if your ISY reboots.

NO, my ISY has never rebooted on any of my numerous tries to assign a certificate

As far as port 443, it is the default port for HTTPS and that's why your computer drops it. Have you checked your router to see if any other devices in your network are port forwarded to 443?

Despite not having any devices other than my router, laptop, and ISY, I still looked around on my router, to see if I could find anything on 444, this is what I've been going with since reassigning the port. Is that OK?

Link to comment

Did you accept the Bouncy Castle certificate? This is the free encryption package. If not, please go to Java Control Panel, click on security, delete this certificate, and retry (make sure you close all your browsers before doing so).

 

Yes, port 444 is fine ... if you cannot find anything for port 443, then I would assume that that port is also OK. If you can tell me what's the actual error on port 443, then I might be able to better help out.

I successfully deleted the current certificates, (there's actually 2 in the java command console) and reloaded them, they take when I select generate and install, but I'm never prompted to aks where to save them when I select save, and the ISY never reboots. I still get the warning about the default certificate.

 

I've also noticed now that the UDI administrative console hangs up when left unattended for a while. The tab remains on my screen but the window doesn't restore when selected, and I have to use control panel to close the unresponsive program.

Link to comment

Zellarman,

 

Quite interesting! Although you are using XP, what you're witnessing (at least up to now) is all Vista related (not having enough permission to save the file and thus never installing it). Have you tried this operation from another computer?

 

With kind regards,

Michel

 

Did you accept the Bouncy Castle certificate? This is the free encryption package. If not, please go to Java Control Panel, click on security, delete this certificate, and retry (make sure you close all your browsers before doing so).

 

Yes, port 444 is fine ... if you cannot find anything for port 443, then I would assume that that port is also OK. If you can tell me what's the actual error on port 443, then I might be able to better help out.

I successfully deleted the current certificates, (there's actually 2 in the java command console) and reloaded them, they take when I select generate and install, but I'm never prompted to aks where to save them when I select save, and the ISY never reboots. I still get the warning about the default certificate.

 

I've also noticed now that the UDI administrative console hangs up when left unattended for a while. The tab remains on my screen but the window doesn't restore when selected, and I have to use control panel to close the unresponsive program.

Link to comment
  • 1 month later...

My apologies for not responding for so long, and unfortunately, as of yet I've been unable to try this with a different computer. My budget limit's my available toys, and right now all money goes to primarily Insteon related stuff, and not computers. I will still try and borrow somebody's laptop so I can answer your question.

Link to comment

Zellarman,

 

My apologies for putting this burden on you. You can also send your URL/credentials to support@universal-devices.com and we'll check it out from here and let you know the outcome.

 

Have you tried clearing the Java cache?

 

With kind regards,

Michel

 

My apologies for not responding for so long, and unfortunately, as of yet I've been unable to try this with a different computer. My budget limit's my available toys, and right now all money goes to primarily Insteon related stuff, and not computers. I will still try and borrow somebody's laptop so I can answer your question.
Link to comment
  • 1 month later...

Running 2.6.4 now. I enabled internet access, and wasn't asked to do anything w/ a certificate, I guess it resolved itself in the latest update. I am now able to access my ISY w/the i-pod touch through the local network (no admin b/c touch doesn't run java, but the other html pages work like a charm) who woulda thunk I'd be able to control my lights w/ an i-pod!

Link to comment

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...