Jump to content

Unable to launch the application


Recommended Posts

I installed an update to Java earlier today, and now I am no longer able to launch the 99i administrative console from my desktop shortcut. If I open a browser and enter the ip address of the ISY, I have no problem getting to the administrative console. when I use the shortcut, I get an application error. If I click on the Details button, I get the following under the Launch File tab:

99i Administrative Console

Universal Devices, Inc.

Configuration Utility for ISY99i Series

99i Administrative Console


If I select the Exception tab, I get the following:


at com.sun.javaws.security.JNLPSignedResourcesHelper.checkSignedResourcesHelper(Unknown Source)

at com.sun.javaws.security.JNLPSignedResourcesHelper.checkSignedResources(Unknown Source)

at com.sun.javaws.Launcher.prepareResources(Unknown Source)

at com.sun.javaws.Launcher.prepareAllResources(Unknown Source)

at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)

at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)

at com.sun.javaws.Launcher.launch(Unknown Source)

at com.sun.javaws.Main.launchApp(Unknown Source)

at com.sun.javaws.Main.continueInSecureThread(Unknown Source)

at com.sun.javaws.Main$1.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

How do I fix this? I have tried uninstalling Java and reinstalling Java, but it makes no difference.

Link to comment

Delete your old icon.


Open a browser and go to: http:///admin/admin.jnlp Accept any certificates and/or confirm any security exceptions and save the resulting file to your desktop or other preferred location.


Hope this helps.



Link to comment
:D Xathros - It worked like a champ. What do you suppose was the problem?



Not sure but I suspect that after the java uninstall/reinstall, you needed to set the security exception or accept the certificate.



Link to comment
Now I have another question. How do I add the other ISY's that are off my network so I can get to them via the admin console?


I haven't tried this myself as I only have my ISY to play with but I believe you can follow the same procedure I gave you above but using the internet reachable addresses for the other ISYs and save the AdminConsole with a different filename.


:cry: Michel - That doesn't work for me. See the start of this thread.


If you are still getting security failures when accessing the URL the Michel provided, I suspect you have an old or damaged certificate that needs to be deleted and re-accepted.

Go into the Java control panel:

Security Tab

Click the Certificates button

Select "Trusted Certificates"

User Tab

Remove anything from Universal Devices, Inc.

Close and apply your way out of the Java control panel


Try Michel's URL again.


This WILL mean you will need to re-accept the cert for your local admin console as well.


You might also want to look at this: viewtopic.php?p=68358#p68358





Link to comment

Xathros -

I have tried your suggestion, but it makes no difference. I still get the same error when I use Michel's URL. Your URL got me the administrative console to connect to the ISY on premises. However, I have 2 other loctions with ISYs I have to manage, and I really would like to have the interface woirk the way it is supposed to.

Link to comment



It may make more sense at this point to open a ticket with UDI support so they can remote into your system and see whats going on. There is a link to submit a ticket at the bottom of any of Michel's posts.



Link to comment


This topic is now archived and is closed to further replies.

  • Create New...